Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Печать свойств номенклатуры (помогите!)

GeorgeSPb
читатель
офлайн
Дата регистрации: 19.08.2003
Сообщений: 9
Пост №1
 
19.08.2003 01:03

Задача:

Согласно п. 12 Закона о защите потребителей достаточно иметь в накладной указания на сертификаты и т.п. Каждому товару я через механизм свойств занес информацию о сертификации.

Вопрос:

Как в форме накладной добавить значения свойств номенклатуры? Какой нужен код и какой код в форме документа?



P.S.

Мне уже делали аналогичную операцию, но только со свойствами контрагентов. Но изменить код я не смог.

vela
читатель
офлайн
Дата регистрации: 18.08.2003
Сообщений: 20
Пост №2
 
19.08.2003 09:49

Немного пространный вопрос.

Программист, поэтому в механизмах торговли разбираюсь не особо. Но насколько знаю накладных разных видов много. Из какого именно документа печатается? В какую область накладной нужно выводить желаемую информацию? Это все немаловажно для определения формы, места размещения и содержания кода.

GeorgeSPb
читатель
офлайн
Дата регистрации: 19.08.2003
Сообщений: 9
Пост №3
 
19.08.2003 10:50

"Спасибо за внимание. Подробнее напишу..



У меня сейчас есть функция, которую я использую при печати накладной счета и т.д.



Функция глПечатьСвойстваКлиента(Конт,ИмяСвойства) Экспорт;

      

Стр = """";



Спр = СоздатьОбъект("Справочник.СвойстваКонтрагентов");

Спр.ИспользоватьВладельца(Конт.Клиент);

Спр.ВыбратьЭлементы();

Пока (Спр.ПолучитьЭлемент() = 1) Цикл      



Если (ИмяСвойства = СокрЛП(Спр.ВидСвойства.Наименование)) Тогда



Стр = Стр + СокрЛП(Строка(Спр.ЗначениеСвойства)) + ";";

КонецЕсли;

КонецЦикла;



Возврат Стр;

КонецФункции      





Я ее вставляю в форму документа в шапку, перед табличной частью:



В документах после полей наименование и адрес контрагента, вставляетяс информация о категории цены, отсрочке и виде контрагента, которая хранится как свойства контрагента.



Вид покупателя : [глПечатьСвойстваКлиента(Контекст,"Вид покупателя")] Категория цены : [глПечатьСвойстваКлиента(Контекст,"Вид цены")] Отсрочка платежа : [глПечатьСвойстваКлиента(Контекст,"Отсрочка платежа")]



И вот тоже самое мне надо для НОМЕКЛАТУРЫ, а вставлять эту инормацию буду в табличную часть документа



Пример:



Деталь № 007 Сертификат РОСС.564.875 срок 01.01.2003 - 01.01.2005. и далее в колонках пойдет количество цена и т.д."

Zuf
читатель
офлайн
Дата регистрации: 20.06.2003
Сообщений: 17
Пост №4
 
19.08.2003 17:16

"Создай такую функцию в глобалке

Функция глПечатьСвойстваНоменклатуры(Конт,ИмяСвойства) Экспорт;



Стр = """";



Спр = СоздатьОбъект("Справочник.СвойстваНоменклатуры");

Спр.ИспользоватьВладельца(Конт.Номенклатура);

Спр.ВыбратьЭлементы();

Пока (Спр.ПолучитьЭлемент() = 1) Цикл



Если (ИмяСвойства = СокрЛП(Спр.ВидСвойства.Наименование)) Тогда



Стр = Стр + СокрЛП(Строка(Спр.ЗначениеСвойства)) + ";";

КонецЕсли;

КонецЦикла;



Возврат Стр;

КонецФункции

Дальше все аналогично, вызываешь функцию с параметрами и получаешь свойство"

GeorgeSPb
читатель
офлайн
Дата регистрации: 19.08.2003
Сообщений: 9
Пост №5
 
19.08.2003 19:54

Спасибо, завтра попробую. Но вопрос: что собой представляет параметр "Конт"? Строка в печтной форме выглядит "Товар.Наименование". "Конт" заменит на "Товар"?

Zuf
читатель
офлайн
Дата регистрации: 20.06.2003
Сообщений: 17
Пост №6
 
20.08.2003 09:58

"Тогда сделай так

Функция глПечатьСвойстваНоменклатуры(Номенклатура,ИмяСвойства) Экспорт;



Стр = """";



Спр = СоздатьОбъект("Справочник.СвойстваНоменклатуры");

Спр.ИспользоватьВладельца(Номенклатура);

Спр.ВыбратьЭлементы();

Пока (Спр.ПолучитьЭлемент() = 1) Цикл



Если (ИмяСвойства = СокрЛП(Спр.ВидСвойства.Наименование)) Тогда



Стр = Стр + СокрЛП(Строка(Спр.ЗначениеСвойства)) + ";";

КонецЕсли;

КонецЦикла;



Возврат Стр;

КонецФункции



В качестве параметров передаешь непосредственно номенклатуру и значение свойства например "Сертификат". Успехов."

vela
читатель
офлайн
Дата регистрации: 18.08.2003
Сообщений: 20
Пост №7
 
20.08.2003 10:04

Конт - это контекст документа, т.е. в процедуру/функцию глобального модуля как бы передается документ. Через этот параметр можно обращаться к реквизитам документа. Exp.: Конт.ДатаДок вернет дату документа из которого вызвана процедура/функция. На будущее.

GeorgeSPb
читатель
офлайн
Дата регистрации: 19.08.2003
Сообщений: 9
Пост №8
 
20.08.2003 14:39

Документ работает!



СПАСИБО всем, кто отозвался на мой вопрос.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги