Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Особенности использования документа в качестве реквизита табличной части другого документа

Zlata
читатель
офлайн
Дата регистрации: 15.08.2002
Сообщений: 124
Пост №1
 
20.08.2003 06:24

"Здравствуйте!!!

В качестве реквизита табличной части одного документа(хозяина), я использую другой документ(рабочий). Мне это необходимо, что бы собрать документы с одинаковыми реквизитами, но формирующими операции и проводки за разные даты в одном месте. И теперь мне нужно из документа-хозяина провести все его документы-рабочие, в модуле проведения, как известно нельзя вообще использовать иетод Провести(). Пытаюсь в модуле формы документа-хозяина, уже и в отдельную обработку вывела, выглядит это так:

из модуля формы документа-хозяина делаю вызов

ОткрытьФормуМодально("Обработка.ПроведениеДоков",Контекст);

а в этой форме нехитрый алгоритм:

Док_хозяин=Форма.Параметр;

Док_хозяин.ВыбратьСтроки();

Пока Док_хозяин.ПолучитьСтроку()=1 Цикл

Док_рабочий=Док_хозяин.Ремонт;

Сообщить(Док_рабочий.Выбран());

Док_рабочий.Провести();

КонецЦикла;

а программа ругается:

1

Док_рабочий.Провести();

{Обработка.ПроведениеДоков.Форма.Модуль(8)}: Не выбран документ!

хотя единичку рисует %((, т.е. на самом деле документ выбран, так же не работает метод Записать(), хотя менять реквизиты документа- рабочего программа позволяет, а на вот эти методы ругается, в чем же дело???

Заранее благодарна, Злата.



"

vela
читатель
офлайн
Дата регистрации: 18.08.2003
Сообщений: 20
Пост №2
 
20.08.2003 08:05

"Немного некорректно. Документ не спозиционирован, ты пытаешься провести простую переменную.

Не нужно ничего осложнять обработками, просто поправь:



Док_хозяин=Форма.Параметр;

Док_рабочий=СоздатьОбъект("Документ.РабочийКПримеру");

Док_хозяин.ВыбратьСтроки();

Пока Док_хозяин.ПолучитьСтроку()=1 Цикл

Если Док_рабочий.НайтиДокумент(Док_хозяин.Ремонт)=1 Тогда

Док_рабочий.Провести();

КонецЕсли;

КонецЦикла;





"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги