Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Непонятная ошибка при поиске в таблице значений

SAP
читатель
офлайн
Дата регистрации: 06.06.2003
Сообщений: 58
Пост №1
 
25.08.2003 11:14

"Выполняю следующий отчет:<br><br><br><br>Процедура Сформировать()<br><br> <br><br> ТекстЗапроса = <br><br> "//{{ЗАПРОС(Запрос)<br><br> |Период с Дата1 по Дата2;<br><br> |Сотрудник      = ЖурналРасчетов.Зарплата.Объект;<br><br> |ДатаНачала = ЖурналРасчетов.Зарплата.ДатаНачала;<br><br> |ДатаОкончания = ЖурналРасчетов.Зарплата.ДатаОкончания;<br><br> |ВидРасчета = ЖурналРасчетов.Зарплата.ВидРасч;<br><br> |<br><br> |Группировка Сотрудник Без Групп Упорядочить по Сотрудник.Наименование;<br><br> |Условие(ВидРасчета.ВходитВГруппу(ГруппаРасчетов.Отпуска)=1);<br><br> |"//}}ЗАПРОС<br><br> ; <br><br> <br><br> Запрос = СоздатьОбъект("Запрос");<br><br> Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда<br><br> Сообщить("Ошибка выполнения запроса","!");<br><br> Возврат;<br><br> КонецЕсли;<br><br> <br><br> СпрСотр=СоздатьОбъект("Справочник.Сотрудники");<br><br> <br><br> Таблица=СоздатьОбъект("Таблица");<br><br> Таблица.ИсходнаяТаблица("Таблица");<br><br><br><br> Если Были=1 тогда<br><br> Таблица.ВывестиСекцию("Шапка<");<br><br> Таблица.ВывестиСекцию("Заголовок1");<br><br> Таблица.ВывестиСекцию("Шапка>");<br><br> Пока Запрос.Группировка("Сотрудник")=1 Цикл<br><br> П1=Запрос.Сотрудник.Код;<br><br> П2=Запрос.Сотрудник;<br><br> П3=Запрос.ВидРасчета.Наименование;<br><br> П4=Запрос.ДатаНачала;<br><br> П5=Запрос.ДатаОкончания;<br><br> Таблица.ВывестиСекцию("СтрокаОтчета");<br><br> КонецЦикла;<br><br> Иначе<br><br> Таблица.ВывестиСекцию("Шапка<");<br><br> Таблица.ВывестиСекцию("Заголовок2");<br><br> Таблица.ВывестиСекцию("Шапка>");<br><br> Таб=СоздатьОбъект("ТаблицаЗначений");<br><br> Таб.НоваяКолонка("Сотрудник");<br><br> Запрос.Выгрузить(Таб);<br><br> <br><br> СпрСотр.ВыбратьЭлементы();<br><br> <br><br> Пока СпрСотр.ПолучитьЭлемент()=1 Цикл<br><br> Стр=0;<br><br> Кол=0;<br><br> Если Таб.НайтиЗначение(СпрСотр,Стр,Кол)=0 тогда<br><br><br><br>Насколько я понимаю, в этом месте метод Таб.НайтиЗначение(СпрСотр,Стр,Кол) должен возвращать 1 если найден соответствующий элемент справочника сотрудники. Тем не менее 1 возвращается для всех сотрудников, хотя абсолютно точно известно, что в таблице имеются не все сотрудники. Подскажите, где моя ошибка.<br><br><br><br> П1=СпрСотр.Код;<br><br> П2=СпрСотр;<br><br> П3="""";<br><br> П4="""";<br><br> П5="""";<br><br> Таблица.ВывестиСекцию("СтрокаОтчета");<br><br> КонецЕсли;<br><br> КонецЦикла;<br><br> КонецЕсли;<br><br> <br><br> Таблица.ТолькоПросмотр(1);<br><br> Таблица.Опции(0, 0, 0, 0, 0);<br><br> Таблица.ПараметрыСтраницы(2,,,0,0,0,0);<br><br> Таблица.Показать("Отчет по отпускам");<br><br> <br><br>КонецПроцедуры<br><br>"

Dag
новичок
офлайн
Пост №2
 
25.08.2003 12:09

Попробуй <br><br>Если Таб.НайтиЗначение(СпрСотр.ТекущийЭлемент()</b>,Стр,Кол)=0 тогда <br><br>

SAP
читатель
офлайн
Дата регистрации: 06.06.2003
Сообщений: 58
Пост №3
 
26.08.2003 12:26

Обходные пути есть, но хотелось бы разобраться в сути происходящего.

Dag
новичок
офлайн
Пост №4
 
26.08.2003 13:43

В таблице значений у вас хранятся ссылки на элементы справочника. Поэтому в параметрах поиска вы тоже должны явным образом указать именно элемент справочника, а не сам справочник - даже если текущая запись в нем и является критерием для поиска.

SAP
читатель
офлайн
Дата регистрации: 06.06.2003
Сообщений: 58
Пост №5
 
28.08.2003 10:59

А, ну да, спасибо, разобрался :)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00, все желающие)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С