Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Непонятная ошибка при поиске в таблице значений

SAP
читатель
офлайн
Дата регистрации: 06.06.2003
Сообщений: 58
Пост №1
 
25.08.2003 11:14

"Выполняю следующий отчет:



Процедура Сформировать()



ТекстЗапроса =

"//{{ЗАПРОС(Запрос)

|Период с Дата1 по Дата2;

|Сотрудник      = ЖурналРасчетов.Зарплата.Объект;

|ДатаНачала = ЖурналРасчетов.Зарплата.ДатаНачала;

|ДатаОкончания = ЖурналРасчетов.Зарплата.ДатаОкончания;

|ВидРасчета = ЖурналРасчетов.Зарплата.ВидРасч;

|

|Группировка Сотрудник Без Групп Упорядочить по Сотрудник.Наименование;

|Условие(ВидРасчета.ВходитВГруппу(ГруппаРасчетов.Отпуска)=1);

|"//}}ЗАПРОС

;



Запрос = СоздатьОбъект("Запрос");

Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда

Сообщить("Ошибка выполнения запроса","!");

Возврат;

КонецЕсли;



СпрСотр=СоздатьОбъект("Справочник.Сотрудники");



Таблица=СоздатьОбъект("Таблица");

Таблица.ИсходнаяТаблица("Таблица");



Если Были=1 тогда

Таблица.ВывестиСекцию("Шапка<");

Таблица.ВывестиСекцию("Заголовок1");

Таблица.ВывестиСекцию("Шапка>");

Пока Запрос.Группировка("Сотрудник")=1 Цикл

П1=Запрос.Сотрудник.Код;

П2=Запрос.Сотрудник;

П3=Запрос.ВидРасчета.Наименование;

П4=Запрос.ДатаНачала;

П5=Запрос.ДатаОкончания;

Таблица.ВывестиСекцию("СтрокаОтчета");

КонецЦикла;

Иначе

Таблица.ВывестиСекцию("Шапка<");

Таблица.ВывестиСекцию("Заголовок2");

Таблица.ВывестиСекцию("Шапка>");

Таб=СоздатьОбъект("ТаблицаЗначений");

Таб.НоваяКолонка("Сотрудник");

Запрос.Выгрузить(Таб);



СпрСотр.ВыбратьЭлементы();



Пока СпрСотр.ПолучитьЭлемент()=1 Цикл

Стр=0;

Кол=0;

Если Таб.НайтиЗначение(СпрСотр,Стр,Кол)=0 тогда



Насколько я понимаю, в этом месте метод Таб.НайтиЗначение(СпрСотр,Стр,Кол) должен возвращать 1 если найден соответствующий элемент справочника сотрудники. Тем не менее 1 возвращается для всех сотрудников, хотя абсолютно точно известно, что в таблице имеются не все сотрудники. Подскажите, где моя ошибка.



П1=СпрСотр.Код;

П2=СпрСотр;

П3="""";

П4="""";

П5="""";

Таблица.ВывестиСекцию("СтрокаОтчета");

КонецЕсли;

КонецЦикла;

КонецЕсли;



Таблица.ТолькоПросмотр(1);

Таблица.Опции(0, 0, 0, 0, 0);

Таблица.ПараметрыСтраницы(2,,,0,0,0,0);

Таблица.Показать("Отчет по отпускам");



КонецПроцедуры

"

Dag
новичок
офлайн
Пост №2
 
25.08.2003 12:09

Попробуй

Если Таб.НайтиЗначение(СпрСотр.ТекущийЭлемент(),Стр,Кол)=0 тогда

SAP
читатель
офлайн
Дата регистрации: 06.06.2003
Сообщений: 58
Пост №3
 
26.08.2003 12:26

Обходные пути есть, но хотелось бы разобраться в сути происходящего.

Dag
новичок
офлайн
Пост №4
 
26.08.2003 13:43

В таблице значений у вас хранятся ссылки на элементы справочника. Поэтому в параметрах поиска вы тоже должны явным образом указать именно элемент справочника, а не сам справочник - даже если текущая запись в нем и является критерием для поиска.

SAP
читатель
офлайн
Дата регистрации: 06.06.2003
Сообщений: 58
Пост №5
 
28.08.2003 10:59

А, ну да, спасибо, разобрался :)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги