Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Зачет аванса Бюджет 624

Валерий-НВ
читатель
офлайн
Дата регистрации: 19.11.2007
Сообщений: 13
Пост №1
 
21.07.2008 21:45

"Бюджетка релиз 624, модуль формы документа ЗачетАвансаВыданного<br>Процедура ЗаполнитьНаОсновании()<br>выполняется нормально до вот этой процедуры:<br><br>Процедура ДозаполнитьТабЧ()       <br> СпСчетов = СоздатьОбъект("СписокЗначений");<br> ДопТ = СоздатьОбъект("ТаблицаЗначений");<br> ДопТ.НоваяКолонка("Счет","Счет");<br> ДопТ.НоваяКолонка("Сумма","Число");<br> ТабЧ.ВыбратьСтроки();<br> Пока ТабЧ.ПолучитьСтроку() = 1 Цикл<br> ДопТ.НоваяСтрока();<br> ДопТ.Счет = ТабЧ.СчетАванса;<br> ДопТ.Сумма = ТабЧ.Сумма;<br><br> ДопТ.НоваяСтрока();<br> ДопТ.Счет = ТабЧ.СчетРасчета;<br> ДопТ.Сумма = ТабЧ.Сумма;<br> КонецЦикла; <br> ДопТ.Свернуть("Счет","Сумма");<br> ДопТ.Выгрузить(СпСчетов,,,"Счет");<br> <br> БИт = СоздатьОбъект("БухгалтерскиеИтоги");<br> БИт.Рассчитать(ДатаДок,ДатаДок,СпСчетов,0,ПланыСчетов.ЕПСБУ,ВыбраннаяФирма);<br> БИт.Актуальность(1);<br> <br> ТабЧ.ВыбратьСтроки();<br> Пока ТабЧ.ПолучитьСтроку() = 1 Цикл<br> ТекСуммаР = ТабЧ.Сумма;<br> ТекСуммаАв = БИт.СКД(ТабЧ.СчетАванса,"С",,ТабЧ.ФКР,,Контрагент,ТабЧ.Субконто4,ТабЧ.Субконто5); <br> ТекОстР = БИт.СКК(ТабЧ.СчетРасчета,"С",,ТабЧ.ФКР,,Контрагент,ТабЧ.Субконто4,ТабЧ.Субконто5);<br> СуммаЗач = Мин(ТекСуммаР,ТекСуммаАв,ТекОстР);<br> ТабЧ.Сумма = СуммаЗач;<br> КонецЦикла; <br> БИт.Актуальность(0);             <br>КонецПроцедуры // ДозаполнитьТабЧ()<br><br>Может кто подскажет, что не так в этой процедуре, в частности ТекСуммаАв = Ит.СКД не видит что есть остаток по субконто5, хотя все условия выполняются. <br>если убрать отбор по субконто5 то остаток видит."

Елена Р.
читатель
офлайн
Дата регистрации: 06.05.2008
Сообщений: 898
Пост №2
 
22.07.2008 11:03

Может Субконто5 - "оборотное" в плане счетов

Валерий-НВ
читатель
офлайн
Дата регистрации: 19.11.2007
Сообщений: 13
Пост №3
 
22.07.2008 18:20

Нет не оборотное, признак я поставил учет по сумме

Елена Р.
читатель
офлайн
Дата регистрации: 06.05.2008
Сообщений: 898
Пост №4
 
23.07.2008 05:55

Оборотный другая галочка, то есть может быть субконто по сумме, но учитываться по этому субконто будут, только обороты. В описании субконто в плане счетов галочка "Только обороты"

Валерий-НВ
читатель
офлайн
Дата регистрации: 19.11.2007
Сообщений: 13
Пост №5
 
23.07.2008 06:14

Я поставил учет по только сумме, в принципе эта проблема в бюджетке уже навероное с год существует, я пытался и до этого реализовать учет расчетов с *** и кредиторами по детализации ЭКР, и была такая же картина. Вот сейчас это приперло и приходится решать эту проблему плотно.

Валерий-НВ
читатель
офлайн
Дата регистрации: 19.11.2007
Сообщений: 13
Пост №6
 
23.07.2008 17:09

Люди! неужто ни у кого нет мыслей по этому поводу?:(

SLAVKAP
читатель
офлайн
Дата регистрации: 03.11.2006
Сообщений: 10
Пост №7
 
27.07.2008 22:25

Есть мнение - что субконто 4 - то бишь договор, если не ошибаюсь, пустое - попробуй заполнить в доке оплаты и акте, соответственно, субконто5 будет аффтаматически определяццо - была такая фигня....<br><br>ЗЫ Ежели без договора все происходило, то заведи договор с названием "Без договора" и выбеои его:) <br>

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С