Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как узнать пустая ли ТаблицаЗначений для Кадры и Зарплата

Dim1978
читатель
офлайн
Дата регистрации: 06.10.2003
Сообщений: 2
Пост №1
 
06.10.2003 18:28

"Мне надо Вывести все подразделения и заполнить сколько по Факту вакансий.<br><br>ПИшу код:<br><br>Процедура Сформировать() <br><br> Перем Запрос,Подразд,Таб,ТЗ;<br><br> Подразд=СоздатьОбъект("Справочник.ШтатноеРасписание");<br><br> ТЗ=СоздатьОбъект("ТаблицаЗначений");<br><br> ТЗ.НоваяКолонка("Подр","Справочник.Подразделения");<br><br> ТЗ.НоваяКолонка("Всего","Число",18,2,"Всего");<br><br> Таб=СоздатьОбъект("Таблица");<br><br> Таб.ВывестиСекцию("Отчет");<br><br> Таб.ВывестиСекцию("Шапка");<br><br> Подразд.ВыбратьЭлементы();<br><br> Пока Подразд.ПолучитьЭлемент()=1 Цикл<br><br> ТЗ.ВыбратьСтроки();<br><br> Если ТЗ.КоличествоСтрок()=0 Тогда <br><br>ТЗ.НоваяСтрока();<br><br>ТЗ.Подр=Подразд.ТекущийЭлемент();<br><br>ТЗ.Всего=Подразд.СтавокВсего;<br><br>КонецЕсли; <br><br> Пока ТЗ.ПолучитьСтроку()=1 Цикл<br><br> Если ТЗ.Подр=Подразд.ТекущийЭлемент() Тогда<br><br>ТЗ.Всего=ТЗ.Всего+Подразд.СтавокВсего;<br><br> Иначе<br><br>ТЗ.НоваяСтрока();<br><br>ТЗ.Подр=Подразд.ТекущийЭлемент();<br><br>ТЗ.Всего=Подразд.СтавокВсего;<br><br>КонецЕсли; <br><br>КонецЦикла;<br><br>КонецЦикла;<br><br>ТЗ.ВыбратьСтроки();<br><br>Пока ТЗ.ПолучитьСтроку()=1 Цикл<br><br>ПечПодр=ТЗ.Подр ;<br><br> Всего=ТЗ.Всего;<br><br> Таб.ВывестиСекцию("Запрос");<br><br> КонецЦикла;<br><br>Таб.ТолькоПросмотр(1);<br><br>Таб.Опции(0,0,4,0);<br><br>Таб.Показать("Список товаров по каталогу","""");<br><br>КонецПроцедуры<br><br>В чем у меня проблема выдает везде нули, а подразделения так и вообще не выводит."

Илья
читатель
офлайн
Дата регистрации: 30.09.2003
Сообщений: 39
Пост №2
 
08.10.2003 01:27

"Эк, ты навертел!<br><br>Попробуй так:<br><br>Процедура Сформировать()<br><br> ШР = СоздатьОбъект("Справочник.ШтатноеРасписание");<br><br> Тз = СоздатьОбъект("ТаблицаЗначений");<br><br> Таб = СоздатьОбъект("Таблица");<br><br> <br><br> Тз.НоваяКолонка("Подр","Справочник.Подразделения");<br><br> ТЗ.НоваяКолонка("Всего","Число",18);<br><br> <br><br> ШР.ВыбратьЭлементы();<br><br> Пока ШР.ПолучитьЭлемент() = 1 Цикл<br><br> Тз.НоваяСтрока();<br><br> Тз.Подр = ШР.Подразделение;<br><br> Тз.Всего = ШР.СтавокВсего.Получить(ТекущаяДата());//СтавокВсего - Периодический<br><br> КонецЦикла;                                                 <br><br> <br><br> Тз.Свернуть("Подр","Всего");//Вместо счетчика<br><br> <br><br> Тз.ВыбратьСтроки();<br><br> Пока Тз.ПолучитьСтроку() = 1 Цикл<br><br> ПечПодр = Тз.Подр;<br><br> ПечВсего = Тз.Всего;<br><br> Таб.ВывестиСекцию("Запрос");<br><br> КонецЦикла;<br><br> <br><br> Таб.Показать(,)<br><br> <br><br>КонецПроцедуры"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С