Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как узнать пустая ли ТаблицаЗначений для Кадры и Зарплата

Dim1978
читатель
офлайн
Дата регистрации: 06.10.2003
Сообщений: 2
Пост №1
 
06.10.2003 18:28

"Мне надо Вывести все подразделения и заполнить сколько по Факту вакансий.

ПИшу код:

Процедура Сформировать()

Перем Запрос,Подразд,Таб,ТЗ;

Подразд=СоздатьОбъект("Справочник.ШтатноеРасписание");

ТЗ=СоздатьОбъект("ТаблицаЗначений");

ТЗ.НоваяКолонка("Подр","Справочник.Подразделения");

ТЗ.НоваяКолонка("Всего","Число",18,2,"Всего");

Таб=СоздатьОбъект("Таблица");

Таб.ВывестиСекцию("Отчет");

Таб.ВывестиСекцию("Шапка");

Подразд.ВыбратьЭлементы();

Пока Подразд.ПолучитьЭлемент()=1 Цикл

ТЗ.ВыбратьСтроки();

Если ТЗ.КоличествоСтрок()=0 Тогда

ТЗ.НоваяСтрока();

ТЗ.Подр=Подразд.ТекущийЭлемент();

ТЗ.Всего=Подразд.СтавокВсего;

КонецЕсли;

Пока ТЗ.ПолучитьСтроку()=1 Цикл

Если ТЗ.Подр=Подразд.ТекущийЭлемент() Тогда

ТЗ.Всего=ТЗ.Всего+Подразд.СтавокВсего;

Иначе

ТЗ.НоваяСтрока();

ТЗ.Подр=Подразд.ТекущийЭлемент();

ТЗ.Всего=Подразд.СтавокВсего;

КонецЕсли;

КонецЦикла;

КонецЦикла;

ТЗ.ВыбратьСтроки();

Пока ТЗ.ПолучитьСтроку()=1 Цикл

ПечПодр=ТЗ.Подр ;

Всего=ТЗ.Всего;

Таб.ВывестиСекцию("Запрос");

КонецЦикла;

Таб.ТолькоПросмотр(1);

Таб.Опции(0,0,4,0);

Таб.Показать("Список товаров по каталогу","""");

КонецПроцедуры

В чем у меня проблема выдает везде нули, а подразделения так и вообще не выводит."

Илья
читатель
офлайн
Дата регистрации: 30.09.2003
Сообщений: 39
Пост №2
 
08.10.2003 01:27

"Эк, ты навертел!

Попробуй так:

Процедура Сформировать()

ШР = СоздатьОбъект("Справочник.ШтатноеРасписание");

Тз = СоздатьОбъект("ТаблицаЗначений");

Таб = СоздатьОбъект("Таблица");



Тз.НоваяКолонка("Подр","Справочник.Подразделения");

ТЗ.НоваяКолонка("Всего","Число",18);



ШР.ВыбратьЭлементы();

Пока ШР.ПолучитьЭлемент() = 1 Цикл

Тз.НоваяСтрока();

Тз.Подр = ШР.Подразделение;

Тз.Всего = ШР.СтавокВсего.Получить(ТекущаяДата());//СтавокВсего - Периодический

КонецЦикла;                                                



Тз.Свернуть("Подр","Всего");//Вместо счетчика



Тз.ВыбратьСтроки();

Пока Тз.ПолучитьСтроку() = 1 Цикл

ПечПодр = Тз.Подр;

ПечВсего = Тз.Всего;

Таб.ВывестиСекцию("Запрос");

КонецЦикла;



Таб.Показать(,)



КонецПроцедуры"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги