Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

как запустить Web ссылки из под 1С

RusRMM
читатель
офлайн
Дата регистрации: 24.10.2007
Сообщений: 31
Пост №1
 
23.01.2009 14:36

"Ести сайт http://www.star.poltava.ua/index.php?next_week где представлены телепрограммы, как сделать в кнопу в 1с, чтобы открывались нужные ссылки с каналами в Internet Explore.

Пытался так, но невыходит

Катал="С:Program FilesInternet Explorer";
ИмяФ = "IEXPLORE.EXE";
СтрПрог = Катал + ИмяФ + " " + ИмяССылки;
ЗапуститьПриложение(СтрПрог);

"

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №2
 
23.01.2009 15:40

"ЗапуститьПриложение("www.buh.ru");"

RusRMM
читатель
офлайн
Дата регистрации: 24.10.2007
Сообщений: 31
Пост №3
 
23.01.2009 16:29

"Explorer, запускается но нехочет запускаться ссылка, как сделать что бы она запускалась. Думал наделать нужных ссылок на диске и к ним прописать путь но это тупо, вот модуль может кто чего подскажет.


Перем ИмяПути, ИмяФайла;

Процедура ПриОткрытии()
Каталог = ВосстановитьЗначение("загрузка");
Если Каталог = """" Тогда
Каталог = "Выберите каталог...";
ИмяФайла = "IEXPLORE.EXE";
КонецЕсли
КонецПроцедуры

Процедура ОткрФ()
ФС.ВыбратьФайл(0, ИмяФайла, ИмяПути);//, , "*.exe|*.exe", "exe", );
Каталог = ИмяПути + ИмяФайла;
КонецПроцедуры

Процедура ПриЗакрытии()
СохранитьЗначение("загрузка", Каталог);
КонецПроцедуры
Процедура Сформировать()
Активизировать("Каталог");
СтрПрог = Каталог;
ЗапуститьПриложение(СтрПрог);

КонецПроцедуры

"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №4
 
24.01.2009 13:27

Проверил вариант Thorvardr-а - все запускается.

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №5
 
24.01.2009 22:13

Попробуйте: Пуск-Настройка-Панель управления-Установка и удаление программ-Выбор программ по умолчанию. Там, возможно, у вас надо указать "обозреватель Internet по умолчанию"

RusRMM
читатель
офлайн
Дата регистрации: 24.10.2007
Сообщений: 31
Пост №6
 
26.01.2009 09:29

СП, всё получилось, стояла в настройках Opera, поставил Explore всё запустилось.

RusRMM
читатель
офлайн
Дата регистрации: 24.10.2007
Сообщений: 31
Пост №7
 
26.01.2009 10:24

а как сделать что бы открывались 2 страницы одновременно, а то так одна накладывается на другую.

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №8
 
26.01.2009 12:58

В Internet Explorer:
меню: Сервис-Свойства обозревателя-Дополнительно-Обзор-Использовать одно и то же окно для загрузки ярлыков = Нет

RusRMM
читатель
офлайн
Дата регистрации: 24.10.2007
Сообщений: 31
Пост №9
 
26.01.2009 13:57

никатит(((, всёравно последнюю ссылку запускает.

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №10
 
26.01.2009 14:23

"Перем Флаг;

Процедура Сформировать()
Флаг=1-Флаг;
Если Флаг=1 Тогда
      ЗапуститьПриложение("www.buh.ru/forum");
Иначе
      ЗапуститьПриложение("www.buh.ru");
КонецЕсли;
КонецПроцедуры


открывается два разных окошка. Версия IE = 6. Возможно, ваша проблемка связана с тем, что у вас идет очень быстрый вызов, то есть, второе ЗапуститьПриложение() отрабатывает еще до того, как выполнилось первое, тогда да, IE считает, что первую ссылку вы ввели с ошибкой и теперь поправились, при этом не догружает первый контент до конца и сразу начинает грузить второй"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги