Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

1c 7.7 Обработка для выгрузки товара в весы

koldun
читатель
офлайн
Дата регистрации: 19.01.2009
Сообщений: 3
Пост №1
 
05.02.2009 09:15

"Здравствуйте, написал обработку для весов cas 1.6. <br>Процедура Сформировать()<br> Сообщить("""");<br> Сообщить("Отправка товаров в весы.");<br> Сообщить("""");<br> Попытка<br> ЗагрузитьВнешнююКомпоненту("LP16DLLCOM.dll");<br> Весы = СоздатьОбъект("LP16DLLCOM.lp16");<br> Исключение<br> Сообщить("Не удалось подключить DLL!");<br> return;<br> КонецПопытки;<br> Сообщить("подключили DLL!");<br> Попытка<br> Весы.ip = "192.168.0.200";<br> Весы.port = 8111;<br> Весы.Connect();<br> Исключение<br> Сообщить("Не удалось соединится в весами.");<br> return;<br> КонецПопытки;<br>КонецПроцедуры <br>Процедура Sendtovar()<br> Попытка<br>Весы.PLUNO = PLUN;<br>Весы.PRICE = PRICET;<br>Весы.LIFE = LIFET;<br>Весы.TARE = TARET;<br>Весы.groupcode = GroupCodeT;<br>Весы.MSG1 = Name1;<br>Весы.MSG2 = Name2;<br>Весы.ITEM = ITEMT;<br> Весы.SendPLU();<br> Исключение<br> Сообщить("Не удалось отправить товар.");<br> return;<br> КонецПопытки;<br> Сообщить("Товар отправлен !");<br> КонецПроцедуры <br><br>Процедура Recivetovar()<br>Весы.PLUNO = PLUN;<br>Весы.RecvPLU(1);<br> <br>PLUN=Весы.PLUNO;<br>PRICET=Весы.PRICE;<br>LIFET=Весы.LIFE;<br>TARET=Весы.TARE;<br>GroupCodeT=Весы.groupcode;<br>Name1=Весы.MSG1;<br>Name2=Весы.MSG2;<br>ITEMT=Весы.ITEM;<br><br>КонецПроцедуры<br><br>Проблема в том что занимаюсь 1с не долго и не знаю как сделать что бы в весы и из весов можно было заносить товар списком.<br>Тоесть выбирать из уже существующей номенклатуры?<br>Буду рад услышать любые советы)"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С