Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

1c 7.7 Обработка для выгрузки товара в весы

koldun
читатель
офлайн
Дата регистрации: 19.01.2009
Сообщений: 3
Пост №1
 
05.02.2009 09:15

"Здравствуйте, написал обработку для весов cas 1.6.
Процедура Сформировать()
Сообщить("""");
Сообщить("Отправка товаров в весы.");
Сообщить("""");
Попытка
ЗагрузитьВнешнююКомпоненту("LP16DLLCOM.dll");
Весы = СоздатьОбъект("LP16DLLCOM.lp16");
Исключение
Сообщить("Не удалось подключить DLL!");
return;
КонецПопытки;
Сообщить("подключили DLL!");
Попытка
Весы.ip = "192.168.0.200";
Весы.port = 8111;
Весы.Connect();
Исключение
Сообщить("Не удалось соединится в весами.");
return;
КонецПопытки;
КонецПроцедуры
Процедура Sendtovar()
Попытка
Весы.PLUNO = PLUN;
Весы.PRICE = PRICET;
Весы.LIFE = LIFET;
Весы.TARE = TARET;
Весы.groupcode = GroupCodeT;
Весы.MSG1 = Name1;
Весы.MSG2 = Name2;
Весы.ITEM = ITEMT;
Весы.SendPLU();
Исключение
Сообщить("Не удалось отправить товар.");
return;
КонецПопытки;
Сообщить("Товар отправлен !");
КонецПроцедуры

Процедура Recivetovar()
Весы.PLUNO = PLUN;
Весы.RecvPLU(1);

PLUN=Весы.PLUNO;
PRICET=Весы.PRICE;
LIFET=Весы.LIFE;
TARET=Весы.TARE;
GroupCodeT=Весы.groupcode;
Name1=Весы.MSG1;
Name2=Весы.MSG2;
ITEMT=Весы.ITEM;

КонецПроцедуры

Проблема в том что занимаюсь 1с не долго и не знаю как сделать что бы в весы и из весов можно было заносить товар списком.
Тоесть выбирать из уже существующей номенклатуры?
Буду рад услышать любые советы)"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги