Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как изменить адрес контрагента в 1С 8.1

korok
читатель
офлайн
Дата регистрации: 11.02.2009
Сообщений: 2
Пост №1
 
11.02.2009 11:14

"Пожалуйста подскажите как можно изменить программно юридический адрес контрагента?

Контрагент = Справочники.Контрагенты.НайтиПоКоду(КодКонтрагента).ПолучитьОбъект();
Контрагент.ИНН = ИНН;
Контрагент.КПП = КПП;

.... тут нужно написать изменение юридического адреса, где переменная адреса - АдресКонтрагента

Контрагент.Записать();

Я так понял через общий модуль нужно это сделать?

Не пойму что то...Подскажите пожалуйста, знаю что вопрос дурацкий на самом деле...

"

korok
читатель
офлайн
Дата регистрации: 11.02.2009
Сообщений: 2
Пост №2
 
11.02.2009 13:39

В общем разобрался сам...

user25
читатель
офлайн
Дата регистрации: 13.05.2008
Сообщений: 8
Пост №3
 
07.09.2009 11:31

"Вот как я выводил юридический и фактический адреса контрагентов в 1С 8.1:

// пишем самодельную функцию:

Функция ПолучитьАдрес(КодКонтрагента, ВидАдреса=0)

Результат = """";

Если ВидАдреса = 0 Тогда

Адрес = "Юридический адрес";

Иначе

Адрес = "Фактический адрес";

КонецЕсли;

НаборЗаписей = РегистрыСведений.КонтактнаяИнформация;

ВыборкаРС = НаборЗаписей.Выбрать();

Пока ВыборкаРС.Следующий() Цикл

Если ТипЗнч(ВыборкаРС.Объект) = Тип("СправочникСсылка.Контрагенты") Тогда

Если СокрЛП(ВыборкаРС.Объект.Код) = СокрЛП(КодКонтрагента) Тогда

Если СокрЛП(ВыборкаРС.Вид) = Адрес Тогда

Результат = Строка(ВыборкаРС.Представление);

КонецЕсли;

КонецЕсли;

КонецЕсли;

КонецЦикла;

Возврат Результат;

КонецФункции


Процедура КнопкаСформироватьНажатие(Кнопка)
// Вставить содержимое обработчика.

//Родитель = Справочники.Контрагенты.НайтиПоКоду("000000001"); // группа справочника

ВыборкаСК = Справочники.Контрагенты.Выбрать(Справочники.Контрагенты.ПустаяСсылка(),,,"Код Возр");
//ВыборкаСК = Справочники.Контрагенты.Выбрать(Родитель,,,"Код Возр");

Пока ВыборкаСК.Следующий() Цикл

Если ВыборкаСК.ЭтоГруппа = Истина Тогда

Продолжить;

КонецЕсли;

Адрес = ПолучитьАдрес(ВыборкаСК.Код,1);

Если ПустаяСтрока(Строка(Адрес)) = 0 Тогда

Сообщить(Адрес);

Иначе

Сообщить(" ");

КонецЕсли;

КонецЦикла;

КонецПроцедуры

В восьмёрке часть данных справочника контрагентов хранится не в самом справочнике "Контрагенты" (как в 7-ке), а в РегистрыСведений.КонтактнаяИнформация. Вот такая вот система "через задницу"."

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №4
 
07.09.2009 13:20

> Вот такая вот система "через задницу".

ИМХО тоже самое можно сказать про вышеописанный код программы...

user25
читатель
офлайн
Дата регистрации: 13.05.2008
Сообщений: 8
Пост №5
 
07.09.2009 15:24

Вообще-то это мой первый в жизни код на 1С 8.0. :) Написан на скорую руку - без знания 8-ки, чисто через Яндекс + Синтакс-помощник. Задача стояла перегрузить справочник контрагенты из 8-ки в 7-ку с минимумом затрат времени на изучение 8-ки.

Всё-таки трудно, абсолютно не зная 8-ку, за 2 дня написать даже такой код. :)

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №6
 
07.09.2009 16:02

"Ну если это не последний Ваш код на 8-ке, то в следующий раз, когда захотите поделиться чем-то полезным на форуме, то хотя бы убирайте из кода все отладочные строки и, по возможности, постарайтесь избегать критики тех механизмов 1С, с которыми знакомы только поверхностно. ;)"

user25
читатель
офлайн
Дата регистрации: 13.05.2008
Сообщений: 8
Пост №7
 
08.09.2009 10:16

Я критикую потому, что вообще очень плохого мнения о продукции фирмы 1С. Они способны извратить (в своих программных продуктах) самую здравую идею. 8-ка произвела негативное впечатление (даже по сравнению с 7-кой, которая тоже плохая).
Отладочный код - пригодится другим, у кого-то может быть чуть иная задача.

Кстати - небольшое добавление: к коду

Если СокрЛП(ВыборкаРС.Объект.Код) = СокрЛП(КодКонтрагента) Тогда

нужно ещё добавить доп. проверку на совпадения кодов родителей.

ПСВ
читатель
офлайн
Дата регистрации: 06.04.2009
Сообщений: 379
Пост №8
 
08.09.2009 12:53

"а переборка всех записей всего Регистра не нужна , а если там будет миллион записей?

Курите Отборы , запросы

из справки:
Курсы = РегистрыСведений.КурсыВалют;
ОтборВалют = Новый Структура("Валюта");
ОтборВалют.Валюта = ВыбВалюта;
ВыборкаКурсовВалют = Курсы.Выбрать(,,ОтборВалют);
Пока ВыборкаКурсовВалют.Следующий() Цикл
Сообщить("Дата " + ВыборкаКурсовВалют.Период +
" Валюта "+СокрЛП(ВыборкаКурсовВалют.Валюта) +
", Курс "+ ВыборкаКурсовВалют.Курс );
КонецЦикла;

"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №9
 
08.09.2009 13:42

> Всё-таки трудно, абсолютно не зная 8-ку...

и

> Я критикую потому, что вообще очень плохого мнения о продукции фирмы 1С

Вам самому не смешно? Очень напоминает "кошек", которых чтобы нравились "нужно уметь готовить"...

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги