Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как изменить адрес контрагента в 1С 8.1

korok
читатель
офлайн
Дата регистрации: 11.02.2009
Сообщений: 2
Пост №1
 
11.02.2009 11:14

"Пожалуйста подскажите как можно изменить программно юридический адрес контрагента?<br><br>Контрагент = Справочники.Контрагенты.НайтиПоКоду(КодКонтрагента).ПолучитьОбъект();<br>Контрагент.ИНН = ИНН;<br>Контрагент.КПП = КПП;<br><br>.... тут нужно написать изменение юридического адреса, где переменная адреса - АдресКонтрагента<br><br>Контрагент.Записать();<br><br>Я так понял через общий модуль нужно это сделать?<br><br>Не пойму что то...Подскажите пожалуйста, знаю что вопрос дурацкий на самом деле...<br><br>"

korok
читатель
офлайн
Дата регистрации: 11.02.2009
Сообщений: 2
Пост №2
 
11.02.2009 13:39

В общем разобрался сам...

user25
читатель
офлайн
Дата регистрации: 13.05.2008
Сообщений: 8
Пост №3
 
07.09.2009 11:31

"Вот как я выводил юридический и фактический адреса контрагентов в 1С 8.1:<br><br>// пишем самодельную функцию:<br><br>Функция ПолучитьАдрес(КодКонтрагента, ВидАдреса=0)<br> <br> Результат = """";<br><br> Если ВидАдреса = 0 Тогда<br> <br> Адрес = "Юридический адрес";<br> <br> Иначе<br> <br> Адрес = "Фактический адрес";<br> <br> КонецЕсли;<br> <br> НаборЗаписей = РегистрыСведений.КонтактнаяИнформация;<br> <br> ВыборкаРС = НаборЗаписей.Выбрать();<br> <br> Пока ВыборкаРС.Следующий() Цикл <br> <br> Если ТипЗнч(ВыборкаРС.Объект) = Тип("СправочникСсылка.Контрагенты") Тогда<br> <br> Если СокрЛП(ВыборкаРС.Объект.Код) = СокрЛП(КодКонтрагента) Тогда<br> <br> Если СокрЛП(ВыборкаРС.Вид) = Адрес Тогда<br> <br> Результат = Строка(ВыборкаРС.Представление);<br> <br> КонецЕсли;<br> <br> КонецЕсли;<br> <br> КонецЕсли;<br> <br> КонецЦикла;<br> <br> Возврат Результат;<br> <br>КонецФункции<br> <br><br>Процедура КнопкаСформироватьНажатие(Кнопка)<br> // Вставить содержимое обработчика.<br> <br> //Родитель = Справочники.Контрагенты.НайтиПоКоду("000000001"); // группа справочника<br> <br> ВыборкаСК = Справочники.Контрагенты.Выбрать(Справочники.Контрагенты.ПустаяСсылка(),,,"Код Возр");<br> //ВыборкаСК = Справочники.Контрагенты.Выбрать(Родитель,,,"Код Возр");<br> <br> Пока ВыборкаСК.Следующий() Цикл<br> <br> Если ВыборкаСК.ЭтоГруппа = Истина Тогда<br> <br> Продолжить;<br> <br> КонецЕсли;<br> <br> Адрес = ПолучитьАдрес(ВыборкаСК.Код,1); <br> <br> Если ПустаяСтрока(Строка(Адрес)) = 0 Тогда<br> <br> Сообщить(Адрес);<br> <br> Иначе<br> <br> Сообщить(" ");<br> <br> КонецЕсли; <br> <br> КонецЦикла;<br> <br>КонецПроцедуры<br><br>В восьмёрке часть данных справочника контрагентов хранится не в самом справочнике "Контрагенты" (как в 7-ке), а в РегистрыСведений.КонтактнаяИнформация. Вот такая вот система "через задницу"."

Денис (САМАРА)
читатель
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №4
 
07.09.2009 13:20

> Вот такая вот система "через задницу".<br><br>ИМХО тоже самое можно сказать про вышеописанный код программы...

user25
читатель
офлайн
Дата регистрации: 13.05.2008
Сообщений: 8
Пост №5
 
07.09.2009 15:24

Вообще-то это мой первый в жизни код на 1С 8.0. :) Написан на скорую руку - без знания 8-ки, чисто через Яндекс + Синтакс-помощник. Задача стояла перегрузить справочник контрагенты из 8-ки в 7-ку с минимумом затрат времени на изучение 8-ки.<br><br>Всё-таки трудно, абсолютно не зная 8-ку, за 2 дня написать даже такой код. :)

Денис (САМАРА)
читатель
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №6
 
07.09.2009 16:02

"Ну если это не последний Ваш код на 8-ке, то в следующий раз, когда захотите поделиться чем-то полезным на форуме, то хотя бы убирайте из кода все отладочные строки и, по возможности, постарайтесь избегать критики тех механизмов 1С, с которыми знакомы только поверхностно. ;)"

user25
читатель
офлайн
Дата регистрации: 13.05.2008
Сообщений: 8
Пост №7
 
08.09.2009 10:16

Я критикую потому, что вообще очень плохого мнения о продукции фирмы 1С. Они способны извратить (в своих программных продуктах) самую здравую идею. 8-ка произвела негативное впечатление (даже по сравнению с 7-кой, которая тоже плохая).<br>Отладочный код - пригодится другим, у кого-то может быть чуть иная задача.<br><br>Кстати - небольшое добавление: к коду<br><br>Если СокрЛП(ВыборкаРС.Объект.Код) = СокрЛП(КодКонтрагента) Тогда<br><br>нужно ещё добавить доп. проверку на совпадения кодов родителей.

ПСВ
читатель
офлайн
Дата регистрации: 06.04.2009
Сообщений: 379
Пост №8
 
08.09.2009 12:53

"а переборка всех записей всего Регистра не нужна , а если там будет миллион записей?<br><br>Курите Отборы , запросы<br><br>из справки:<br>Курсы = РегистрыСведений.КурсыВалют;<br>ОтборВалют = Новый Структура("Валюта");<br>ОтборВалют.Валюта = ВыбВалюта; <br>ВыборкаКурсовВалют = Курсы.Выбрать(,,ОтборВалют);<br>Пока ВыборкаКурсовВалют.Следующий() Цикл<br> Сообщить("Дата " + ВыборкаКурсовВалют.Период + <br> " Валюта "+СокрЛП(ВыборкаКурсовВалют.Валюта) +<br> ", Курс "+ ВыборкаКурсовВалют.Курс );<br>КонецЦикла;<br><br>"

Денис (САМАРА)
читатель
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №9
 
08.09.2009 13:42

> Всё-таки трудно, абсолютно не зная 8-ку...<br><br>и<br><br>> Я критикую потому, что вообще очень плохого мнения о продукции фирмы 1С<br><br>Вам самому не смешно? Очень напоминает "кошек", которых чтобы нравились "нужно уметь готовить"...

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С