Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Бухгалтерия 7.7 Добавить колонку в форму журнала

Svetlana_E
активный пользователь
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2641
Пост №1
 
12.02.2009 06:48

Вопрос: Как добавить новую колонку в форму списка журнала? Так чтобы она не была привязана ни к какой графе, для вывода в нее пиктограммы, которая будет формироваться программно в модуле этой формы. Типа второй колонки в журнале "Платежные документы"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №2
 
12.02.2009 08:06

Вставить поле "Текст", установить свойство "Показывать пиктограммы", в форму списка внести картинку, состоящую из линейки пиктограмм (формат пиктограмм можно посмотреть в файле "IMAGECOL.BMP", вроде 16х16 пикселей), в модуле задавать картинку (ИДКолонки = <Номер пиктограммы в линейке>).

Svetlana_E
активный пользователь
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2641
Пост №3
 
12.02.2009 08:52

> Вставить поле "Текст"
Вот за это спасибо! Не могла создать саму пустую колонку!

> в форму списка внести картинку, состоящую из линейки пиктограмм (формат пиктограмм можно посмотреть в файле "IMAGECOL.BMP", вроде 16х16 пикселей), в модуле задавать картинку (ИДКолонки = <Номер пиктограммы в линейке>).
Это непонятно.
Колонку создала,установила свойство "Показывать пиктограммы", в "Формула" поставила "ВыводПиктограммы()".
В модуле(примерная структура, что-то типа):

Функция ВыводПиктограммы()
Если а=Истина тогда
возврат пикто1
Иначе
возврат пикто2
КонецЕсли
КонецФункции

Вопросы:
1)Что значит "в форму списка внести картинку, состоящую из линейки пиктограмм (формат пиктограмм можно посмотреть в файле "IMAGECOL.BMP", вроде 16х16 пикселей)". Какие конкретные действия я для этого должна сделать?
2) Что именно должно стоять вместо "пикто1" и "пикто2"? Хотя это наверное станет понятно, если пойму первое..

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №4
 
12.02.2009 09:35

1) ПКМ на многострочной части журнала - закладка "Картинка".
2) Функция должна возвращать номер пиктограмки из колекции картинок (посмотрите наконец в "пэйнте" файл "IMAGECOL.BMP").

Svetlana_E
активный пользователь
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2641
Пост №5
 
12.02.2009 09:45

Спасибо! Все получилось. Я файл посмотрела, но никак не могла понять, как он "цепляется" к таблице. Еще раз спасибо!

Ольга_плюс
читатель
офлайн
Дата регистрации: 23.01.2009
Сообщений: 21
Пост №6
 
21.10.2009 16:08

"Помогите, пожалуйста, добить проблему: чтобы в журнале "Расчеты через казначейство" ставилась галка при проведении документа "Кассовое выбытие". Все ваши рекомендации сделала: поле "Текст" вставила, установила свойство "Показывать пиктограммы", в формуле поставила "НомерПиктограммы()", в форму списка внесла картинку, состоящую из линейки пиктограмм. Что подредактировать в модуле, не знаю.
Модуль выглядит так:

Перем гСписокКолонок;
Перем гИдФормы;
Перем ДатаПроведения_;

//******************************************************************************
//
//
Процедура ПечатьДокумента()

Парам=СоздатьОбъект("СписокЗначений");
Парам.Установить("Действие","Печать");
ОткрытьФорму(ТекущийДокумент,Парам);

КонецПроцедуры

//******************************************************************************
//
Функция НомерПиктограммы()

Если ТекущийДокумент.Выбран() = 0 Тогда
Возврат 0;
КонецЕсли;

СуммаВыписки = 0;
НомПикт=0;
ДатаПроведения_="""";

ПодчДок = СоздатьОбъект("Документ");
Если ПодчДок.ВыбратьПодчиненныеДокументы(ТекущийДокумент.ДатаДок,,ТекущийДокумент) = 1 Тогда
Пока ПодчДок.ПолучитьДокумент() = 1 Цикл
Если (ПодчДок.Вид() = "СписаниеСоСчета") Или (ПодчДок.Вид() = "ПоступлениеНаСчет")Тогда
СуммаВыписки = СуммаВыписки+ПодчДок.Итог("Сумма");
//НомПикт = 5;
//ДатаВыписки = ПодчДок.ДатаДок;
ДатаПроведения_ = ПодчДок.ДатаДок;
КонецЕсли;

КонецЦикла;
Если СуммаВыписки<>0 Тогда
Если СуммаВыписки<ТекущийДокумент.СуммаДокумента Тогда
НомПикт=4;
Иначе
НомПикт = 5;
КонецЕсли;
КонецЕсли;
КонецЕсли;

Возврат НомПикт;

КонецФункции // НомерПиктограммы()

//******************************************************************************
//
//
Процедура ПоКнопкеЭкспортИмпорт()

ОткрытьФорму("Обработка.Казначейство_Главная");

КонецПроцедуры

//******************************************************************************
//
//
Процедура ПоКнопкеДействия()
Если ТекущийДокумент.Выбран()= 0 Тогда
Предупреждение("Не выбран документ !");
Возврат;
Иначе
Меню = СоздатьОбъект("СписокЗначений");
Меню.ДобавитьЗначение("ПечатьДокумента","Печать документа");
Меню.ДобавитьЗначение("Реестр",       "Реестр документов");
Меню.ДобавитьЗначение("РеестрЗКР",      "Реестр заявок на кассовый расход");
ВидОтчета = """";
Если Меню.ВыбратьЗначение(ВидОтчета,,,,1)=1 Тогда
Если ВидОтчета="ПечатьДокумента" Тогда
ПечатьДокумента();
ИначеЕсли ВидОтчета = "Реестр" Тогда
глПечатьЖурналаДокументов(Контекст, "РасчетыЧерезКазначейство");
ИначеЕсли ВидОтчета = "РеестрЗКР" Тогда

Расшифровка = СоздатьОбъект("СписокЗначений");
Расшифровка.Установить("Дата1",       НачМесяца(ТекущийДокумент.ДатаДок));
Расшифровка.Установить("Дата2",       КонМесяца(ТекущийДокумент.ДатаДок));
Расшифровка.Установить("ВыбраннаяФирма", ТекущийДокумент.ВыбраннаяФирма);
Расшифровка.Установить("ВидДокумента", "ЗКР");

Если ((глЕстьРеквизитШапки("РазделЛицевогоСчета",ТекущийДокумент.Вид()) = 1) ИЛИ
(глЕстьРеквизитМнЧ("РазделЛицевогоСчета", ТекущийДокумент.Вид()) = 1))Тогда

ТекущийДокумент.ПолучитьСтрокуПоНомеру(1);
Если ТекущийДокумент.РазделЛицевогоСчета.ВладелецСчета = ТекущийДокумент.ВыбраннаяФирма Тогда
Расшифровка.Установить("ЛицевойСчет", ТекущийДокумент.РазделЛицевогоСчета);                  
КонецЕсли;

КонецЕсли;

глРасшифровка = Расшифровка;
глОбновить = 2;
глФлагРасшифровки = 1;
ОткрытьФорму("Отчет.РеестрПП");
глФлагРасшифровки = 0;
глОбновить = 0;

КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецПроцедуры

//******************************************************************************
//
//
Процедура Отбор()

Поз=СпЗнач.ТекущаяСтрока();
УстановитьОтбор(СпЗнач.ПолучитьЗначение(Поз));

КонецПроцедуры // Отбор

//******************************************************************************
// Предопределенная процедура.
//
Процедура ПриОткрытии()

//глУстановитьВидимостьКолонок(Контекст, гИдФормы, гСписокКолонок, 1);

Если ТипЗначенияСтр(Форма.Параметр) = "Документ" Тогда
глАктивизироватьДокумент(Контекст, Форма.Параметр);
КонецЕсли;

КонецПроцедуры
//******************************************************************************
// Предопределенная процедура
//
Процедура ПриПовторномОткрытии()

Если ТипЗначенияСтр(Форма.Параметр) = "Документ" Тогда
глАктивизироватьДокумент(Контекст, Форма.Параметр);
КонецЕсли;

КонецПроцедуры // ПриПовторномОткрытии()
////////////////////////////////////////////////////////­////////////////////////

гИдФормы = "Журнал_РасчетыЧерезКазначейство_ФормаСписка";

// Список колонок видимостью которых будем управлять
гСписокКолонок = СоздатьОбъект("СписокЗначений");
гСписокКолонок.ДобавитьЗначение("ВыбраннаяФирма", "Учреждение");
гСписокКолонок.ДобавитьЗначение("ЛицевойСчет" , "Лицевой счет");
гСписокКолонок.ДобавитьЗначение("Контрагент" , "Контрагент");
гСписокКолонок.ДобавитьЗначение("Сумма" , "Сумма документа");
гСписокКолонок.ДобавитьЗначение("ДатаПроведения", "Дата проведения");
гСписокКолонок.Пометка(1, 1);
гСписокКолонок.Пометка(4, 1);

СпЗнач.УдалитьВсе();
СпЗнач.ДобавитьЗначение("""","Все документы");
СпЗнач.ДобавитьЗначение("ЗаявкаНаКассовыйРасход","Заявка на кассовый расход");
СпЗнач.ДобавитьЗначение("ЗаявкаНаНаличные","Заявка на наличные");
СпЗнач.ДобавитьЗначение("РеквизитыЧеков","Реквизиты чека (в заявку на наличные)");
СпЗнач.ДобавитьЗначение("ЗаявкаНаВозврат","Заявка на возврат");
СпЗнач.ДобавитьЗначение("ЗапросНаАннулированиеЗаявки","Запрос на аннулирование заявки");"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №7
 
21.10.2009 18:10

1) Вы выбираете подчиненные документы только на день документа (ПодчДок.ВыбратьПодчиненныеДокументы(ТекущийДокумент.ДатаДок,,ТекущийДокумент)), возможно выписки сделаны в другие дни и подчиненных документов в выборке попросту нет?

2) Если я правильно понял, то при наличии хотя бы каких-нибудь выписок, но на общую сумму меньше чем сумма документа-основания, должна выводиться картинка №4, если сумма выписок равна или больше чем сумма документа-основания, то картинка №5. В противом случае не выводится никакая картинка. Для чего тогда служат картинки №1..№3?

3) Для каких целей при выводе пиктограммы Вы определяете переменную "ДатаПроведения_"?

Ольга_плюс
читатель
офлайн
Дата регистрации: 23.01.2009
Сообщений: 21
Пост №8
 
22.10.2009 09:31

1) Подчиненные документы есть.

2)3) Так написано в модуле. У нас типовая конфигурация для Бухгалтерии для распорядителей бюджетных средств, ред.3.1, релиз 7.70.334.

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №9
 
22.10.2009 10:19

А Вы на картинку, привязанную в журнале, смотрели? Там есть вообще 5 пиктограмм?

Ольга_плюс
читатель
офлайн
Дата регистрации: 23.01.2009
Сообщений: 21
Пост №10
 
22.10.2009 11:15

Конечно смотрела - я сама картинку привязывала - там 7 пиктограмм.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги