Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

кбк в графе корреспондирующий счет, субсчет РКО (ПКО)

torin_8903
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 12
Пост №1
 
18.02.2009 15:46

Подскажите пожалуйста,
что нужно сделать что бы в графе кореспондирующий счет, субсчет перед счетом было кбк в приходно кассовом ордере?
7,7 (7,10,027) релиз 7,70,630

SLAVKA_P
читатель
офлайн
Дата регистрации: 07.12.2008
Сообщений: 66
Пост №2
 
18.02.2009 23:57

А поступление всегда по одному КБК происходит?

torin_8903
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 12
Пост №3
 
19.02.2009 07:55

да всегда по одному

SLAVKA_P
читатель
офлайн
Дата регистрации: 07.12.2008
Сообщений: 66
Пост №4
 
19.02.2009 08:35

Ну тогда заведи еще одну переменную, присвой ей значение КБК и добавь в ту же ячейку....

torin_8903
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 12
Пост №5
 
19.02.2009 09:19

а можно чуть подробней где это и как правильно? я так понял в конфигураторе в форме этого документа?

SLAVKA_P
читатель
офлайн
Дата регистрации: 07.12.2008
Сообщений: 66
Пост №6
 
19.02.2009 23:35

"а вы случаем не программист?...

в процедуре печать в самом начале

ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
КБК_1 = Строка (ФКР);
КонецЦикла;

потом примерно в районе строки 700

Если СтрДлина(ГрСчКредит)=6 Тогда
КорСчетП=КБК_1 + глКодСчетаКраткий(ГрСчКредит,".");
Иначе
ВыбратьСтроки();
КорСчетП=КБК_1 + глКодСчетаКраткий(ГрСчКредит,".");
СтрСч="""";
Пока ПолучитьСтроку()=1 Цикл
Если КорСчет.Выбран()=1 Тогда
Если СтрДлина(СтрСч)=0 Тогда
СтрСч=КорСчет.Код+",";
КорСчетП=КБК_1 + глКодСчетаКраткий(КорСчет,".");
Иначе
Если Найти(СтрСч,КорСчет.Код+",")=0 Тогда
Если ПустаяСтрока(СтрЗаменить(ГрСчКредит,".",""""))=0 Тогда
КорСчетП=""""+КодИсточника+"."+СокрП(СтрЗаменить(ГрСчКредит,".",""""));
ДлинаКода=СтрДлина(КорСчетП);
Для инд=ДлинаКода+1 По 7 Цикл
КорСчетП=КБК_1 + КорСчетП+"0";
КонецЦикла;
Прервать;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;

Это вот если усиленно не думать....

"

torin_8903
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 12
Пост №7
 
20.02.2009 06:49

к сожелению к програмированию отношения не имею, но иногда сталкиваюсь с такими проблемами

SLAVKA_P
читатель
офлайн
Дата регистрации: 07.12.2008
Сообщений: 66
Пост №8
 
20.02.2009 07:41

лучше б написал получилось или нет...

torin_8903
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 12
Пост №9
 
20.02.2009 09:47

пока не успешно. в документы\расходный ордер модуль документа не вижу процедуры печати, и строк там нет 700 там их намного меньше.

Svetlana_E
активный пользователь
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2641
Пост №10
 
20.02.2009 16:18

> Подскажите пожалуйста,
> что нужно сделать что бы в графе кореспондирующий счет, субсчет перед счетом было кбк в приходно кассовом ордере?

Можно еще раз сформулировать вопрос? Не пойму слов:"субсчет перед счетом было кбк"
захожу в ПКО. Таблица. Вижу поле "Кор.счет(кредит)", под ним "КБК(кредит)"...
Или вы про печатную форму?
И в любом случае совет, который вам дали(для печати), реализовывать надо через модуль формы, а не через модуль документа!
И учтите, что форма ПКО (РКО) это форма, утвержденная ГосКомСтатом!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги