Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

ЗУП 8.1 Релиз 2.5.12.1 Связь между базами

inna__p
читатель
офлайн
Дата регистрации: 25.03.2009
Сообщений: 5
Пост №1
 
25.03.2009 15:42

"Подскажите, плз., 1) почему при соединении баз с помощью Automation Server все выполняется и зависает, не отключается в конце; с помощью COM-соединения все нормально? 2) справочники обрабатываются без проблем, к перечислению обращаюсь точно так же - почему не выбирается?
Перебрасываю физ.лиц из ЗУП в Бух. Обе 8.1. "

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8345
Пост №2
 
26.03.2009 08:26

1) Возможно как то не правильно используете технологию OLE.
2) Чем COM-соединение не устраивает?

inna__p
читатель
офлайн
Дата регистрации: 25.03.2009
Сообщений: 5
Пост №3
 
26.03.2009 11:51

Я во всем разобралась кроме зависания. Использовала COM-соединение. Просто хотелось бы узнать причину зависания.

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8345
Пост №4
 
26.03.2009 17:58

Что бы узнать причину необходимо увидеть, что Вы там за код написали.

inna__p
читатель
офлайн
Дата регистрации: 25.03.2009
Сообщений: 5
Пост №5
 
27.03.2009 09:03

"Процедура КнопкаВыполнитьНажатие(Кнопка)
#Если Клиент Тогда
V81 = Новый COMОбъект("V81.Application");
Путь = "D:\ЗУП_2003\";
Попытка
Состояние ("Выполняется подключение к информационной базе...");
РезультатПодключения = V81.Connect("File=""""" + Путь +
"""""; Usr=""""Adm"""";Pwd=555");
Сообщить("База 8.1 подключена");
Исключение
Сообщить (ОписаниеОшибки());
Предупреждение("Не удалось подключиться");
КонецПопытки;
СпрСотр = V81.Справочники.СотрудникиОрганизаций;
Выборка = СпрСотр.Выбрать();
Пока Выборка.Следующий() Цикл
КодСотра = Выборка.Код;
НайденнаяСсылка = Справочники.СотрудникиОрганизаций.НайтиПоКоду(КодСотра);
Если НайденнаяСсылка = Справочники.СотрудникиОрганизаций.ПустаяСсылка() Тогда
НовыйЭлемент = Справочники.СотрудникиОрганизаций.СоздатьЭлемент();
НовыйЭлемент.Наименование = Выборка.Наименование;
НовыйЭлемент.Организация = Справочники.Организации.НайтиПоКоду("000000001");
НовыйЭлемент.Физлицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(СокрЛП(Выборка.Наименование));
КодФЛ = НовыйЭлемент.Физлицо.Код;
Если НовыйЭлемент.Физлицо.Пустая() Тогда
НовоеФЛ = Справочники.ФизическиеЛица.СоздатьЭлемент();
НовоеФЛ.Наименование = Выборка.Наименование;
СпрФЛ = V81.Справочники.ФизическиеЛица.НайтиПоНаименованию(СокрЛП(Выборка.Наименование));
НовоеФЛ.Код = СпрФЛ.Код;
КодФЛ = НовоеФЛ.Код;
НовоеФЛ.Записать();
НовыйЭлемент.Физлицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(СокрЛП(Выборка.Наименование));
КонецЕсли;
НовыйЭлемент.Актуальность=Истина;
НовыйЭлемент.Код = "0"+КодФЛ;
Сообщить ("Принимаю сотрудника " + Выборка.Наименование);
НовыйЭлемент.Записать();
Конецесли;
ОбработкаПрерыванияПользователя();
КонецЦикла;
#КонецЕсли
КонецПроцедуры
"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8345
Пост №6
 
27.03.2009 20:00

1) Инструкции препроцессора не имеют смысла в модуле формы.
2) Поиск по наименованию производится без флага на точное соответствие.
3) "По старинке" переменную "V81" можно приравнять к "Неопределено".
4) Если это разовый перенос, то рациональнее было перекинуть данные через файл XML (это уже так от себя).

inna__p
читатель
офлайн
Дата регистрации: 25.03.2009
Сообщений: 5
Пост №7
 
27.03.2009 20:09

Спасибо за советы. Это не разовый, а регулярный перенос, все гораздо длиннее, я укоротила для отправки сюда.

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8345
Пост №8
 
28.03.2009 06:58

Тогда подключайтесь базе через "COMConnector" и не мучайте приложение. :)

inna__p
читатель
офлайн
Дата регистрации: 25.03.2009
Сообщений: 5
Пост №9
 
28.03.2009 09:55

Спасибо, так и сделала, теперь не буду сомневаться :)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги