Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

не формируются данные по запросу

177
читатель
офлайн
Дата регистрации: 07.05.2008
Сообщений: 470
Пост №1
 
27.03.2009 20:12

"7.7 ПУБ, делаю запрос //*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Без итогов;
|Товар = Документ.РеализацияПродукции.Товар, Документ.План.Продукция, Документ.Заявка.Товар, регистр.МестаХранения.МПЗ;
|КолРП = Документ.РеализацияПродукции.Количество;
|КолМХ = регистр.МестаХранения.Количество;
|КолПлан = Документ.План.Количество;
|КолЗаявка = Документ.Заявка.Количество;
|Функция КолПланСумма = Сумма(КолПлан);
|Функция КолРПСумма = Сумма(КолРП);
|Функция КолЗаявкаСумма = Сумма(КолЗаявка);
|Функция МХ = КонОст(КолМХ);
|Группировка Товар;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка() = 1 Цикл
Если (Запрос.Товар.Родитель.Наименование=Перечисление.Видыматериалов.Сырье)или
( Запрос.Товар.Родитель.Наименование=Перечисление.Видыматериалов.ДавальческоеСырье) Тогда
Сообщить("материалы");
ИначеЕсли (Запрос.Товар.Родитель.Наименование=Перечисление.ТипыНоменклатуры.Продукция) Тогда
ИначеЕсли(Запрос.Товар.Родитель.Наименование=Перечисление.ТипыНоменклатуры.Полуфабрикат) Тогда
Наимен = Запрос.МПЗ;
План = Запрос.КолПланСумма;
Заявки = Запрос.КолЗаявкаСумма;
МХ = Запрос.МХ;
Таб.ВывестиСекцию("Сформировать");
//Иначе
// продолжить;
КонецЕсли;
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", """");
КонецПроцедуры
и делаю сортировку по условию по родителю т.е.отбираю только полуфабрикаты и продукцию, а врезультате ничего, помогите правильно ли я написала условие?"

Ещё
читатель
офлайн
Дата регистрации: 16.06.2006
Сообщений: 129
Пост №2
 
28.03.2009 01:01

У вас наименование группы - перечисление??? Что-то верится с трудом

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №3
 
28.03.2009 19:18

1) С чего Вы взяли, что данные по запросу не формируются?
2) Для сравнения наименования группы, на что было указано выше, нужно поставить "Строка(Перечисление.Видыматериалов.Сырье)".
3) Вообще странное условие сравнения. Нельзя разве сразу в запросе отобрать нужные виды?

177
читатель
офлайн
Дата регистрации: 07.05.2008
Сообщений: 470
Пост №4
 
28.03.2009 22:07

т.е.я выбираю ВидМПЗ и прописываю Условие(ВидМПЗ=Перечисление.ВидыМатериалов.Продукция)и т.д.
тогда исчезает количество План, Заявка и реализация, а мне надо чтобы были все данные тольео по 2-ум видам , а он мне выдает все, поэтому и пытаюсь прописать условие, а оно не срабатывает вылетает пишет ошибку(поле агрегатного объекта не найдено т.е. в справочниках одно и тоже поле названо по разному)

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №5
 
29.03.2009 11:10

Кроме проверки условия на равенство никаких других проверок в запросе не существует? "В", например...

177
читатель
офлайн
Дата регистрации: 07.05.2008
Сообщений: 470
Пост №6
 
01.04.2009 08:02

сделала сама без чей либо помощи ...........................

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги