Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Запрос по документу Платежное поручение 7.7

Svetlana_Ivanova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 3
Пост №1
 
08.04.2009 08:54

"Добрый день, заклинило не по-детски.Вопрос-ерунда,но тем не менее, помогите,заранее спасибо.
Стандартный запрос,в стандартной базе:
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса ="//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|ТекущийДокумент = Документ.ПлатежноеПоручение.ТекущийДокумент;
|Группировка ТекущийДокумент;
|"//}}ЗАПРОС;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей ТекущийДокумент
КонецЦикла;
НЕ РАБОТАЕТ!!!В цикл не заходит,не видит документов.(Запрос.Группировка(1)=0)
Естественно, документы в базе есть, вместо платежного документа ставишь любой другой работает, ничего не понимаю :("

aily
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 10
Пост №2
 
08.04.2009 13:01

"Может в запросе не хватает метода "Обрабатывать все"?

На сколько помню платежки не делают проводок, может по этому запрос тупит.

Док.ВыбратьДокументы(ВыбНачПериода,ВыбКонПериода);
Пока Док.ПолучитьДокумент()=1 Цикл

КонецЦикла;

Работает вполне ыстро :) Зачем запрос?"

Svetlana_Ivanova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 3
Пост №3
 
08.04.2009 13:12

Запрос нужен для выборки с дополнительными условиями и группировками.
"Обрабатывать все" ставила, даже делала платежки с формированием проводок, ничего...Не понятно очень, тем более на таком элементарном...:(

aily
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 10
Пост №4
 
08.04.2009 13:18

Конфигурация какая?

aily
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 10
Пост №5
 
08.04.2009 13:24

" Перем Запрос, ТекстЗапроса;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с НачДата по КонДата;
|ОбрабатыватьДокументы все;
|Док = Документ.ПлатежноеПоручение.ТекущийДокумент;
|Группировка Док;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса

// Заполнение полей "Заголовок"

Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей Док
Сообщить(Запрос.Док);
КонецЦикла;
// Вывод заполненной формы


Только проверил на Бухгалтерии, все тип-топ :)"

Svetlana_Ivanova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 3
Пост №6
 
08.04.2009 13:42

"Спасибо за помощь, действительно, без этой строки для платежек не работает:
ОбрабатыватьДокументы все;
А ведь ставила это в запрос...
Заработалась...:)"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги