Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

НайтиПОнаименованию

Ильнур
читатель
офлайн
Дата регистрации: 10.02.2009
Сообщений: 51
Пост №1
 
10.04.2009 17:34

"             Выписка.ВыбратьСтроки();
Пока Выписка.ПолучитьСтроку() = 1 Цикл

Если (Выписка.КоррСчет = СчетПоКоду("62.1")) ИЛИ
(Выписка.КоррСчет = СчетПоКоду("62.2")) Тогда
Контрагент = СоздатьОбъект("Справочник.Контрагенты");
Контрагент = Контрагент.НайтиПоНаименованию(Выписка.Субконто1);
       Сообщить(Контрагент);
КонецЕсли;
КонецЦикла;
Выводит нули.В чем может быть моя ошибка?"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №2
 
10.04.2009 18:31

"Вообще-то НайтиПоНаименованию возвращает 0, если не найдено.
Ваш код по-хорошему должен выглядеть так:

Контрагент = СоздатьОбъект("Справочник.Контрагенты");
Выписка.ВыбратьСтроки();
Пока Выписка.ПолучитьСтроку() = 1 Цикл
Если (Выписка.КоррСчет = СчетПоКоду("62.1")) ИЛИ
            (Выписка.КоррСчет = СчетПоКоду("62.2")) Тогда
       Рез = Контрагент.НайтиПоНаименованию(Выписка.Субконто1.Наименование);
       Сообщить(Рез);
КонецЕсли;
КонецЦикла;

1. Не стоит присваивать тому, что раньше было справочником число
2. Ищите по наименованию, а подставляете ссылку."

Lady_Mo
читатель
офлайн
Дата регистрации: 25.01.2005
Сообщений: 106
Пост №3
 
15.04.2009 14:33

"А нахрена, простите за выражение искать по наименованию???
Выписка.Субконто1 - это ссылка на элемент справочника...
И вообще зачем создавать объект а потом его искать, если достачтоно просто вывести его в сообщение
Достаточно будет:
Выписка.ВыбратьСтроки();
Пока Выписка.ПолучитьСтроку() = 1 Цикл

Если (Выписка.КоррСчет = СчетПоКоду("62.1")) ИЛИ
(Выписка.КоррСчет = СчетПоКоду("62.2")) Тогда
       Сообщить(Выписка.Субконто1);
КонецЕсли;
КонецЦикла;
"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги