Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Странный элемент справочника

Duh
читатель
офлайн
Дата регистрации: 16.05.2003
Сообщений: 40
Пост №1
 
16.12.2003 12:53

"Есть проблема: в справочнике ОС (в режиме предприятия) встаю на элемент "А" - машина начинает что-то очень долго считать, но не виснет. Нашел место в Глобальном модуле, где это тормозит: глРасчетАмортизацииОС - выглядит это так:<br><br>...<br><br> КонецЕсли;<br><br> КонецЕсли;<br><br><br><br>==> ИначеЕсли ДатаМесяц(ДатаРасчета) = 12 Тогда<br><br> НачалоГода = НачГода(ДатаРасчета);<br><br> Для НомерМесяца = 1 по 12 Цикл<br><br> ДатаРеквизитов = КонМесяца(ДобавитьМесяц(НачалоГода, НомерМесяца-1));<br><br> Если ОС.НачислятьАмортизацию.Получить(ДатаРеквизитов) = 1 Тогда<br><br> БухИт.ПериодМ(НомерМесяца, ДатаГод(ДатаРасчета));<br><br> БалансоваяСтоимость = БухИт.СНД(СчетУчета,,, ОС);<br><br> НачисленныйИзнос = БухИт.СНД(СчетНачисленияАмортизации,,, ОС);<br><br> Если БухИт.СКД(СчетУчета,,, ОС) <> 0 Тогда<br><br> ОстаточнаяСтоимость = БалансоваяСтоимость - НачисленныйИзнос - РассчитаннаяАмортизацияБух;<br><br> ИзносЗаМесяц = БалансоваяСтоимость * ОС.КоэффициентАмортизации.Получить(ДатаРеквизитов) / 1200;<br><br> РассчитаннаяАмортизацияБух = РассчитаннаяАмортизацияБух + Мин(ИзносЗаМесяц, ОстаточнаяСтоимость);<br><br> КонецЕсли;<br><br> КонецЕсли;<br><br> КонецЦикла;<br><br> КонецЕсли;<br><br> РассчитаннаяАмортизацияБух = Окр(РассчитаннаяАмортизацияБух, 2, 1);<br><br> РассчитаннаяАмортизацияНалог = Окр(РассчитаннаяАмортизацияНалог, 2, 1);<br><br><br><br> СведенияОбОС = СоздатьОбъект("СписокЗначений");<br><br> СведенияОбОС.Установить("СчетУчета", СчетУчета);<br><br>...<br><br><br><br>проблемы начинаются там где "==>"<br><br>в чём дело не понятно, помогите плиззз<br><br><br><br>Спасибо!"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С