Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Странный элемент справочника

Duh
читатель
офлайн
Дата регистрации: 16.05.2003
Сообщений: 40
Пост №1
 
16.12.2003 12:53

"Есть проблема: в справочнике ОС (в режиме предприятия) встаю на элемент "А" - машина начинает что-то очень долго считать, но не виснет. Нашел место в Глобальном модуле, где это тормозит: глРасчетАмортизацииОС - выглядит это так:

...

КонецЕсли;

КонецЕсли;



==> ИначеЕсли ДатаМесяц(ДатаРасчета) = 12 Тогда

НачалоГода = НачГода(ДатаРасчета);

Для НомерМесяца = 1 по 12 Цикл

ДатаРеквизитов = КонМесяца(ДобавитьМесяц(НачалоГода, НомерМесяца-1));

Если ОС.НачислятьАмортизацию.Получить(ДатаРеквизитов) = 1 Тогда

БухИт.ПериодМ(НомерМесяца, ДатаГод(ДатаРасчета));

БалансоваяСтоимость = БухИт.СНД(СчетУчета,,, ОС);

НачисленныйИзнос = БухИт.СНД(СчетНачисленияАмортизации,,, ОС);

Если БухИт.СКД(СчетУчета,,, ОС) <> 0 Тогда

ОстаточнаяСтоимость = БалансоваяСтоимость - НачисленныйИзнос - РассчитаннаяАмортизацияБух;

ИзносЗаМесяц = БалансоваяСтоимость * ОС.КоэффициентАмортизации.Получить(ДатаРеквизитов) / 1200;

РассчитаннаяАмортизацияБух = РассчитаннаяАмортизацияБух + Мин(ИзносЗаМесяц, ОстаточнаяСтоимость);

КонецЕсли;

КонецЕсли;

КонецЦикла;

КонецЕсли;

РассчитаннаяАмортизацияБух = Окр(РассчитаннаяАмортизацияБух, 2, 1);

РассчитаннаяАмортизацияНалог = Окр(РассчитаннаяАмортизацияНалог, 2, 1);



СведенияОбОС = СоздатьОбъект("СписокЗначений");

СведенияОбОС.Установить("СчетУчета", СчетУчета);

...



проблемы начинаются там где "==>"

в чём дело не понятно, помогите плиззз



Спасибо!"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги