Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

путь к файлу

k-katerinova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 84
Пост №1
 
22.04.2009 15:02

1с7.7 Зик 253 как написать на языке 1с путь к папке в которую нужно выгрузить фал, ползователя находятся по лок.сети!?

Vladko
активный пользователь
офлайн
Дата регистрации: 27.08.2007
Сообщений: 2364
Пост №2
 
22.04.2009 15:16

"предположим, что на форму поместили текстовый реквизит "Каталог" с кнопкой выбора.
в модуле пишем:
Процедура ПриНачалеВыбораЗначения(ИД,Флаг)
Если ИД="Каталог" Тогда
Флаг = 0;
ФС.ВыбратьКаталог(Каталог,"Выберите каталог для закачки файлов");
КонецЕсли;
КонецПроцедуры //ПриНачалеВыбораЗначения()
после этого реквизит Каталог всегда будет иметь путь к папке выгрузки - его можно и использовать для формирования файлов"

k-katerinova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 84
Пост №3
 
22.04.2009 15:36

"у мен написано

Процедура ВыборКаталога(ИмяКаталога)

//Каталог = """";
//Стр = "Файл настройки (*." + Фильтр + ")|*." + Фильтр + """";

Если ФС.ВыбратьКаталог(ИмяКаталога, "Выберите каталог") = 1 Тогда
ПутьКФайлу = СокрЛП(ИмяКаталога);
КонецЕсли;

КонецПроцедуры

Процедура ПриНачалеВыбораЗначения(ИдЭлементаДиалога, Фл)

Если ИдЭлементаДиалога = "ПутьКФайлу" Тогда
      
ВыборКаталога(СокрЛП(ПутьКФайлу));

КонецЕсли;

КонецПроцедуры
"

k-katerinova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 84
Пост №4
 
22.04.2009 15:59

я мня нет кнопки путь к файлу,хотя в конфигураторе он изображается

k-katerinova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 84
Пост №5
 
22.04.2009 16:13

как тогда сделать кнопку для выбора пути к файлу выгрузки???

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8345
Пост №6
 
22.04.2009 19:22

"ПутьКФайлу" это реквизит диалога (Строка, неограниченной длинны), на закладке "Дополнительно" которого установлен флаг "Имеет кнопку выбора.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги