Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

путь к файлу

k-katerinova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 84
Пост №1
 
22.04.2009 15:02

1с7.7 Зик 253 как написать на языке 1с путь к папке в которую нужно выгрузить фал, ползователя находятся по лок.сети!?

Vladko
активный пользователь
офлайн
Дата регистрации: 27.08.2007
Сообщений: 2643
Пост №2
 
22.04.2009 15:16

"предположим, что на форму поместили текстовый реквизит "Каталог" с кнопкой выбора.<br>в модуле пишем:<br>Процедура ПриНачалеВыбораЗначения(ИД,Флаг) <br> Если ИД="Каталог" Тогда<br> Флаг = 0;<br> ФС.ВыбратьКаталог(Каталог,"Выберите каталог для закачки файлов");<br> КонецЕсли;<br>КонецПроцедуры //ПриНачалеВыбораЗначения()<br>после этого реквизит Каталог всегда будет иметь путь к папке выгрузки - его можно и использовать для формирования файлов"

k-katerinova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 84
Пост №3
 
22.04.2009 15:36

"у мен написано <br><br>Процедура ВыборКаталога(ИмяКаталога)<br> <br> //Каталог = """";<br> //Стр = "Файл настройки (*." + Фильтр + ")|*." + Фильтр + """";<br><br> Если ФС.ВыбратьКаталог(ИмяКаталога, "Выберите каталог") = 1 Тогда<br> ПутьКФайлу = СокрЛП(ИмяКаталога);<br> КонецЕсли;<br> <br>КонецПроцедуры<br><br>Процедура ПриНачалеВыбораЗначения(ИдЭлементаДиалога, Фл)<br> <br> Если ИдЭлементаДиалога = "ПутьКФайлу" Тогда<br>        <br> ВыборКаталога(СокрЛП(ПутьКФайлу));<br> <br> КонецЕсли;<br> <br>КонецПроцедуры<br>"

k-katerinova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 84
Пост №4
 
22.04.2009 15:59

я мня нет кнопки путь к файлу,хотя в конфигураторе он изображается

k-katerinova
читатель
офлайн
Дата регистрации: 07.04.2009
Сообщений: 84
Пост №5
 
22.04.2009 16:13

как тогда сделать кнопку для выбора пути к файлу выгрузки???

Денис (САМАРА)
читатель
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №6
 
22.04.2009 19:22

"ПутьКФайлу" это реквизит диалога (Строка, неограниченной длинны), на закладке "Дополнительно" которого установлен флаг "Имеет кнопку выбора.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С