Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Выбор и запрет на изменение значения из списка в форме

m0s
читатель
офлайн
Дата регистрации: 11.03.2009
Сообщений: 18
Пост №1
 
23.04.2009 16:11

"Добрый день!
Данный вопрос возник из темы здесь же http://www.buh.ru/forum/thread.jsp?id=460950 но уже более конкретен и не вполне соответствует той теме.

Вкратце, 1С ТиС 7.7, есть формы (отчеты), в которых реализованы в зависимости от группы пользователя определенные ограничения на доступность некоторых элементов данной формы (выпадающий список, кнопки и тд).

Необходимо, чтобы у одной группы форма открывалась с одним значением из этого списка без возможности его изменить (поле = фильтр, и изначально пустым, с возможностью установки только 1го значения из всех - тоже не подходит, т.е. открывается форма и там должно быть уже установлено опред.значение списка)

На данный момент, не без помощи в другой ветке форума, я представляю это себе принудительным заданием значения поля списка (только как это можно сделать?) и затем блокировкой данного списка как элемента формы следующим способом: Форма.ВыбРекв.Доступность(0);

Скажите пожалуйста, как можно выбрать значение по умолчанию для выпадающего списка в форме?
Попробовал на примере поля с идентификатором ВыбСклад но строка
ВыбСклад.ТекущаяСтрока(1);

выдает ошибку:
ВыбСклад.ТекущаяСтрока(1);
{Отчет.ОстаткиТМЦ.Форма.Модуль(146)}: Поле агрегатного объекта не обнаружено (ТекущаяСтрока)

Задаю это в том же фрагменте где и описывается доступность данных элементов в зависимости от группы т.е. процедура с некоторыми сокращениями и комментариями:

Процедура УправлениеДиалогом()

Если Форма.Закладки.ТекущаяСтрока() = 1 Тогда      
Форма.ИспользоватьСлой("Шапка,Подвал,Основной1,Основной2,Разделитель"+СокрЛП(ВидРазделителя));
Если ЦенаТовара.ПолучитьЗначение(ЦенаТовара.ТекущаяСтрока()) = "из справочника цен" Тогда
Форма.ЦенаИзСправочника.Видимость(1);
Иначе
Форма.ЦенаИзСправочника.Видимость(0);
КонецЕсли;

Иначе
Форма.ИспользоватьСлой("Шапка,МФ,Подвал");
КонецЕсли;

//begin
Если ЭтоГруппа1()=1 Тогда
// здесь сокращен....
             //здесь ВыбСклад.ТекущаяСтрока(1); -???
Форма.ВыбСклад.Доступность(0);
Форма.кнХСклад.Доступность(0);
// здесь сокращен....
Иначе
//не Группа1
КонецЕсли;
//end

КонецПроцедуры //УправлениеДиалогом()"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №2
 
24.04.2009 07:11

"> //здесь ВыбСклад.ТекущаяСтрока(1); -???
СпрСклады = СоздатьОбъект("Справочник.Склады");

Если СпрСклады.НайтиПоКоду("00001", 0) = 1 Тогда
ВыбСклад = СпрСклады.ТекущийЭлемент();
КонецЕсли;"

m0s
читатель
офлайн
Дата регистрации: 11.03.2009
Сообщений: 18
Пост №3
 
28.04.2009 14:40

Ура!! Спасибо Вам большое, то что нужно!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги