Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Код элемента справочника не уникальный!!!

gugolovski
читатель
офлайн
Дата регистрации: 29.04.2009
Сообщений: 4
Пост №1
 
29.04.2009 05:19

Помогите.
В 1С торговля-склад у справочника стоит значение: длина кода 5 символов. В базе был создан справочник под кодом 99999, при создании следущего элемента справочника, предлагается код 10000(при попытке созранится выходит сообщение "код не уникальный!"). Что делать?
с 1 по 99999 используются около 30000 элементов, как сделать чтобы 1С предлагала код из пула 1-99999, из тех что не используется.
Возможно ли сделать кнопку, чтобы 1С предлагала уникальный код?

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №2
 
29.04.2009 07:27

Можно сделать миниотчет "СвободныйКод", который будет выводить вам уникальный код из вашего "пула".

gugolovski
читатель
офлайн
Дата регистрации: 29.04.2009
Сообщений: 4
Пост №3
 
29.04.2009 07:32

"Я придумал сделать только такое, а вот как создать "отчет" или включить перебор номеров не знаю - не специалист. Кто нибудь кодом может помочь?

Процедура ПриНажатии()

Код = СчитатьКод;
СчитатьКод = ...

КонецПроцедуры"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №4
 
29.04.2009 08:37

"Процедура ПриНажатии()

ТипКода = Метаданные.Справочник("Номенклатура").ТипКода;
ДлинаКода = Метаданные.Справочник("Номенклатура").ДлинаКода;

Если ДлинаКода = 0 Тогда
Возврат;
КонецЕсли;

МаксКод = """";

СчетчикЦикла = 0;
Для СчетчикЦикла = 1 По ДлинаКода Цикл
МаксКод = МаксКод + "9";
КонецЦикла;

МаскаКода = СтрЗаменить(МаксКод, "9", "0");
МаксКод = Число(МаксКод);

СпрНоменклатура = СоздатьОбъект("Справочник.Номенклатура");

СчетчикЦикла = 0;
Для СчетчикЦикла = 1 По МаксКод Цикл

Если СчетчикЦикла % 100 = 0 Тогда
Проц = Окр(СчетчикЦикла * 100 / МаксКод);
Состояние("Определение кода: " + Проц + "%");
КонецЕсли;

Если ТипКода = "Текстовый" Тогда

ТекКод = Лев(МаскаКода, ДлинаКода - СтрДлина(Строка(СчетчикЦикла))) + СчетчикЦикла;

Иначе

ТекКод = СчетчикЦикла;

КонецЕсли;

Если СпрНоменклатура.НайтиПоКоду(ТекКод) = 0 Тогда
Код = ТекКод;
Прервать;
КонецЕсли;

КонецЦикла;

КонецПроцедуры"

gugolovski
читатель
офлайн
Дата регистрации: 29.04.2009
Сообщений: 4
Пост №5
 
29.04.2009 08:49

Большое спасибо дорогой друг - все работает. Если не сложно, то не посоветуешь как подкорректоровать код, чтобы он кода выбирал не с 1 по 99999, а с 10000 по 99999. (Мне важно чтобы код начинался с любой цифры кроме нуля).

Vladko
активный пользователь
офлайн
Дата регистрации: 27.08.2007
Сообщений: 2461
Пост №6
 
29.04.2009 09:07

в твоём случае:
.....
Для СчетчикЦикла = 10000 По МаксКод Цикл
.....
можно сделать также универсально, как и остальной код программы

gugolovski
читатель
офлайн
Дата регистрации: 29.04.2009
Сообщений: 4
Пост №7
 
29.04.2009 09:08

спасибо огромное

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №8
 
29.04.2009 09:15

...ну так напиши ему универсально, сообщение то может еще какому-нибудь "убийце автонумерации" пригодиться. :)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги