Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

1С v 7.7 Подчиненный подчиненному справочнику. Не могу выбрать элементы.

Luser
читатель
офлайн
Дата регистрации: 06.05.2009
Сообщений: 2
Пост №1
 
06.05.2009 02:46

"Суть проблемы такая. Пишу конфигурацию на основе 1С:Бухгалтерия 7.7. Возникла необходимость создать следующую структуру данных: Справочник1 <-- Справочник2 <-- Справочник3. Т.е. Справочнику1 подчинен Справочник2, которому в свою очередь подчинен Справочник3.
В модуле формы элемента Справочника1 расположена ТЗ с данными, которые заполняются при открытии из Справочника2. Необходимо при изменении данных через ТЗ и соответственно в Справочнике2 (это реализовано) вносить соответствующие изменения и в Справочик3.
...
Спр2 = СоздатьОбъект("Справочник.2");
Если Спр2.НайтиЭлемент(ТекущийЭлемент())=1 Тогда
Спр3 = СоздатьОбъект("Справочник.3");
Если Спр3.НайтиЭлемент(Спр2.ТекущийЭлемент().Владелец) = 1 Тогда
      Сообщить(Спр3.ТекущийЭлемент());
Иначе
      Сообщить("Бууууууууу");
КонецЕсли;
КонецЕсли;
...
В этом случае выводит Бууууууууу. Т.Е. не позиционирует на текущий элемент Справочника3

Если так
...
Спр2 = СоздатьОбъект("Справочник.2");
Если Спр2.НайтиЭлемент(ТекущийЭлемент())=1 Тогда
Спр3 = СоздатьОбъект("Справочник.3");
Спр3.ИспользоватьВладельца(Спр2.ТекущийЭлемент().Владелец);
Если Спр3.НайтиПоРеквизиту("ГодУчета",Период,0)=1 Тогда
Если Спр3.Выбран() > 0 Тогда
Спр3.КубыГод.Установить(ДатаВСпр, ЛгКуб);
КонецЕсли;
Иначе
Спр3.Новый();
Спр3.ГодУчета = Период;
Спр3.КубыГод.Установить(ДатаВСпр, ЛгКуб);
Спр3.Записать();
КонецЕсли;
КонецЕсли;
...
Тогда результат такой:
Если Спр3.НайтиПоРеквизиту("ГодУчета",Период,0)=1 Тогда
{Справочник.ХХХХХХ.Форма.Модуль(22)}: Неверное имя реквизита!

В общем проблема такая. Не получается из Справочника1 изменить значение элемента Справочника3.
Может кто знает, подскажите хотя бы куда рыть. Просто не очень хотелось бы менять структуру справочников"

Luser
читатель
офлайн
Дата регистрации: 06.05.2009
Сообщений: 2
Пост №2
 
06.05.2009 04:46

Всё. Спасибо. Сам разобрался.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги