Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

транзакция в 1с бухгалтерия 7.7

Фенин Иван
читатель
офлайн
Дата регистрации: 26.11.2008
Сообщений: 19
Пост №1
 
14.05.2009 14:21

"Ошибка при выполнении процедуры ЗафиксироватьТранзакцию

Вот такую ошибку пишет, когда создаю новое средство, в основных и нематериальных активах.
Код стоит Автоматически, но он его не создает. в чем может быть проблема?

Вырезка из кода

Процедура ВводНового(Копирование)
Новый = 1;
ЗначениеОтбора="""";
ИспользоватьДату('01.01.2009');
Если Копирование = 0 Тогда
Если ТипЗначенияСтр(Форма.Параметр) = "Справочник" Тогда
Владелец = Форма.Параметр;
ИначеЕсли ТипЗначенияСтр(Форма.Параметр) ="СписокЗначений" Тогда
Если ТипЗначенияСтр(Форма.Параметр.Получить("Владелец")) = "Справочник" Тогда
Владелец= Форма.Параметр.Получить("Владелец");
КонецЕсли;
Если ТипЗначенияСтр(Форма.Параметр.Получить("Родитель")) = "Справочник" Тогда
Родитель= Форма.Параметр.Получить("Родитель");
КонецЕсли;
КонецЕсли;
ВидНФА=Перечисление.ВидыНФА.ОС;
КоличественныйУчет=0;
СпособНачисленияАмортизации=3;
Иначе
СостояниеОС ="""";
ДатаПостОС =""""; НомерДокПост="""";
ДатаВводаВЭксплуатацию =""""; АктПередачВЭкспл="""";
ДатаПеремещ = """"; НомерПриказаПерем="""";
ДатаВыбытия = """"; НомАктаВыбытия="""";
ПричинаВыбытия ="""";
МестоХранения = """";
КонецЕсли;
БалансСтоимОС=0;
ОстСтоимость=0;
КоличествоОС=0;
Код="автоматически"; //Е
КонецПроцедуры "

Вячеслав-С
читатель
офлайн
Дата регистрации: 10.04.2009
Сообщений: 20
Пост №2
 
14.05.2009 14:28

">Код="автоматически"; //Е

Попробуйте без этой строчки.
А еще лучше - процитируйте текст ошибки."

Фенин Иван
читатель
офлайн
Дата регистрации: 26.11.2008
Сообщений: 19
Пост №3
 
14.05.2009 15:22

Вот такую ошибку выдает "Ошибка при выполнении процедуры ЗафиксироватьТранзакцию",
и пишет что кон не уникальный.
Как сделать так, что бы код присваивался автоматически изменяясь с созданием нового объекта?
Спасибо

Вячеслав-С
читатель
офлайн
Дата регистрации: 10.04.2009
Сообщений: 20
Пост №4
 
14.05.2009 15:23

Уберите код, который я выделил.

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №5
 
14.05.2009 15:49

"Код = УстановитьНовыйКод();
"

Антышев Влад
читатель
офлайн
Дата регистрации: 14.05.2009
Сообщений: 8
Пост №6
 
14.05.2009 19:39

1. Если автоматом не создает, значит нарушена уникальность номеров - перенумеровать !
2. В настройках справочника отключено автоматическое создание номеров ))

Фенин Иван
читатель
офлайн
Дата регистрации: 26.11.2008
Сообщений: 19
Пост №7
 
15.05.2009 08:34

"убрал строчку, которую сказали, запустил, теперь как сделать? что бы код присваивался автоматически?

подставил строчку
Код = УстановитьНовыйКод();
и теперь он выдает

Код = УстановитьНовыйКод();
процедура вызывается как функция

и обьект когда его копируешь не открывается (("

Фенин Иван
читатель
офлайн
Дата регистрации: 26.11.2008
Сообщений: 19
Пост №8
 
15.05.2009 08:36

А где настройки справочника смотреть? что бы поставить автоматическое присваивание номеров.
Спасибо

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №9
 
15.05.2009 12:01

"Извиняюсь - надо было просто написать:
УстановитьНовыйКод();
"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №10
 
15.05.2009 12:05

Отсортируйте по коду и посмотрите на них внимательно.
Я уже не помню точно как это в 7-ке, а 8-ка берет последний код и добавляет к нему 1. Отсюда проблема - если код закончился на букву, то все следующие коды будут равны ему. И если кто-то присвоил некоторому элементу максимальный код из девяток, то следующий начнет отсчет с начала и скорее всего такой уже есть.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги