Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

транзакция в 1с бухгалтерия 7.7

Фенин Иван
читатель
офлайн
Дата регистрации: 26.11.2008
Сообщений: 19
Пост №1
 
14.05.2009 14:21

"Ошибка при выполнении процедуры ЗафиксироватьТранзакцию<br><br>Вот такую ошибку пишет, когда создаю новое средство, в основных и нематериальных активах.<br>Код стоит Автоматически, но он его не создает. в чем может быть проблема?<br><br>Вырезка из кода<br><br>Процедура ВводНового(Копирование)<br>Новый = 1;<br>ЗначениеОтбора="""";<br>ИспользоватьДату('01.01.2009');<br>Если Копирование = 0 Тогда <br>Если ТипЗначенияСтр(Форма.Параметр) = "Справочник" Тогда<br>Владелец = Форма.Параметр;<br>ИначеЕсли ТипЗначенияСтр(Форма.Параметр) ="СписокЗначений" Тогда<br>Если ТипЗначенияСтр(Форма.Параметр.Получить("Владелец")) = "Справочник" Тогда <br>Владелец= Форма.Параметр.Получить("Владелец");<br>КонецЕсли;<br>Если ТипЗначенияСтр(Форма.Параметр.Получить("Родитель")) = "Справочник" Тогда <br>Родитель= Форма.Параметр.Получить("Родитель");<br>КонецЕсли;<br>КонецЕсли;<br>ВидНФА=Перечисление.ВидыНФА.ОС;<br>КоличественныйУчет=0;<br>СпособНачисленияАмортизации=3; <br>Иначе<br>СостояниеОС ="""";<br>ДатаПостОС =""""; НомерДокПост="""";<br>ДатаВводаВЭксплуатацию =""""; АктПередачВЭкспл=""""; <br>ДатаПеремещ = """"; НомерПриказаПерем="""";<br>ДатаВыбытия = """"; НомАктаВыбытия="""";<br>ПричинаВыбытия ="""";<br>МестоХранения = """";<br>КонецЕсли;<br>БалансСтоимОС=0;<br>ОстСтоимость=0;<br>КоличествоОС=0;<br>Код="автоматически"; //Е <br>КонецПроцедуры "

Вячеслав-С
читатель
офлайн
Дата регистрации: 10.04.2009
Сообщений: 20
Пост №2
 
14.05.2009 14:28

">Код="автоматически"; //Е <br><br>Попробуйте без этой строчки.<br>А еще лучше - процитируйте текст ошибки."

Фенин Иван
читатель
офлайн
Дата регистрации: 26.11.2008
Сообщений: 19
Пост №3
 
14.05.2009 15:22

Вот такую ошибку выдает "Ошибка при выполнении процедуры ЗафиксироватьТранзакцию",<br>и пишет что кон не уникальный.<br>Как сделать так, что бы код присваивался автоматически изменяясь с созданием нового объекта?<br>Спасибо

Вячеслав-С
читатель
офлайн
Дата регистрации: 10.04.2009
Сообщений: 20
Пост №4
 
14.05.2009 15:23

Уберите код, который я выделил.

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №5
 
14.05.2009 15:49

"Код = УстановитьНовыйКод();<br>"

Антышев Влад
читатель
офлайн
Дата регистрации: 14.05.2009
Сообщений: 8
Пост №6
 
14.05.2009 19:39

1. Если автоматом не создает, значит нарушена уникальность номеров - перенумеровать !<br>2. В настройках справочника отключено автоматическое создание номеров ))<br>

Фенин Иван
читатель
офлайн
Дата регистрации: 26.11.2008
Сообщений: 19
Пост №7
 
15.05.2009 08:34

"убрал строчку, которую сказали, запустил, теперь как сделать? что бы код присваивался автоматически?<br><br>подставил строчку<br> Код = УстановитьНовыйКод();<br>и теперь он выдает <br><br>Код = УстановитьНовыйКод();<br>процедура вызывается как функция<br><br>и обьект когда его копируешь не открывается (("

Фенин Иван
читатель
офлайн
Дата регистрации: 26.11.2008
Сообщений: 19
Пост №8
 
15.05.2009 08:36

А где настройки справочника смотреть? что бы поставить автоматическое присваивание номеров.<br>Спасибо

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №9
 
15.05.2009 12:01

"Извиняюсь - надо было просто написать:<br>УстановитьНовыйКод();<br>"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №10
 
15.05.2009 12:05

Отсортируйте по коду и посмотрите на них внимательно.<br>Я уже не помню точно как это в 7-ке, а 8-ка берет последний код и добавляет к нему 1. Отсюда проблема - если код закончился на букву, то все следующие коды будут равны ему. И если кто-то присвоил некоторому элементу максимальный код из девяток, то следующий начнет отсчет с начала и скорее всего такой уже есть.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С