Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Ловите 20%-18% конвертор для Бух 7.7! - просто скопировать и запустить!

Andy2C
Пост №1
Andy2C
новичок
офлайн
Пост №1
 
08.01.2004 21:05

"Процедура Сформировать()

НДС=СоздатьОбъект("Справочник.СтавкиНДС");

НДС.ВыбратьЭлементы();

Если НДС.НайтиПоРеквизиту("Ставка",18,1)=1 Тогда

НДС18=НДС.ТекущийЭлемент();

Иначе

НДС.Новый();

НДС.Ставка=18;

НДС.Наименование="18%";

НДС.Записать();

НДС18=НДС.ТекущийЭлемент();

КонецЕсли;            

Спр=СоздатьОбъект("Справочник.Номенклатура");

Спр.ВыбратьЭлементы();                        

Пока Спр.ПолучитьЭлемент()=1 Цикл

Если Спр.ТекущийЭлемент().ЭтоГруппа()=1 Тогда

Продолжить;

КонецЕсли;

Если Спр.ТекущийЭлемент().СтавкаНДС.Получить('01.01.2004').Ставка=20 Тогда

Спр.СтавкаНДС.Установить('01.01.2004',НДС18);

Спр.Записать();

КонецЕсли;

КонецЦикла;

КонецПроцедуры"

CloneS
Пост №2
CloneS
читатель
офлайн
Дата регистрации: 26.05.2003
Сообщений: 50
Пост №2
 
13.01.2004 14:22

МОЛОДЕЦ!!!

Ёжик
Пост №3
Ёжик
читатель
офлайн
Дата регистрации: 01.08.2002
Сообщений: 84
Пост №3
 
15.01.2004 12:56

можно было бы и для ТиС бросить



кстати, интересно как-то — в ТиС вместо справочника "Ставки НДС" есть Перечисление.СтавкиНДС



вот гемор



зато СтавкиНП справочник, а не перечисление!



как?

такие вот 1С'овцы засЛанцы...............

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.