Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] Функции, таблицы значений
many
Пост №1
many
Пост №1
 
01.07.2009 11:06

"Всем приветики :-)) Извините за беспокойство, я совсем новичок в 1с 7.7. Можно ли так делать или как то нуна по другому? Попросили собрать ОС по 01, 83, 84, 02,..... Я решила каждый счет прописать в функцию, а потом записать все в таблицу значений, а из неё уже выгрузить в отчет.

//________________________________________________­_­____________________________
Функция ПолучитьСумму(БИ,ТекСчет,Формула,ТекЭлСпр)
Рез=0;
БИ.ВыбратьСчета(,,1);
Если БИ.ПолучитьСчет(1,ТекСчет) = 1 Тогда
Если ПустоеЗначение(ТекЭлСпр)=0 Тогда
Если БИ.ПолучитьСубконто(1,1,ТекЭлСпр)=0 Тогда
Возврат Рез;
КонецЕсли;
КонецЕсли;
Если Формула="СНД" Тогда
Рез = БИ.СНД();
ИначеЕсли Формула="СНК" Тогда
Рез = БИ.СНК();
ИначеЕсли Формула="СКК" Тогда
Рез = БИ.СКК();
ИначеЕсли Формула="СКД" Тогда
Рез = БИ.СКД();
ИначеЕсли Формула="КО" Тогда
Рез = БИ.КО();

Если БИ.ПолучитьКорСчет(СчетПоКоду("01",ПланыСчетов.Основной)) = 1 Тогда
Рез=Рез-БИ.КорДО();
КонецЕсли;

Если БИ.ПолучитьКорСчет(СчетПоКоду("83",ПланыСчетов.Основной)) = 1 Тогда
Рез=Рез-БИ.КорДО();
КонецЕсли;
КонецЕсли;
КонецЕсли;
Возврат Рез;
КонецФункции

//*******************************************
Процедура Сформировать()


БИ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьПланСчетов(ПланыСчетов.Основной);
БИ.ВключатьСубсчета(1,1);
БИ.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства);

Таб=СоздатьОбъект("Таблица");
ТабЗнач=СоздатьОбъект("ТаблицаЗначений");
ТабЗначИтог=СоздатьОбъект("ТаблицаЗначений");
Таб.ИсходнаяТаблица("Таблица");

// Создадим структурированную таблицу
ТабЗнач = СоздатьОбъект ("ТаблицаЗначений");
ТабЗнач.НоваяКолонка("ОС","Число",19,2);
ТабЗнач.НоваяКолонка("Первонач","Число",19,2);
ТабЗнач.НоваяКолонка("Реконструкция","Число",19,2);

ТабЗнач.НаимОС = БИ.Субконто(ВидыСубконто.ОсновныеСредства).Наименование;
ТабЗнач.ПервоначСтоим = ПолучитьСумму(БИ,"83","КО",ТабЗнач);
ТабЗнач.Реконструкция = ПолучитьСумму(БИ,"01","КО",ТабЗнач);

КонецПроцедуры
"

 
many
Пост №1
01.07.2009 11:06
 

"Всем приветики :-)) Извините за беспокойство, я совсем новичок в 1с 7.7. Можно ли так делать или как то нуна по другому? Попросили собрать ОС по 01, 83, 84, 02,..... Я решила каждый счет прописать в функцию, а потом записать все в таблицу значений, а из неё уже выгрузить в отчет.

//________________________________________________­_____________________________
Функция ПолучитьСумму(БИ,ТекСчет,Формула,ТекЭлСпр)
Рез=0;
БИ.ВыбратьСчета(,,1);
Если БИ.ПолучитьСчет(1,ТекСчет) = 1 Тогда
Если ПустоеЗначение(ТекЭлСпр)=0 Тогда
Если БИ.ПолучитьСубконто(1,1,ТекЭлСпр)=0 Тогда
Возврат Рез;
КонецЕсли;
КонецЕсли;
Если Формула="СНД" Тогда
Рез = БИ.СНД();
ИначеЕсли Формула="СНК" Тогда
Рез = БИ.СНК();
ИначеЕсли Формула="СКК" Тогда
Рез = БИ.СКК();
ИначеЕсли Формула="СКД" Тогда
Рез = БИ.СКД();
ИначеЕсли Формула="КО" Тогда
Рез = БИ.КО();

Если БИ.ПолучитьКорСчет(СчетПоКоду("01",ПланыСчетов.Основной)) = 1 Тогда
Рез=Рез-БИ.КорДО();
КонецЕсли;

Если БИ.ПолучитьКорСчет(СчетПоКоду("83",ПланыСчетов.Основной)) = 1 Тогда
Рез=Рез-БИ.КорДО();
КонецЕсли;
КонецЕсли;
КонецЕсли;
Возврат Рез;
КонецФункции

//*******************************************
Процедура Сформировать()


БИ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьПланСчетов(ПланыСчетов.Основной);
БИ.ВключатьСубсчета(1,1);
БИ.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства);

Таб=СоздатьОбъект("Таблица");
ТабЗнач=СоздатьОбъект("ТаблицаЗначений");
ТабЗначИтог=СоздатьОбъект("ТаблицаЗначений");
Таб.ИсходнаяТаблица("Таблица");

// Создадим структурированную таблицу
ТабЗнач = СоздатьОбъект ("ТаблицаЗначений");
ТабЗнач.НоваяКолонка("ОС","Число",19,2);
ТабЗнач.НоваяКолонка("Первонач","Число",19,2);
ТабЗнач.НоваяКолонка("Реконструкция","Число",19,2);

ТабЗнач.НаимОС = БИ.Субконто(ВидыСубконто.ОсновныеСредства).Наименование;
ТабЗнач.ПервоначСтоим = ПолучитьСумму(БИ,"83","КО",ТабЗнач);
ТабЗнач.Реконструкция = ПолучитьСумму(БИ,"01","КО",ТабЗнач);

КонецПроцедуры
"

 
Thorvardr
Пост №2
"Может и так будет работать, но я бы проще делал, ...
01.07.2009 13:36
 
 
many
Пост №3
"в этом месте они завязываются между собой или нет...
01.07.2009 15:15
 
 
Thorvardr
Пост №4
"выгружать в будущем можно:БухИт.ВыбратьСчета();По...
01.07.2009 15:49
 
 
many
Пост №5
"Если мне нужно к примеру так:первоначальная стоим...
01.07.2009 16:22
 
 
many
Пост №6
И еще чтобы прописать проводку - Д01 К83 через БИ....
01.07.2009 16:25
 
 
Thorvardr
Пост №7
"> первоначальная стоимость = ДО(01);> амортизация...
01.07.2009 18:21
 
 
many
Пост №8
Что за желтая книжка? и ЖКК??тогда будет много зап...
01.07.2009 18:54
 
 
Thorvardr
Пост №9
ЖКК (желтокрасные книжки) и желтая книжка - словая...
01.07.2009 19:05
 
 
many
Пост №10
Если запроса будет 2 их как то нужно называть 1 и ...
01.07.2009 19:11
 
 
Thorvardr
Пост №11
"БухИт1=СоздатьОбъект("БухгалтерскиеИтоги");БухИт1...
01.07.2009 21:03
 
 
many
Пост №12
я тоже так думала по началу, но только потом я зам...
02.07.2009 03:12
 
 
many
Пост №13
"Вы с функциями не работали?? может как-нить через...
02.07.2009 03:24
 
 
Thorvardr
Пост №14
мой вариант более быстрый и читабельный, мне кажет...
02.07.2009 13:24
 
 
many
Пост №15
"мне тоже он больше нравиться!!! Только что с этим...
03.07.2009 03:47
 
 
many
Пост №16
"БИ = СоздатьОбъект("БухгалтерскиеИтоги");БИ.Испол...
03.07.2009 05:30
 
 
many
Пост №17
я вот еще, что подумала может вот эту группировку ...
03.07.2009 07:36
 
 
Thorvardr
Пост №18
Что то вы всего туда написали и даже 3 раза к бухи...
03.07.2009 11:28
 
 
many
Пост №19
Группу основных средствГруппу, которая иерархическ...
03.07.2009 18:32
 
 
Thorvardr
Пост №20
"Простите, стормозил. Все можно запихать в один за...
05.07.2009 10:18
 
 
many
Пост №21
Эх, зато я дура, всё также пишу изменяя на своё. В...
05.07.2009 12:17
 
 
Thorvardr
Пост №22
Пробните мою писанину :)
05.07.2009 12:37
 
 
many
Пост №23
Это совсем наверно будет, попросить у вас макет ? ...
05.07.2009 12:50
 
 
Thorvardr
Пост №24
Ок, сейчас сделаю. Куда выслать?
05.07.2009 15:02
 
 
many
Пост №25
пасибки :-)))) nany11@mail.ru
05.07.2009 15:13
 
 
Thorvardr
Пост №26
Выслал... Все таки вышло два запроса, с одним - ци...
05.07.2009 15:43
 
 
many
Пост №27
пасибки :-))) действительно всё получается :-)) ос...
05.07.2009 16:24
 
 
many
Пост №28
"а откуда Вы знаете про эту функцию или как она по...
05.07.2009 16:40
 
 
Thorvardr
Пост №29
ммм, не совсем понятно. Как бы это сказать... Эту ...
05.07.2009 18:26
 
 
many
Пост №30
понятно :-))), действительно очень удобная функция...
05.07.2009 18:32
 
 
many
Пост №31
"Как Вы думаете я правильно написала запрос?ТекстЗ...
05.07.2009 18:41
 
 
many
Пост №32
не выводиться.
05.07.2009 19:12
 
 
Thorvardr
Пост №33
"Не, неправильно. Вы лучше запрос оставьте как был...
05.07.2009 19:53
 
 
many
Пост №34
пасибки :-)), нашла на какую сумму и почему не схо...
05.07.2009 20:00
 
 
many
Пост №35
Надеюсь последний вопрос. Есть какая-нибудь быстра...
05.07.2009 20:02
 
 
many
Пост №36
"добавляю в запрос дату ввода, выводит пустую ячей...
05.07.2009 20:32
 
 
many
Пост №37
Дату ввода в эксплуатацию придумала как вводить, с...
05.07.2009 20:37
 
 
Thorvardr
Пост №38
"Если описать функции внутри первого текстового за...
05.07.2009 20:51
 
 
many
Пост №39
"ном = 0; ИтБалансоваяСтоимость=0;ИтИзнос=0;...
05.07.2009 21:09
 
 
Thorvardr
Пост №40
"ну дык... само собой!ИтБалансоваяСтоимость=ИтБала...
05.07.2009 21:25
 
 
many
Пост №41
"Представляете всё вчера работало, загнала в больш...
06.07.2009 04:38
 
 
Thorvardr
Пост №42
"Берем отладчик и вперед...либо Запрос.СрокПолСтои...
06.07.2009 07:57
 
 
many
Пост №43
можете мне посоветовать какую-нибудь толковую книг...
06.07.2009 08:50
 
 
many
Пост №44
Всё-таки что это может быть когда сохраняешь в Exc...
06.07.2009 08:55
 
 
Thorvardr
Пост №45
Попробуйте обмануть Excel (он сильно умный и в сам...
06.07.2009 09:10
 
 
many
Пост №46
Ржу нимагу, представляешь сегодня вычитала для тог...
06.07.2009 11:15
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании авансовый платеж автозаполнение реквизитов Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безвозмездная передача имущества безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм взыскание налогов видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты возмещение расходов восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты по ГПД выплаты работникам выплаты физическим лицам вычет НДС вычет по НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация гражданско-правовой договор графики работы дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественные налоги имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лекарственные препараты лизинг лизинговое имущество ликвидация организации лицензирование малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая задолженность налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговая ставка налоговое администрирование налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый вычет по ндфл налоговый контроль налоговый мониторинг налоговый учет налоговый учет расходов налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нулевая ставка обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязанности налогоплательщика обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность в фсс отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы передача имущества перенос убытков персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подача уведомления подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверки бизнеса продажа алкогольной продукции прожиточный минимум производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандартный налоговый вычет стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура табачные изделия таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность УКД универсальный корректировочный документ УПД уплата госпошлины уплата налога уплата налогов уплата НДС уплата сбора упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет реализации учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги