Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Запрос к регистру не работает

AL4
читатель
офлайн
Дата регистрации: 20.01.2004
Сообщений: 1
Пост №1
 
20.01.2004 11:56

"Почему-то не работает простой запрос к регистру (с измерениями Товар, Поставщик и ресурсом Количество).<br><br>Мне нужно просто получить список Товаров полученных.<br><br>Может это можно сделать как-то другим способом?<br><br><br><br>Процедура Пуск1() <br><br> НашЗапрос = СоздатьОбъект("Запрос");<br><br> ТекстЗапроса =<br><br> "Товар = Регистр.Партии.Товар;<br><br> |Группировка Товар Упорядочить По Товар.Наименование;<br><br> |";<br><br> Если НашЗапрос.Выполнить(ТекстЗапроса) = 0 Тогда<br><br> Возврат;<br><br> КонецЕсли;<br><br> НашЗапрос.ВНачалоВыборки();<br><br> Пока НашЗапрос.Группировка("Товар") = 1 Цикл<br><br> сообщить(НашЗапрос.Товар);<br><br> КонецЦикла;<br><br>КонецПроцедуры"

Kok
читатель
офлайн
Дата регистрации: 12.09.2003
Сообщений: 25
Пост №2
 
21.01.2004 17:51

А где период запроса (хотябы текущий день)?<br><br><br><br><br><br>

klmn
читатель
офлайн
Дата регистрации: 22.01.2004
Сообщений: 3
Пост №3
 
22.01.2004 14:38

"Процедура Пуск1() <br><br>НашЗапрос = СоздатьОбъект("Запрос"); <br><br>ТекстЗапроса = <br><br>"Товар = Регистр.Партии.Товар;<br><br>|Кол= Регистр.Партии.ХХХ;<br><br>|Функция КонКол= КонОст(Кол);<br><br>|Группировка Товар Упорядочить По Товар.Наименование; <br><br>|"; <br><br>Если НашЗапрос.Выполнить(ТекстЗапроса) = 0 Тогда <br><br>Возврат; <br><br>КонецЕсли; <br><br>НашЗапрос.ВНачалоВыборки(); <br><br>Пока НашЗапрос.Группировка("Товар") = 1 Цикл <br><br>сообщить(НашЗапрос.Товар); <br><br>КонецЦикла; <br><br>КонецПроцедуры <br><br><br><br>ХХХ - какй нибудь ресурс из регистра.Партии <br><br>(Без функции запрос не будет выполняться)<br><br>З.Ы. будут еще вопросы - пишите."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С