Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Запрос к регистру не работает

AL4
Пост №1
AL4
читатель
офлайн
Дата регистрации: 20.01.2004
Сообщений: 1
Пост №1
 
20.01.2004 11:56

"Почему-то не работает простой запрос к регистру (с измерениями Товар, Поставщик и ресурсом Количество).

Мне нужно просто получить список Товаров полученных.

Может это можно сделать как-то другим способом?



Процедура Пуск1()

НашЗапрос = СоздатьОбъект("Запрос");

ТекстЗапроса =

"Товар = Регистр.Партии.Товар;

|Группировка Товар Упорядочить По Товар.Наименование;

|";

Если НашЗапрос.Выполнить(ТекстЗапроса) = 0 Тогда

Возврат;

КонецЕсли;

НашЗапрос.ВНачалоВыборки();

Пока НашЗапрос.Группировка("Товар") = 1 Цикл

сообщить(НашЗапрос.Товар);

КонецЦикла;

КонецПроцедуры"

Kok
Пост №2
Kok
читатель
офлайн
Дата регистрации: 12.09.2003
Сообщений: 25
Пост №2
 
21.01.2004 17:51

А где период запроса (хотябы текущий день)?





klmn
Пост №3
klmn
читатель
офлайн
Дата регистрации: 22.01.2004
Сообщений: 3
Пост №3
 
22.01.2004 14:38

"Процедура Пуск1()

НашЗапрос = СоздатьОбъект("Запрос");

ТекстЗапроса =

"Товар = Регистр.Партии.Товар;

|Кол= Регистр.Партии.ХХХ;

|Функция КонКол= КонОст(Кол);

|Группировка Товар Упорядочить По Товар.Наименование;

|";

Если НашЗапрос.Выполнить(ТекстЗапроса) = 0 Тогда

Возврат;

КонецЕсли;

НашЗапрос.ВНачалоВыборки();

Пока НашЗапрос.Группировка("Товар") = 1 Цикл

сообщить(НашЗапрос.Товар);

КонецЦикла;

КонецПроцедуры



ХХХ - какй нибудь ресурс из регистра.Партии

(Без функции запрос не будет выполняться)

З.Ы. будут еще вопросы - пишите."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.