Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

1с 7.7 Бухгалтерия Подскажите как заполнить значениями таблицу Печатной формы?

Leonardo2009
читатель
офлайн
Дата регистрации: 13.04.2009
Сообщений: 100
Пост №1
 
12.08.2009 14:59

"Сделал отчет "Возврат товаров", все данные получены, но встал вопрос каким методом их заполнить в таблицу.

вот код отчета:
Процедура Выполнить()

Док=СоздатьОбъект("Документ.РасходнаяНакладная");
Док.ВыбратьДокументы(Дата1,Дата2);

Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("""");            
Таб.ВывестиСекцию("Шапка");

Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.ВозвратГП=1 Тогда
ДатаПер=Док.ПолучитьАтрибут("ДатаДок");
НомерДока=Док.ПолучитьАтрибут("НомерДок");
Контр=Док.ПолучитьАтрибут("Контрагент");
Док.ВыбратьСтроки();
Если Док.КоличествоСтрок()>0 Тогда
Пока Док.ПолучитьСтроку()=1 Цикл

Тов=Док.ПолучитьАтрибут("Товар");
Км=Док.ПолучитьАтрибут("Количество");
К=Км*(-1);
Таб.ВывестиСекцию("Строка|Строка1");

КонецЦикла;
КонецЕсли;
КонецЕсли;


КонецЦикла;
// Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,0,0);
Таб.Показать("""");

КонецПроцедуры

таблица должна иметь следующий вид.
       | товар | товар | товар | товар | товар
контрагент число число ... ... ...
контрагент ... ... ... ... ...
контрагент ... ... ... ... ...

Если кто знает подскажите, оч. буду благодарен."

Prikum
активный пользователь
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20575
Пост №2
 
12.08.2009 15:26

Трудности то в чем?

Leonardo2009
читатель
офлайн
Дата регистрации: 13.04.2009
Сообщений: 100
Пост №3
 
12.08.2009 16:29

Тудность в том что номенклатуры много, нужно чтобы заполнение таблица было автоматическим, то есть что бы и контрагенты и возвращаемые им товары и их колличество заполнялось автоматически в виде таблицы, а в моем коде выводится простым списком. Возможно нужно использлвать Таблицу Значений или Список значений только я вот не могу сообразить как это сделать(

Prikum
активный пользователь
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20575
Пост №4
 
12.08.2009 16:33

Есть такое дело, как конструктор запросов, в том числе и на 7.7! Попробуйте его!

Leonardo2009
читатель
офлайн
Дата регистрации: 13.04.2009
Сообщений: 100
Пост №5
 
12.08.2009 20:28

"С помощью макета печатных форм получилось=>
код:
Процедура Сформировать_Колонки(Таб, Стр, Док)
Таб.ВывестиСекцию(Стр+"|Начало");
Док.ВыбратьСтроки();
Если Док.КоличествоСтрок()>0 Тогда
Пока Док.ПолучитьСтроку()=1 Цикл

Тов=Док.ПолучитьАтрибут("Товар");
Км=Док.ПолучитьАтрибут("Количество");
К=Км;
Таб.ПрисоединитьСекцию(Стр+"|Колонка_1");
КонецЦикла;
КонецЕсли;
Таб.ПрисоединитьСекцию(Стр+"|Конец");
КонецПроцедуры

Процедура Сформировать()
Док=СоздатьОбъект("Документ.РасходнаяНакладная");
Док.ВыбратьДокументы("01.05.09","31.05.09");
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Таб.ВывестиСекцию("Заголовок");
Сформировать_Колонки(Таб, "Шапка",Док);
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.ВозвратГП=1 Тогда
Дат=Док.ПолучитьАтрибут("ДатаДок");
Контр=Док.ПолучитьАтрибут("Контрагент");
Таб.ВывестиСекцию("Строка1");
Сформировать_Колонки(Таб, "Строка_1",Док);
КонецЕсли;
КонецЦикла;
Сформировать_Колонки(Таб, "Подвал",Док);
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать","""");
КонецПроцедуры

печатается так:


      
контрагент1 Номенклатура1 Номенклатура2
                   Кол-во       Кол-во
контрагент2 Номенклатура3 Номенклатура4                        
                   Кол-во       Кол-во
контрагент3 Номенклатура2                                    
                   Кол-во
контрагент4 Номенклатура4 Номенклатура5 Номенклатура6
                   Кол-во       Кол-во       Кол-во
контрагент5 ...                                                      
...


но должно быть так:

             Номенклатура1 Номенклатура2 Номенклатура3 Номенклатура4 Номенклатура5 ...
контрагент1       Кол-во      Кол-во
контрагент2                   Кол-во                                    Кол-во
контрагент3                                                Кол-во
контрагент4
контрагент5                                                             Кол-во
...


Понимаю конечн, что голову можно сломать, но если кто нибудь разберется большое спасибо.
"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
13.08.2009 10:56

делай запросом!

пришли скрин макета в конфигураторе - накатаю тебе текст запроса

Leonardo2009
читатель
офлайн
Дата регистрации: 13.04.2009
Сообщений: 100
Пост №7
 
13.08.2009 11:07

Куда тебе прислать???

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №8
 
13.08.2009 11:53

> Куда тебе прислать???

ссуда нельзя ссылку на radikal.ru выложить?

Leonardo2009
читатель
офлайн
Дата регистрации: 13.04.2009
Сообщений: 100
Пост №9
 
13.08.2009 12:05

http://s39.radikal.ru/i085/0908/6b/ce5882fdfede.png

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №10
 
13.08.2009 13:39

кстати обычным запрос кажись не так просто...

а почему ты не хочешь использовать бух запрос?
и анализировать 41.1 60.1 ?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги