Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

7.7 Вывод в отчет значений реквизитов регистров

Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №1
 
11.01.2010 12:01

"|Период с ВыбНач по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Без итогов;
|КредитныйДокумент = Регистр.НачислениеПроцентов.КредитныйДокумент, Регистр.ПеняПоПроцентам.КредитныйДокумент, Регистр.НачислениеОД.КредитныйДокумент, Регистр.ПеняПоОД.КредитныйДокумент;
|Договор = Регистр.ПеняПоОД.Договор, Регистр.ПеняПоПроцентам.Договор, Регистр.НачислениеПроцентов.Договор, Регистр.НачислениеОД.Договор;
|СуммаПроц = Регистр.НачислениеПроцентов.Сумма;
|СуммаОД = Регистр.НачислениеОД.Сумма;
|СуммаПеняПроц = Регистр.ПеняПоПроцентам.Сумма;
|СуммаПеняОД = Регистр.ПеняПоОД.Сумма;
|ПроцентыРасчетнаяСумма = Регистр.НачислениеПроцентов.РасчетнаяСумма; // ЭТО РЕКВИЗИТ
|ПеняПроцРасчетнаяСумма = Регистр.ПеняПоПроцентам.РасчетнаяСумма;// ЭТО РЕКВИЗИТ
|ПеняОДРасчетнаяСумма = Регистр.ПеняПоОД.РасчетнаяСумма;// ЭТО РЕКВИЗИТ
|Функция СуммаПроцПриход = Приход(СуммаПроц);
|Функция СуммаОДПриход = Приход(СуммаОД);
|Функция СуммаПеняПроцПриход = Приход(СуммаПеняПроц);
|Функция СуммаПеняОДПриход = Приход(СуммаПеняОД);
|Группировка Договор без групп;
|Группировка КредитныйДокумент без групп;
|Группировка Месяц;
|Группировка Документ;
|Условие(Договор в ВыбДоговор);
|Условие(КредитныйДокумент = ВыбКредитныйДокумент.ДокументВыдачи);

Вот текст запроса, однако при выводе таблицы выводится только один из реквизитов, сначала "ПроцентыРасчетнаяСумма", потом как только появляются суммы по "СуммаПеняПроцПриход", выводится реквизит ПеняПроцРасчетнаяСумма, а "ПроцентыРасчетнаяСумма" равен нулю и тд.

ВОПРОС - как выводить реквизиты по всем регистрам, без обнуления?
СПАСИБО ЗАРАНЕЕ.
"

Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №2
 
11.01.2010 16:59

кто-нибудь поможет?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №3
 
11.01.2010 17:47

"вы их в конструкцию Функция поместите. То есть, будет что то вроде такого:
|ПроцентыРасчетнаяСумма = Регистр.НачислениеПроцентов.РасчетнаяСумма; // ЭТО РЕКВИЗИТ
|ПеняПроцРасчетнаяСумма = Регистр.ПеняПоПроцентам.РасчетнаяСумма;// ЭТО РЕКВИЗИТ
|ПеняОДРасчетнаяСумма = Регистр.ПеняПоОД.РасчетнаяСумма;// ЭТО РЕКВИЗИТ
|Функция СуммаПроцентыРасчетнаяСумма = Приход(ПроцентыРасчетнаяСумма);
|Функция СуммаПеняПроцРасчетнаяСумма = Приход(ПеняПроцРасчетнаяСумма);
|Функция СуммаПеняОДРасчетнаяСумма = Приход(ПеняОДРасчетнаяСумма);
...

В общем, это все от того, что по идее, внутренние переменные запроса не должны быть видны в дальнейшем через Запрос.ВнутренняяПеременная, а видны должны быть только те переменные, по которым была группировка и результаты функций. 1С, к сожалению, не блокирует обращиние к ним, в результате возникает "ложная надежда", что таким образом можно достать какие то данные"

Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №4
 
11.01.2010 17:57

Спасибо! Получилось, а я думал что складывать будет, и даже на попробовал))

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №5
 
11.01.2010 20:43

"Конечно складывать будет, по всем группировкам, которые у вас есть и будет сложение. Далее при переборе результатов запроса вы получите итоги и по месяцу и по договору и т.п.
|Группировка Договор без групп;
|Группировка КредитныйДокумент без групп;
|Группировка Месяц;
|Группировка Документ;
"

Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №6
 
12.01.2010 09:46

Ресурсы складывает, это ясно. Реквизиты нет - именно этого добивался))))

Lon
читатель
офлайн
Дата регистрации: 20.04.2012
Сообщений: 13
Пост №7
 
14.11.2012 10:47

Добрый день

Это если реквизит типа "число", а если это элемент тип реквизита "справочник"? Тогда что делать? При попытке вставить в функцию будет, естественно, ошибка запроса... Подскажите, плз, как же вывести такие реквизиты

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №8
 
14.11.2012 10:53

"> как же вывести такие реквизиты

ТекстЗапроса="Товар=Справочник.Номенклатура.ТекущийЭлемент;
             |Группировка Товар без групп без упорядочивания;";
Запрос=СоздатьОбъект("Запрос");
Если Запрос.Выполнить(ТекстЗапроса)=1 Тогда
Пока Запрос.Группировка(1)=1 Цикл
      Сообщить(Запрос.Товар);
КонецЦикла;
КонецЕсли;



Для примера текст своего запроса напишите."

Lon
читатель
офлайн
Дата регистрации: 20.04.2012
Сообщений: 13
Пост №9
 
14.11.2012 11:06

"Точный текст запроса дома, но смысл такой:

      |Фирма= Регистр.Цены.Фирма;
      |Номенклатура= Регистр.Цены.Номенклатура;
      |Контрагент= Регистр.Цены.Контрагент;
      |Цена= Регистр.Цены.Цена;
      |Валюта= Регистр.Цены.Валюта; // ЭТО РЕКВИЗИТ
      |Единица= Регистр.Цены.Единица; // ЭТО РЕКВИЗИТ
      |Функция КонОстЦена= КонОст(Цена);
      |Условие(Договор в ВыбДоговор);
      |Группировка Номенклатура без групп;
      |Группировка Контрагент без групп;

Запрос=СоздатьОбъект("Запрос");
Если Запрос.Выполнить(ТекстЗапроса)=1 Тогда
Пока Запрос.Группировка("Номенклатура")=1 Цикл
Пока Запрос.Группировка("Контрагент")=1 Цикл
       Сообщить("Номенклатура: "+Запрос.Номенклатура+" Контрагент: "+Запрос.Контрагент+" Цена "+Запрос.Цена);
       Сообщить("Валюта: "+Запрос.Валюта+" Единица: "+Запрос.Единица); // вот эта строка ничего не выводит
КонецЦикла;
КонецЦикла;
КонецЕсли;

Примерно так -я хочу увидеть значения Валюты и Единицы - а мне запрос ничего не показывает (в регистре данная информация присутствует - проверял)"

Lon
читатель
офлайн
Дата регистрации: 20.04.2012
Сообщений: 13
Пост №10
 
14.11.2012 11:07

"|Условие(Договор в ВыбДоговор); - вместо этой строки:


      |Условие(Фирма=ВыбФирма);"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги