Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Почему 1980-ый?

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №1
 
13.01.2010 07:55

Вот возник такой вопрос, почему когда создаем НОВУЮ номенклатуру или ос, ПЕРВАЯ запись в истории ставится на 1980-ый (или 60-ый) года, так прописано в коде, почему не той датой, которой создается карточка, или той, которую мы указываем "периодические реквизиты указаны на дату..." Может есть какой-то особый смысл? :)

Gars
читатель
офлайн
Дата регистрации: 28.05.2007
Сообщений: 207
Пост №2
 
13.01.2010 14:47

Олимпиада?
:-)

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
13.01.2010 15:30

"> Вот возник такой вопрос, почему когда создаем НОВУЮ номенклатуру или ос, ПЕРВАЯ запись в истории ставится на 1980-ый (или 60-ый) года, так прописано в коде, почему не той датой, которой создается карточка, или той, которую мы указываем "периодические реквизиты указаны на дату..." Может есть какой-то особый смысл? :)

всё просто :
1. в номенклатуре есть следующие строки:
Процедура ВводНового(Копирование)

ИспользоватьДату('01.01.1980');
       ///...
КонецПроцедуры

2. в обработке Запись периодических реквизит - следующие:
Процедура ПриОткрытии()

Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" Тогда
КонтекстФормы = Форма.Параметр.Получить("КонтекстФормы");
СписокРеквизитов = Форма.Параметр.Получить("СписокРеквизитов");
НоваяДата       = Дата(Форма.Параметр.Получить("НоваяДата"));
ПерваяДата       = Дата(Форма.Параметр.Получить("ПерваяДата"));
СвязьРеквизитов = Число(Форма.Параметр.Получить("СвязьРеквизитов"));
КонецЕсли;

Форма.Параметр = 0;

//...

Если НоваяДата = '00.00.0000' Тогда // реквизит диалога - всегда дата
НоваяДата = КонтекстФормы.ИспользоватьДату();
КонецЕсли;
//...
КонецПроцедуры"

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №4
 
13.01.2010 16:40

что бы пользователи не накосячили
например в в документах которые создаются более ранним числом чем элемент справочника

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №5
 
13.01.2010 16:56

> что бы пользователи не накосячили
> например в в документах которые создаются более ранним числом чем элемент справочника

это какой например в 21 веке ?

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №6
 
13.01.2010 18:11

какой пользователь или какой документ?

Алекс Crazy
читатель
офлайн
Дата регистрации: 13.01.2010
Сообщений: 83
Пост №7
 
14.01.2010 00:24

> что бы пользователи не накосячили
> например в в документах которые создаются более ранним числом чем элемент справочника

а не проше выставить дату запрета редактирования документов, как выразился автор 21 веком?

но автор говорит о реквизита номенклатуры

автор прорвете рабочию дату, так на всякий случай :)
параметра/ общее/ рабочая дата

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №8
 
14.01.2010 08:16

> что бы пользователи не накосячили
> например в в документах которые создаются более ранним числом чем элемент справочника

наверное этот ответ наиболее верный. Если история будет начинаться например рабочей датой (2010) годом, то если будем делать док.поступление за 2009 год и введем там через таблицу в справочник ос, то в карточке как-то запись некорректно встает, выше строки с 2010-ым, стоит пустая строка с нулями и дата поступления не заносится вообще...
наверное выбрали, что уж точно никто документы делать раньше 60-го не будет.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги