Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

1С Бюджет 7.7 Кнопка (Печать)

Denius61rus
читатель
офлайн
Дата регистрации: 26.03.2009
Сообщений: 25
Пост №1
 
11.02.2010 09:17

При нажатии на кнопку печать в любом документе например Доверенность или Заявка на кассовый расход, в табличной части внизу где стоит руководитель и главный бухгалтер, должно прописывать из справочника Фамилию и инициалы, у меня почему то сокращает и фамилию, тоесть пишет И.А.В. сокращается всё, дело в том что заявку на кассовый расход казначейство принимает с инициалами перед фамилией, а в расходных расписаниях инициалы после фамилии, поэтому в справочнике физ. лица и сотрудники у меня идут сначало инициалы потом фамилия А.В. Иванов, как же сделать так чтобы правильно из справочников вытаскивала фамилию и инициалы принажатии кнопки печать?
выгрузка в СЭД проходит нормально, а вот печать :( подскажите пожалуйста
конечно можно хирургическим путём все поправить и в таблице прописать, но это же не порядок...

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №2
 
11.02.2010 10:09

А внешнюю печатную форму сделать не пробовали?

Denius61rus
читатель
офлайн
Дата регистрации: 26.03.2009
Сообщений: 25
Пост №3
 
11.02.2010 10:42

Ну если бы знал что это такое (внешняя печатная форма), то попробывал бы...

Metelkina
читатель
офлайн
Дата регистрации: 30.05.2009
Сообщений: 513
Пост №4
 
11.02.2010 10:48

В справочнике физ.лиц фио должно быть прописано полностью: фамилия имя отчество. В этом случае все инициалы расставляются правильно в каждом док-те

Denius61rus
читатель
офлайн
Дата регистрации: 26.03.2009
Сообщений: 25
Пост №5
 
11.02.2010 11:15

Так то оно так, должно быть по идее, но это работает только в таком виде Иванов А.В. в примере с Расходным расписанием...
а что же делать если казначество требует чтобы в платежке в ФИО руководителя и главбуха сначало стояли инициалы потом фамилия!!!??? объясняеться это тем что по приказу 8Н уже задолбались с ними воевать, отказуют платёжки и все тут, пока сам не почитал эти приказы, тогда своими глазами увидил этот маразм, в Расходных расписаниях (Иванов А.В.) в Заявке на кассовый расход (А.В. Иванов) и что теперь делать??? программа не проставляет правильно как надо поэтому пришлось завести в справочнике ФИО руководства в таком формате А.В. Иванов

может кто напишет пример как должно быть написано в шаблоне выгрузки Казначейство_ВыгрузкаФК - ФTXZR090810 - NAME_RUK_UBP - ?? что должно быть написано? у меня стояло ФИОПодпись-Сотрудник-Руководитель, и при выгрузке один инициал куда то терялся, я убрал Подпись и оставил ФИО, и стало выгружать в СЭД с инициалами как в справочнике, но появилась эта проблема о которой я писал, но я думаю это не связано

у меня стоит Бух для бюджетных учреждений 7.70.635
может кто знает где поправить чтобы наконец то все стало на свои места, если бы не заморочки казначейства, то и проблемы не было!!!

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
11.02.2010 11:53

"есть типовая глобальная функция :


Функция глФИО(Сотрудник, ВидФИО=0) Экспорт

Перем ПолноеИмя, Фамилия, ИмяОтчество, Имя, Отчество;
Перем ПозицияПервогоПробела, ПозицияВторогоПробела;
ПолноеИмя = СокрЛП(Сотрудник);
Если ПустоеЗначение(ПолноеИмя)=0 Тогда

ПозицияПервогоПробела = Найти(ПолноеИмя, " ");
Если ПозицияПервогоПробела = 0 Тогда
Возврат ПолноеИмя;
Иначе
Фамилия = Лев(ПолноеИмя, ПозицияПервогоПробела);
ИмяОтчество = Сред(ПолноеИмя, ПозицияПервогоПробела+1);
ИмяОтчество = СокрЛ(ИмяОтчество);
Имя = Лев(ИмяОтчество, 1)+".";

ПозицияВторогоПробела = Найти(ИмяОтчество, " ");
Если ПозицияВторогоПробела = 0 Тогда
Если ВидФИО=0 Тогда
Возврат Фамилия+Имя;
Иначе
Возврат Имя+" "+Фамилия;
КонецЕсли;
Иначе
Отчество = Сред(ИмяОтчество, ПозицияВторогоПробела+1);
Отчество = СокрЛ(Отчество);
Отчество = Лев(Отчество, 1)+".";
Если ВидФИО=0 Тогда
Возврат Фамилия+Имя+Отчество;
Иначе
Возврат Имя+Отчество+" "+Фамилия ;
КонецЕсли;
КонецЕсли;
КонецЕсли;
Иначе
Возврат """";
КонецЕсли;
КонецФункции"

Denius61rus
читатель
офлайн
Дата регистрации: 26.03.2009
Сообщений: 25
Пост №7
 
11.02.2010 13:49

абсолютно верно! :) у меня тоже самое написано, и дальше то что?

Denius61rus
читатель
офлайн
Дата регистрации: 26.03.2009
Сообщений: 25
Пост №8
 
11.02.2010 14:24

всё вопрос можно закрыть, я всё вернул на место как и было раньше, действительно программа сама расставляет инициалы, вот только после обновления форматов для выгрузки, в расходных расписания стояло ранше ФИОРукКратко, а сейчас поставили ФИОРук, взял поправил и все нормально стало!!! От это казначейство взбаламутили всё, всем спасибо за помощь!

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №9
 
11.02.2010 16:01

> всем спасибо за помощь!

бывают косяки :-)

Матрена
читатель
офлайн
Дата регистрации: 05.05.2010
Сообщений: 10
Пост №10
 
22.06.2010 17:29

Может кто знает, как поставить в обработке "выгрузка в казначейство" (выгружаем заявку на кассовый расход )
вместо инициалов в подписях рук-ля и главбуха полные имя фамилия отчество?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги