Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как почистить журнал расчета зарплаты

Svetik_K
читатель
офлайн
Дата регистрации: 21.04.2008
Сообщений: 78
Пост №1
 
18.02.2010 15:13

Добрый день. Подскажите, пожалуйста, как в Зарплате и кадрах (1С предприятие 7.7) правильно почистить содержимое журнала расчета зарплаты и налогов за определенный период.(Нужно удалить данные за первое полугодие 2009 года. Спасибо.

uinny
читатель
офлайн
Дата регистрации: 12.01.2008
Сообщений: 4814
Пост №2
 
18.02.2010 17:11

а за второе полугодие не нужно? только за первое?

Svetik_K
читатель
офлайн
Дата регистрации: 21.04.2008
Сообщений: 78
Пост №3
 
19.02.2010 08:02

Не нужна. Что за сарказм?

uinny
читатель
офлайн
Дата регистрации: 12.01.2008
Сообщений: 4814
Пост №4
 
19.02.2010 09:09

вообще-то это не сарказм, а обычный вопрос.

Svetik_K
читатель
офлайн
Дата регистрации: 21.04.2008
Сообщений: 78
Пост №5
 
19.02.2010 09:39

Возможно, не правильно поняла, приношу извинения.

Svetik_K
читатель
офлайн
Дата регистрации: 21.04.2008
Сообщений: 78
Пост №6
 
19.02.2010 09:41

Ну а если по сути...... можно почистить журнал расчетов или нет?

uinny
читатель
офлайн
Дата регистрации: 12.01.2008
Сообщений: 4814
Пост №7
 
19.02.2010 11:04

я бы сделала так.
1. ОБЯЗАТЕЛЬНО сделала архивную копию базы.
2. с помощью внешней обработки "Смена периода" вернулась в месяцы, которые нужно почистить, и распровела документы по начислению.

только вот вопрос. если вы почистите первое полугодие, а во втором по первому были документы-исправления или сторно... зачем вам вообще это? странная задача.

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №8
 
19.02.2010 11:14

"Например так:
НачатьТранзакцию();
ЖурналРасчетов=СоздатьОбъект("ЖурналРасчетов.Зарплата");
НачальныйПериодЖР=ЖурналРасчетов.ТекущийПериод();
Для i=1 По 6 Цикл
НужнаяДата=Дата(2009,i,1);
ЖурналРасчетов.УстановитьТекущийПериод(ЖурналРасчетов.ПериодПоДате(НужнаяДата),0);
Пока ЖурналРасчетов.ВыбратьПериод(НужнаяДата)=1 Цикл
       Пока ЖурналРасчетов.ПолучитьЗапись()=1 Цикл
             ЖурналРасчетов.УдалитьЗапись();
       КонецЦикла;
КонецЦикла;
КонецЦикла;
ЖурналРасчетов.УстановитьТекущийПериод(НачальныйПериодЖР,0);
ЗафиксироватьТранзакцию();"

Svetlana_gr2007
читатель
офлайн
Дата регистрации: 12.09.2007
Сообщений: 6
Пост №9
 
19.02.2010 11:16

Есть инструмент разработчика для таких вопросов. Я брала на http://1c.proclub.ru/. могу поделиться, если хочешь. Весьма удобная обработка и для работы программиста и вообще.

Svetik_K
читатель
офлайн
Дата регистрации: 21.04.2008
Сообщений: 78
Пост №10
 
19.02.2010 13:59

Буду очень благодарна, скинь пожалуйта на kler_2009@mail.ru

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги