Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Пояснения по коду программы Приходной накладной

Flying_gal
читатель
офлайн
Дата регистрации: 06.02.2010
Сообщений: 35
Пост №1
 
02.03.2010 22:21

"Помогите найти ошибку. Суть всего изложенного в том, что при заполнения документа приходная накладная по подала датарегистрации, в строчку датагосрегситрациив справочник Серии ( http://i056.radikal.ru/1003/27/0bf26d1dd819.jpg )

1. В документе приходной накладной
В табличной части добавил столбец ДатаРегистрации
http://i061.radikal.ru/1003/01/2acb23f9f71f.jpg
2. В столбце товар добавил формулу ПриВыбореСерии();
http://i079.radikal.ru/1003/b6/a75aacec8081.jpg
3. В реквизиты в табличной части внес ДатаРегистрации
http://i025.radikal.ru/1003/d5/1bd10ebe839e.jpg
4. В форме, модуль
Процедура ПриВыбореСерии()
Сообщить("*");
Если ПустоеЗначение(Серии)=1 Тогда
Сообщить("Серии не выбрана");
Возврат;
КонецЕсли;
ДатаРегистрации=СпрСерий.ДатаГосРегистрации;
КонецПроцедуры
5. в Модуль документа
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
ДатаРегистрации=СпрСерий.ДатаГосРегистрации;
КонецЦикла;"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №2
 
03.03.2010 08:04

Сообщение было написано в нетрезвом виде?

Flying_gal
читатель
офлайн
Дата регистрации: 06.02.2010
Сообщений: 35
Пост №3
 
03.03.2010 10:56

сообщение было написано не для кривых мозгов

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №4
 
03.03.2010 13:22

Понял, понял. Не нервничайте...

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №5
 
03.03.2010 19:50

> в Модуль документа

где-где ?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №6
 
03.03.2010 20:22

А я ничего не понял. Пять раз попытался перечитать, картинки посмотрел... Ругаться охота :)

Flying_gal
читатель
офлайн
Дата регистрации: 06.02.2010
Сообщений: 35
Пост №7
 
03.03.2010 20:56

а чего не понятного давайте объясню

Flying_gal
читатель
офлайн
Дата регистрации: 06.02.2010
Сообщений: 35
Пост №8
 
03.03.2010 21:14

вопросик можно больше не комментировать , благодарю за участие

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №9
 
03.03.2010 22:08

Да нет, я без стеба. В самом деле непонятно. Первая фраза сумбурная какая то, слова слились, окончания слов вообще не в тему, смысл потерялся. Пытался по картинкам понять что же нужно получить, не догадался. Могу лишь предположить что задача должна быть озвучена так:
В конфигурации существует некий справочник "Серии", в котором имеется реквизит "ДатаГосРегистрации".
При оформлении пользователем документа "Приходная накладная" нужно сделать так, чтобы в табличной части пользователь видел "дату гос. регистрации", соответствующую выбранной серии товара.

Верно?
Если да, то остается разобраться какая связь между справочниками Номенклатура и Серии. Есть ли в "Приходная накладная" реквизит "Серия"?

Flying_gal
читатель
офлайн
Дата регистрации: 06.02.2010
Сообщений: 35
Пост №10
 
03.03.2010 22:16

не много не так, из документа прих.накладной, данные которые содержаться в ячейки "дата госрегистрации", должна попасти в справочник "серии" в ячейку госрегистрации. вот так. реквизит "Серия" нету, а "Серии" есть

Сам документ, т.е таблица "Приходной накладной"
http://i020.radikal.ru/1003/7f/c447ba19a76d.jpg

А
это тот самый справочник "Серии" куда должно была попасти "Желты цветом выделено"
http://i064.radikal.ru/1003/45/4972475f5536.jpg

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги