Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Добавление галочки в журнал

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №1
 
01.04.2010 09:01

Такая вот ситуация:
в усн (семерка) в журнале платежных документов есть столбец с галочками, когда у пл.поручение есть подчиненный док "выписка", то ставится красная галочка (этот подчиненный док можно увидеть правой кнопкой на пл.поручении-подч.док)
буху хочется видеть аналог этого в ИП
там тоже есть плат.поручения на основ.которых делается "строка выписки банка"
добавляю в таблицу журнала колонку с картинкой "галочка", добавляю функцию НомерПиктограммы()(копирую из упр, меняю ПодчДок.Вид() = "СтрокаВыпискиРасход") но не работает, не видит подчиненного платежке документа
получается строка функции: ПодчДок.ВыбратьПодчиненныеДокументы(ТекущийДокумент.ДатаДок,ТекущийДокумент.ДатаДок+15,ТекущийДокумент) = 0.
еще странно, что даже если у пл.поручения есть подчиненный док (который ссылается на это пл.поручение) правой кнопкой-подч.док = открывает пустой журнал подч.документов...

подскажите пожалуйста почему журнал пустой и как тогда реализовать "галочку"?

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 655
Пост №2
 
01.04.2010 09:30

Вероятно потому, что в документе СтрокаВыпискиРасход реквизит ДокументПодтверждающийФактОплаты имеет тип Неопределенный, а не Документ. А раз нет реквизита с типом Документ, то нет и подчиненных документов.

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №3
 
01.04.2010 09:31

а как тогда быть?

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 655
Пост №4
 
01.04.2010 09:36

Можно, конечно, вместо ВыбратьПодчиненныеДокументы поставить ВыбратьДокументы и проверять реквизит на Платежку, но это будет дольше. А можно изменить тип с Неопределено на Документ, если в основании всегда Платежка.

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №5
 
01.04.2010 10:00

"посмотрела, нет, в основании не всегда платежка иногда там пустая строка "другое"

пожалуйста помогите реализовать второй вариант по проверке стоит ли в реквизите документа платежка ссылающаяся на текущую
не соображу
это получается нужно строку реквизита "ДокументПодтверждающийФактОплаты" дока "строка выписки банка", в которой записан номер и дата платежки разделить на части (там ведь прописывается строкой "платежное поручение 00012 (01.04.10)"), чтобы сравнить с номером и датой текущего документа или как?

Док = СоздатьОбъект("Документ.СтрокаВыпискиРасход");
может подойдет Пока Док.ВыбратьПоЗначению...только отбор какой?


"

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 655
Пост №6
 
01.04.2010 12:21

"Док = СоздатьОбъект("Документ.СтрокаВыпискиРасход");
Док.ВыбратьДокументы(ТекущийДокумент.ДатаДок,ТекущийДокумент.ДатаДок+15);
Пока Док.ПолучитьДокумент() = 1 Цикл
       Если ТипЗначенияСтр(Док.ДокументПодтверждающийФактОплаты) = "Документ" Тогда
            Если Док.ДокументПодтверждающийФактОплаты.Вид() = "ПлатежноеПоручение" Тогда
             Если Док.ДокументПодтверждающийФактОплаты = ТекущийДокумент Тогда
                   НомПикт = 1;
             КонецЕсли;
            КонецЕсли;
       КонецЕсли;
КонецЦикла;
"

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №7
 
01.04.2010 13:04

спасибо, спасибо, спасибо !!! :))))))))))))))))

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 655
Пост №8
 
01.04.2010 13:31

"Для скорости можно после НомПикт = 1; добавить
Прервать;
чтобы не проходить цикл до конца, если уже нашли.
"

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №9
 
01.04.2010 13:49

оно и так все очень быстро работает
еще раз спасибо, теперь можно со спокойной душой идти спать (у нас ночь :))

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №10
 
21.04.2010 11:50

"Продолжение темы.
Программа УСН

нужна помощ в реализации такого задания:

в журнале платежных доков есть галочка у пл.поручения (если есть к примеру док. основание "выписка"), но в реестр при выборе "проведенные" доки не попадают, потому что статуса как такового "проведен" у дока нет, а галочка - это просто картинка.
Нужно, чтобы док, у коорого есть подчиненный попадал в реестр с условием "проведенные".

Реестр - это обработка "обработка документов", там задается условие, только я не могу понять, нашла в модуле обработки строку
Если Признак = "Проведенные" Тогда
Если Док.Проведен() = 0 Тогда
Продолжить;
конецЕсли;
ИначеЕсли Признак = "Непроведенные" Тогда
Если (Док.Проведен() = 1) или (Док.Вид() = "Операция") Тогда
Продолжить;
КонецЕсли;


не могу понять, куда вставить условие, что если док=пл.поручение имеет подчиненный, то должен попасть в отбор проведенных доков...

"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги