Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

помогите сравнить 2-е ТЗ - ТЗ_УТ и ТЗ_БП

Julia13
читатель
офлайн
Дата регистрации: 22.03.2010
Сообщений: 29
Пост №1
 
02.04.2010 16:39

"Задача: надо сравнить по док.(поступление) 2-е ИС УТ и БП
Вот мой код:

Процедура КнопкаСформироватьНажатие(Кнопка)
Запрос = Новый Запрос;
Запрос.Текст = "

|ВЫБРАТЬ
| ПоступлениеТоваровУслуг.Ссылка,
| ПоступлениеТоваровУслуг.Дата,
| ПоступлениеТоваровУслуг.Номер,
| ПоступлениеТоваровУслуг.СуммаДокумента
|ИЗ
| Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
|ГДЕ
| ПоступлениеТоваровУслуг.Дата МЕЖДУ &НачПериода И &КонПериода
//| И ПоступлениеТоваровУслуг.СкладОрдер = &Склад
| И ПоступлениеТоваровУслуг.Проведен = ИСТИНА
|
|УПОРЯДОЧИТЬ ПО
| Дата
|";
Запрос.УстановитьПараметр("НачПериода", НачПериода);
Запрос.УстановитьПараметр("КонПериода", КонПериода);
Запрос.УстановитьПараметр("Склад", Склад);

РезультатЗапроса = Запрос.Выполнить().Выгрузить();

ТЗ_УТ = Новый ТаблицаЗначений;

ТЗ_УТ.Колонки.Добавить("Ссылка");
ТЗ_УТ.Колонки.Добавить("Дата");
ТЗ_УТ.Колонки.Добавить("Номер");
ТЗ_УТ.Колонки.Добавить("СуммаДокумента");

//Запрос В БП
V8 = Новый ComОбъект("V81.ComConnector");

Попытка
Открытие = V8.Connect("File=""""F:\InfoBase"""";Usr=""""Администратор"""";");//("File=""""c:\InfoBases\Trade"""";Usr=""""Director"""";")

Исключение
Предупреждение("База данных не открыта!!!!");
Возврат;
КонецПопытки;

Открытие.NewObject("Запрос");
Запрос.Текст ="
//БП запрос по док.ПТиУ и РТиУ
|ВЫБРАТЬ
| ПоступлениеТоваровУслуг.Ссылка,
| ПоступлениеТоваровУслуг.Дата,
| ПоступлениеТоваровУслуг.Номер,
| ПоступлениеТоваровУслуг.СуммаДокумента
| ИЗ
| Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
|ГДЕ
| ПоступлениеТоваровУслуг.Дата МЕЖДУ &НачПериода И &КонПериода
| И ПоступлениеТоваровУслуг.Проведен = ИСТИНА
//| И ПоступлениеТоваровУслуг.Склад = &Склад
|
|УПОРЯДОЧИТЬ ПО
| Дата
|";

Запрос.УстановитьПараметр("НачПериода", НачПериода);
Запрос.УстановитьПараметр("КонПериода", КонПериода);
Запрос.УстановитьПараметр("Склад", Склад);

РезультатCOM = Запрос.Выполнить().Выгрузить();

ТЗ_БП = Новый ТаблицаЗначений;

ТЗ_БП.Колонки.Добавить("Ссылка");
ТЗ_БП.Колонки.Добавить("Дата");
ТЗ_БП.Колонки.Добавить("Номер");
ТЗ_БП.Колонки.Добавить("СуммаДокумента");

//Для каждого Строка Из ТЗ_УТ Цикл
//Документ_УТ = Строка.Ссылка;
//Дата_УТ = Строка.Дата;
//Номер_УТ = Строка.Номер;
//СуммаДокумента_УТ = Строка.СуммаДокумента;

//КонецЦикла;

КонецПроцедуры
"

Alexor
читатель
офлайн
Дата регистрации: 08.07.2003
Сообщений: 201
Пост №2
 
02.04.2010 16:44

"Я бы сделал так:


ТЗ_УТ.Колонки.Добавить("Дата");
ТЗ_УТ.Колонки.Добавить("Номер");
ТЗ_УТ.Колонки.Добавить("СуммаУТ");
ТЗ_УТ.Колонки.Добавить("СуммаБух");

заполнил бы из Ут и БУх.
Потом

ТЗ_УТ.Свернуть("Дата,Номер","СуммаУТ,СуммаБух");


"

Julia13
читатель
офлайн
Дата регистрации: 22.03.2010
Сообщений: 29
Пост №3
 
02.04.2010 17:29

Скажите пожалуйста, а как я могу проверить что у меня выгрузилось в COMОбъект?
Допустим что выгрузилось в ТЗ_УТ я сделала так ТЗ_УТ.ВыбратьСтроку(), а как на счет ТЗ_БП я же вызываю его ч/з COMОбъект..

Денис (САМАРА)
читатель
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №4
 
04.04.2010 09:35

"> Скажите пожалуйста, а как я могу проверить что у меня выгрузилось в COMОбъект?

Для Каждого СтрТЗ ИЗ ТЗ_БП Цикл

Сообщить("№" + СтрТЗ.Номер + " от " + СтрТЗ.Дата + " - " + СтрТЗ.СуммаДокумента);

КонецЦикла;

З.Ы. Сравнение лучше делать как советовал Alexor."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги