Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Выборка из табличной части

zmeidt
читатель
офлайн
Дата регистрации: 04.04.2010
Сообщений: 4
Пост №1
 
04.04.2010 17:38

Ситуация следующая.....
В форму документа.РеализацияОтгруженнойПродукции добавляю кнопку "Кнопка1"......
нужно чтобы при нажитии открывалась новая форма с таблицей товаров из табличной части РеализацияОтгруженнойПродукции(которые я выбрал в ней заранее). С возможностью каким либо образом выбирать сразу несколько нужных товаров из этой таблицы.
Буду очень признателен если поможете.

tulke
читатель
офлайн
Дата регистрации: 25.01.2009
Сообщений: 60
Пост №2
 
05.04.2010 10:38

Можно(какой вопрос, такой ответ).

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №3
 
05.04.2010 10:59

"Нужно при нажатии на кнопку открывать предварительную форму диалога (обработку), в которой вам нужно разработать интерфейс выбора требуемых строк из первичного документа. Проще говоря, алгоритм процедуры, срабатываемой при нажатии на кнопку, будет примерно такой:

Процедура ПриНажатииНаКнопку1()
СписокПараметров=СоздатьОбъект("СписокЗначений");
СписокПараметров.Установить("Контекст",Контекст);
ОткрытьФормуМодально("Обработка.ВыборСоставаПечатиРОП",СписокПараметров);
Если СписокПараметров.Получить("СтатусВозврата")=1 Тогда
       Таб=СоздатьОбъект("Таблица");
       Таб.ВывестиСекцию("Шапка");
       ТЧ=СписокПараметров.Получить("ТабличнаяЧасть");
       Для i=1 По ТЧ.КоличествоСтрок() Цикл
             Таб.ВывестиСекцию("Строка");
       КонецЦикла;
       Таб.ВывестиСекцию("Подвал");
       Таб.Опции(0,0,0,0);
       Таб.ТолькоПросмотр(1);
       Таб.Показать("Реализация отгруженной продукции №"+Строка(НомерДок)+" от "+Формат(ДатаДок,"ДДДММГГГГ")+" г.");
КонецЕсли;
КонецПроцедуры"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №4
 
05.04.2010 11:34

А это еще вопрос: 7-ка ли у автора? :)

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №5
 
05.04.2010 11:53

> ...выбирать сразу несколько нужных товаров из этой таблицы.

А что с выбранными товарами потом делать?

zmeidt
читатель
офлайн
Дата регистрации: 04.04.2010
Сообщений: 4
Пост №6
 
05.04.2010 16:39

Угу Предприятие 7.7....

zmeidt
читатель
офлайн
Дата регистрации: 04.04.2010
Сообщений: 4
Пост №7
 
05.04.2010 16:41

Нужные товары нужно как то выбрать(ну например галочками отметить).....потом нажать сделанную кнопочку "Печать Чеков" и распечатать чеки на выбранные товары.

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №8
 
05.04.2010 17:06

а какая в итоге-то у вас платформа?

Svetlana_E
читатель
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2641
Пост №9
 
05.04.2010 17:07

А зачем тогда доп. форма?
> нужно чтобы при нажитии открывалась новая форма с таблицей товаров из табличной части РеализацияОтгруженнойПродукции(которые я выбрал в ней заранее)

Почему нельзя пометить и распечатать прямо из таблицы документа?

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №10
 
05.04.2010 18:08

Я бы такое тоже сделал через кнопку и обработку. Мало ли - документ закрыт для редактирования, печать в таких случаях все-равно оставляют доступной.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги