Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Комплексная конфигурация 7.7(самописная)

Saxarok
читатель
офлайн
Дата регистрации: 31.10.2007
Сообщений: 69
Пост №1
 
08.04.2010 00:02

Добрый день!!!
Подскажите пожалуйста кто может,если конечно что-то станет понятно из моего
рассказа.
Есть документ Заказ,на его форме есть реквизит ПолеВвода - "ВЗ", в который
автоматически с новой строки помещается такая строка "ПолныйКод()_Наименование_Цена".
При выводе документа на печать просто выводился перечень строк из этого реквизита.Сейчас
возникла необходимость сортировать строки (пока неважно по какому из полей) для
отслеживания дублей.
Вопрос,как в печатную форму документа передавать каждую строку из "ВЗ" и как впоследствии
можно их отсортировать(сгрупировать).
А может я не тем путём пошла???Может можно группировать сразу при автоматическом вводе
строки в ВЗ???
Спасибо за помощь!!!

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №2
 
08.04.2010 09:45

"Смутно, но примерно понятно.
Насколько я понял, "ВЗ" - поле для ввода многострочного текста и этот текст выглядит там примерно так:
000010_Колесо_5000.00
000014_Шина_2200.00
000031_Фара_4000.00

При этом значения в строках могут повторяться и основная задача - поиск дублей строк.
//Текстовое поле преобразуем в таблицу значений. С ней работать проще.
ТаблДанных=СоздатьОбъект("ТаблицаЗначений");
ТаблДанных.НоваяКолонка("Код");
ТаблДанных.НоваяКолонка("Наименование");
ТаблДанных.НоваяКолонка("Цена");
Для i=1 По СтрКоличествоСтрок(ВЗ) Цикл
Стр=СтрПолучитьСтроку(ВЗ,i);
Если ПустаяСтрока(Стр)=0 Тогда
       СписокРеквизитов=глРазложить(Стр,"_");
       Если СписокРеквизитов.РазмерСписка()=3 Тогда
             ТаблДанных.НоваяСтока();
             ТаблДанных.Код=СписокРеквизитов.ПолучитьЗначение(1);
             ТаблДанных.Наименование=СписокРеквизитов.ПолучитьЗначение(2);
             ТаблДанных.Цена=СписокРеквизитов.ПолучитьЗначение(3);
       КонецЕсли;
КонецЕсли;
КонецЦикла;
//получили ТаблДанных, которую можно сортировать, сворачивать и т.п.
//для примера решим подзадачу о выяснении дубликатов строк по ключевому полю, пусть, например, таким полем будет "Наименование"
КлонТаблДанных=СоздатьОбъект("ТаблицаЗначений");
ТаблДанных.Выгрузить(КлонТаблДанных);
КлонТаблДанных.НоваяКолонка("КоличествоВхождений","Число",10,0);
КлонТаблДанных.Заполнить(1,,,"КоличествоВхождений");
КлонТаблДанных.Свернуть("Наименование","КоличествоВхождений");
Для i=1 По КлонТаблДанных.КоличествоСтрок() Цикл
Если КлонТаблДанных.ПолучитьЗначение(i,"КоличествоВхождений")>1 Тогда
       Стр="В данных имеется дублирование по позиции """""+КлонТаблДанных.ПолучитьЗначение(i,"Наименование")+""""" в строках: ";
       Для t=1 По ТаблДанных.КоличествоСтрок() Цикл
             Если КлонТаблДанных.ПолучитьЗначение(i,"Наименование")=ТаблДанных.ПолучитьЗначение(t,"Наименование") Тогда
                   Стр=Стр+Строка(t)+", ";
             КонецЕсли;
       КонецЦикла;
       Сообщить(Лев(Стр,СтрДлина(Стр)-2));
КонецЕсли;
КонецЦикла;"

Saxarok
читатель
офлайн
Дата регистрации: 31.10.2007
Сообщений: 69
Пост №3
 
08.04.2010 11:47

Ух ты!!!Ну вы как всегда меня не подвели,но неожидала что всё будет так отлично.
Буду сейчас пробовать.
Заранее огромадное спасибо!Thorvardr просто супер помощник.
Обязательно напишу про результаты

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №4
 
08.04.2010 14:05

как это комплексная-самописная ?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги