Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Печатная форма

Julia13
читатель
офлайн
Дата регистрации: 22.03.2010
Сообщений: 29
Пост №1
 
08.04.2010 13:25

"У док.ВозвратПоставщику сделали печатную форму(далее ПФ) АКТ.
Задача. У ПФ есть параметр "ДокументОснование" в этот параметр при печати передаются реквизиты:
- НомерВходящегоДокумента;
- ДатаВходящегоДокумента;

А т.к. я вношу товары в ТЧ док.ВозвратПоставщику товары с разными док..
Мне надо при печати ПФ, чтоб в строке передавались (- НомерВходящегоДокумента;
- ДатаВходящегоДокумента) разных док.ПоступленияТовара.

Подскажите как это сделать. Нашла в ПФ строку которая выводит параметр ДокументОснование

Для Каждого Строка Из СсылкаНаОбъект.Товары Цикл

Строка.ДокументПоступления.НомерВходящегоДокумента;
Строка.ДокументПоступления.ДатаВходящегоДокумента;

Страница1.Параметры.ДокументОснование = ?(СсылкаНаОбъект.Товары[0].ДокументПоступления <> Неопределено,"Товарная накладная № " + СсылкаНаОбъект.Товары[0].ДокументПоступления.НомерВходящегоДокумента + " от " + Формат(СсылкаНаОбъект.Товары[0].ДокументПоступления.ДатаВходящегоДокумента, "ДФ=dd.MM.yyyy"), """");

КонецЦикла;

Выдает ошибку.
{ВнешняяОбработка.ВозвратТоваровПоставщикуТОРГ2(83,54)}: Неопознанный оператор
Строка.ДокументПоступления.НомерВходящегоДокумента<>;
{ВнешняяОбработка.ВозвратТоваровПоставщикуТОРГ2(84,53)}: Неопознанный оператор
Строка.ДокументПоступления.ДатаВходящегоДокумента<>;

Подскажите как исправить ошибку?


"

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №2
 
08.04.2010 13:49

"По хорошему надо проверить не только есть документ или нет, но и есть у него реквизит или нет.
Кстати СсылкаНаОбъект.Товары[0].ДокументПоступления может быть пустой ссылкой.
И еще вопрос - зачем цикл, если реально делаете через СсылкаНаОбъект.Товары[0]???

Функция ПолучитьСтрокуОснования (ДокОсн)
Если Не ЗначениеЗаполнено (ДокОсн) Тогда Возврат """"; КонецЕсли;
МД = ДокОсн.Метаданные();
Если (МД.Реквизиты.Найти("НомерВходящегоДокумента") <> Неопределено) И
(МД.Реквизиты.Найти("ДатаВходящегоДокумента")<> Неопределено) Тогда
Возврат "Товарная накладная № "+ДокОсн.НомерВходящегоДокумента + " от " +
       Формат(ДокОсн.ДатаВходящегоДокумента, "ДФ=dd.MM.yyyy");
Иначе
Возврат """";
КонецЕсли;
Возврат """";
КонецФункции

А уже в вашей строке написать так:
Страница1.Параметры.ДокументОснование = ПолучитьСтрокуОснования (СсылкаНаОбъект.Товары[0].ДокументПоступления);
"

Julia13
читатель
офлайн
Дата регистрации: 22.03.2010
Сообщений: 29
Пост №3
 
08.04.2010 14:48

Вы наверное меня не правильно поняли. У вас есть эл.ящик я Вам в картинках отправлю

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №4
 
08.04.2010 17:22

Курсы программистов.

Julia13
читатель
офлайн
Дата регистрации: 22.03.2010
Сообщений: 29
Пост №5
 
08.04.2010 18:00

"А не проще было подсказать(((
Вот как надо это делать...
//muv
Стр = """";
Для Каждого ТекСтрока Из СсылкаНаОбъект.Товары Цикл
       НомерВх = Строка(ТекСтрока.ДокументПоступления.НомерВходящегоДокумента);
Если (Стр = """") Тогда
Стр = Стр + НомерВх + " от " + Формат(ТекСтрока.ДокументПоступления.ДатаВходящегоДокумента, "ДФ=dd.MM.yyyy");
Иначе
Стр = Стр + ", " + НомерВх + " от " + Формат(ТекСтрока.ДокументПоступления.ДатаВходящегоДокумента, "ДФ=dd.MM.yyyy");
КонецЕсли;
//ТекСтрока.ДокументПоступления.ДатаВходящегоДокумента;
КонецЦикла;
// Страница1.Параметры.ДокументОснование = ?(СсылкаНаОбъект.Товары[0].ДокументПоступления <> Неопределено,"Товарная накладная № " + СсылкаНаОбъект.Товары[0].ДокументПоступления.НомерВходящегоДокумента + " от " + Формат(СсылкаНаОбъект.Товары[0].ДокументПоступления.ДатаВходящегоДокумента, "ДФ=dd.MM.yyyy"), """");
Страница1.Параметры.ДокументОснование = Стр;
//muv

Мне нужны советы по кодированию, а не то что мне надо идти на курсы((((("

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №6
 
09.04.2010 09:06

Этот код предполагает, что в табличной части "Товары" только одна строка?
Если да, то зачем тогда цикл, если нет, то почему вместо "ТекСтрока" данные для вывода в печ.форму берутся из "СсылкаНаОбъект.Товары[0]", т.е. только из первой строки?
А вообще данные для печати надо запросом выбирать.

З.Ы. Иди на курсы программистов! :)

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №7
 
09.04.2010 09:48

Советую посмотреть, какие типы принимает ДокументПоступления. И для каждого проверить наличие реквизитов шапки ДатаВходящегоДокумента и НомерВходящегоДокумента. А то однажды поймаете ошибку.
К тому же сравнение на Неопределено не всегда удачно. Пустая ссылка тоже "<> Неопределено", но нужны ли вам пустые значения? Лучше используйте ЗначениеЗаполнено (...).

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги