Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

7.7, Торговля и склад, документ "Реализация"

PetrNN
читатель
офлайн
Дата регистрации: 15.04.2010
Сообщений: 4
Пост №1
 
15.04.2010 11:48

"1C Предприятие 7.7, Торговля и склад редакция 9.2
Документ "Реализация", при нажатии на кнопку "ТОРГ-12" в отчете по умолчанию появляется следующее:

Отпуск разрешил Генеральный директор /Сидоров В.В./
Главный (старший) бухгалтер Петров В.И.
Отпуск груза произвел Зав.складом Козлов В.И.

Нужно что-бы в форме документа "Реализация" можно было выбрать поле "Отпуск разрешил" и "Главный (старший) бухгалтер"
Выбор "Главный (старший) бухгалтер" реализовать получилось:
Для этого на форме создал поле ввода "ГлБухгалтер" тип Справочник.ФизЛица

В модуле строчку
ПечГлавБух = Фирма.ЮрЛицо.ГлБухгалтер.Получить(ДатаДок);
заменил на:

Если ГлБухгалтер.Выбран()=1 Тогда
ПечГлавБух=ГлБухгалтер.Наименование;

Иначе ПечГлавБух = Фирма.ЮрЛицо.ГлБухгалтер.Получить(ДатаДок);
печЛицо=ДокОснование.ДокОснование.Лицо.Наименование;
КонецЕсли;
А сделать выбор "Отпуск разрешил" не знаю как сделать, подскажите пожалуйста. Копался в обработке torg12.ert, ничего не откопал."

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
15.04.2010 13:24

"на форму внешней обработки (если невнешняя - лучше вынеси) сделать Поле со списком с идентификатором, с примеру, ПСС


Процедура ПриОткрытии()
ПСС.ДобавитьЗначение("Отпуск разрешил ");
ПСС.ДобавитьЗначение("Главный (старший) бухгалтер ");
ПСС.ТекущаяСтрока();
КонецПроцедуры

//далее...

КстоРазрешил = ПСС.ПолучитьЗначение(ПСС.ТекущаяСтрока());

Если ГлБухгалтер.Выбран()=1 Тогда
ПечГлавБух=КстоРазрешил + ГлБухгалтер.Наименование;

Иначе ПечГлавБух = КстоРазрешил + Фирма.ЮрЛицо.ГлБухгалтер.Получить(ДатаДок);
печЛицо=ДокОснование.ДокОснование.Лицо.Наименование;
КонецЕсли;"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги