Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как ограничить просмотр данных по начислению ЗП?

_ska_s
читатель
офлайн
Дата регистрации: 16.01.2009
Сообщений: 14
Пост №1
 
15.04.2010 12:48

Конфигурация Бухгалтерия 1.6. Главный бухгалтер требует ограничить просмотр данных по начислению ЗП для всех пользователей, кроме неё. Подскажите как написать код, чтоб проверялась роль пользователя и если это "Бухгалтер", то чтоб не формировались ОСВ, Анализ счета, Карточки по счету 70, 69. (ну я этот код вставлю во все отчеты).
Помогите, никогда особо не приходилось писать что-то подобное.
Буду очень признателен

ПСВ
читатель
офлайн
Дата регистрации: 06.04.2009
Сообщений: 379
Пост №2
 
15.04.2010 12:56

"Процедура ПриОткрытии

Если НЕ РольДоступна("Бухгалтер") Тогда
Возврат;
КонецЕсли;"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
15.04.2010 13:17

"> Процедура ПриОткрытии
>
> Если НЕ РольДоступна("Бухгалтер") Тогда
> Возврат;
> КонецЕсли;

а без кода нельзя ? о_О"

_ska_s
читатель
офлайн
Дата регистрации: 16.01.2009
Сообщений: 14
Пост №4
 
15.04.2010 13:27

Но ведь нужно чтоб по всем другим счетам ОСВ и отчеты формировались.

_ska_s
читатель
офлайн
Дата регистрации: 16.01.2009
Сообщений: 14
Пост №5
 
15.04.2010 13:29

Без кода, я запретил бухгалтерам просматривать соответствующие документы.

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
15.04.2010 13:34

> Без кода, я запретил бухгалтерам просматривать соответствующие документы.

курим права

Olga3891
читатель
офлайн
Дата регистрации: 10.10.2006
Сообщений: 444
Пост №7
 
15.04.2010 13:45

"У нас такое было, мы привязвались к имени пользователя "глТекущийПользователь", и эту проверку вставляли в процедуру формирования отчета, и еще привязывались к счету 70.
что то типа
Если Счет = ПланыСчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда Тогда
Если Не глЗначениеПеременной("глТекущийПользователь")="Иванов Иван Иванович" Тогда
Возврат;
КонецЕсли;
КонецЕсли;
"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №8
 
15.04.2010 13:48

RLS может помочь

_ska_s
читатель
офлайн
Дата регистрации: 16.01.2009
Сообщений: 14
Пост №9
 
15.04.2010 14:41

"Спасибо за ответы.
Реализовал так:
Если Счет = ПланыСчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда Тогда
Если НЕ РольДоступна("ПравоГлавногоБухгалтера") Тогда
Предупреждение("У Вас нет права просматривать данные по этому счету!");
Возврат;
КонецЕсли;
КонецЕсли;"

ПСВ
читатель
офлайн
Дата регистрации: 06.04.2009
Сообщений: 379
Пост №10
 
15.04.2010 14:46

RLS , наложить ограничение на план счетов на счет 70
я даже пример когда то давал - но найти в своих постах не могу и через гугл то же не пробивается

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги