Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как в таблице вернуться на начальную строку?

AndrewM
читатель
офлайн
Дата регистрации: 13.04.2010
Сообщений: 11
Пост №1
 
16.04.2010 08:47

"Всем добрый день.

Подскажите, как в 1С 7.7 вернуться к первой строке таблицы.
Я прохожу цикл по всем строкам:

тблИсточник = СоздатьОбъект("ТаблицаЗначений");
...
Пока тблИсточник.ПолучитьСтроку() = 1 Цикл
...
КонецЦикла;

Но потом мне надо опять пройти этот цикл. А как вернуться к первой строке, не знаю.
Нашёл метод "ТекущаяСтрока(<Строка>)". Пишу перед циклом:

тблИсточник.ТекущаяСтрока(1);

но почему-то это не помогает."

StarS
читатель
офлайн
Дата регистрации: 15.07.2003
Сообщений: 1623
Пост №2
 
16.04.2010 08:54

"Повторить:

тблИсточник.ВыбратьСтроки();
Пока тблИсточник.ПолучитьСтроку() = 1 Цикл
...
КонецЦикла;

Или:

Для Сч=1 По ТблИсточник.Количество() Цикл
Тбл.ПолучитьСтрокуПоНомеру(Сч);
....
КонецЦикла;
"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
16.04.2010 11:34

> Всем добрый день.
>
> Подскажите, как в 1С 7.7 вернуться к первой строке таблицы.
> Я прохожу цикл по всем строкам:
>

зачем ?

AndrewM
читатель
офлайн
Дата регистрации: 13.04.2010
Сообщений: 11
Пост №4
 
16.04.2010 14:50

> > Всем добрый день.
> >
> > Подскажите, как в 1С 7.7 вернуться к первой строке таблицы.
> > Я прохожу цикл по всем строкам:
> >
>
> зачем ?
>
>

Потому что я в коде прохожу по всем строкам таблицы с начала до конца 2 раза. И чтобы второй раз пройти этот цикл, надо вернуться в начало.

Спасибо, StarS. Метод "ВыбратьСтроки()" помог. :)

maestro_voln
читатель
офлайн
Дата регистрации: 04.03.2009
Сообщений: 289
Пост №5
 
16.04.2010 16:49

видимо перепроверяет компутер, вдруг что-то пропустил...

AndrewM
читатель
офлайн
Дата регистрации: 13.04.2010
Сообщений: 11
Пост №6
 
16.04.2010 17:10

:-) Что бы он (компутер) без меня делал

AndrewM
читатель
офлайн
Дата регистрации: 13.04.2010
Сообщений: 11
Пост №7
 
16.04.2010 17:23

Тут по ходу возник ещё вопросик:

Как в 1С 7.7 определить путь до рабочего стола (чтобы по умолчанию выгрузка предлагала сохранить файл в нём).
Т.е. как достать каталог пользователя винды, который не предоставляется методом "КаталогПользователя()" (он даёт только каталог пользователя в самом 1С). Или тут только в реестр лазать? (А как уж это в 1С делается, я и подавно не знаю).

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №8
 
16.04.2010 17:34

> Тут по ходу возник ещё вопросик:
>
> Как в 1С 7.7 определить путь до рабочего стола (чтобы по умолчанию выгрузка предлагала сохранить файл в нём).
> Т.е. как достать каталог пользователя винды, который не предоставляется методом "КаталогПользователя()" (он даёт только каталог пользователя в самом 1С). Или тут только в реестр лазать? (А как уж это в 1С делается, я и подавно не знаю).

%USERPROFILE%\Рабочий стол

AndrewM
читатель
офлайн
Дата регистрации: 13.04.2010
Сообщений: 11
Пост №9
 
16.04.2010 17:44

Большое спасибо, zak555 (398843952).

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №10
 
16.04.2010 18:04

> Большое спасибо, zak555 (398843952).

не за что

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги