Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как составить отчет, выводящий сотрудников, работавших на дату в 77?

arrio
читатель
офлайн
Дата регистрации: 08.12.2008
Сообщений: 196
Пост №1
 
16.04.2010 16:42

"1С 77.025 ЗиК 7.70.295
Нужен отчет, который выбирал бы сотрудников, работавших на предприятии на определенную дату. В Отчеты - Произвольные нет реквизита отбора по датам (т.е. показать всех, у кого Дата приема на работу > произвольная дата < увольнения или работа по н.в) Как его составить? Или сделать обработку?

Нашел в интернете:

СпрСот = СоздатьОбъект("Справочник.Сотрудники");
СпрСот.ВыбратьЭлементы();
Пока СпрСот.ПолучитьЭлемент() = 1 Цикл
Если СпрСот.СостояниеФизЛица.Получить(ДатаДок) = Перечисление.СостояниеФизЛица.СотрудникОсновной Тогда
НоваяСтрока();
Сотрудник = СпрСот.ТекущийЭлемент();
ТипЧасов = Типч;
КонецЕсли;
КонецЦикла;

Запускаю во внешней обработке, но у меня она выдает:

Если СпрСот.СостояниеФизЛица.Получить(ДатаДок<>) = Перечисление.СостояниеФизЛица.СотрудникОсновной Тогда
{\\BASE\EXTFORMS\SOTR_NA_DATU.ERT(6)}: Переменная не определена (ДатаДок)
НоваяСтрока<>();
{\\BASE\EXTFORMS\SOTR_NA_DATU.ERT(7)}: Процедура не обнаружена (НоваяСтрока)
ТипЧасов = Типч<>;
{\\BASE\EXTFORMS\SOTR_NA_DATU.ERT(9)}: Переменная не определена (Типч)"

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №2
 
19.04.2010 10:25

"То что вы нашли в интернете, это довольно простой кусок алгоритма с точки зрения корректности собираемых данных. Его особенности:
- не будут выведены все сотрудники, находящиеся в отпуске по уходу за ребенком
- не будут выведены все сотрудники, являющиеся внешними совместителями
- не будут выведены все сотрудники, работающие по договору гражданско-правового характера

Сразу у вас оно не заработало потому что алгоритм, который вы видите написан для заполнения табличной части какого то документа, вероятно табеля учета рабочего времени и ожидается, что есть табличная часть, предопределенный реквизит ДатаДок, описывающий момент, на который происходит выборка и все такое. Короче, в чистом виде, как вы это нашли, вас это не устроит, совершенно точно.
Алгоритм должен быть примерно такой:

НужнаяДата=Дата("26.03.2006"); //какая то дата, на которую формируем выборку
Сотрудники=СоздатьОбъект("Справочник.Сотрудники");
Сотрудники.ВыбратьЭлементы(0);
Пока Сотрудники.ПолучитьЭлемент(1)=1 Цикл
ТекСотрудник=Сотрудники.ТекущийЭлемент()
Если ПустоеЗначение(ТекСотрудник.СостояниеФизЛица.Получить(НужнаяДата))=0 Тогда
       Сообщить(ТекСотрудник);
ИначеЕсли глВидРасчетаДействует(ТекСотрудник,,НужнаяДата,НужнаяДата)=1 Тогда
       Сообщить(ТекСотрудник);
КонецЕсли;
КонецЦикла;"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги