Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [Прочее] перенос документов из Бух 4.5 в ТиС 9.2
shpecl
Пост №1
shpecl
читатель
офлайн
Дата регистрации: 09.06.2010
Сообщений: 8
Пост №1
 
09.06.2010 12:36

"1С 7.7 сетевая (7.70.027)
бух редакции 4.5 (7.70.513)
торговля+склад 9.2 (7.70.938)

при нажатии в обработчике на кнопку сформировать выдает ошибку:
рн.Скидка=1*мПродажа.Скидка.Наименование;
{путь к файлу обработчика(281)}: Поле агрегатного объекта не обнаружено (Скидка)
Раньше все работало, как выяснилось были установлены какие-то обновления, после чего все и рухнуло.

Вот та часть кода в которой находится ошибка. Помогите пожалуйста и если можно объясните общедоступным языком что и куда, т.к. я не сильно разбираюсь в 1С. Заранее спасибо

//===========================================­===
// ЗаполнитьДокументРеализация()                  
//==============================================
Процедура ЗаполнитьДокументРеализация(мПродажа, рн)
Перем СтавкаНДС;

вариантРасчетаНДС=мПродажа.СуммаВклНДС;
                  

рн.Контрагент=ПолучитьКонтрагента(мПродажа.Контрагент.НаименованиеБух);
рн.Договор=рн.Контрагент.ОсновнойДоговор;
рн.МестоХранения=шаблонРеализ.МестоХранения;
рн.ВидОтгрузки=шаблонРеализ.ВидОтгрузки;
рн.УчитыватьНП=шаблонРеализ.УчитыватьНП;
рн.ЗачитыватьАванс=шаблонРеализ.ЗачитыватьАванс;
рн.Курс=шаблонРеализ.Курс;
рн.Скидка=1*мПродажа.Скидка.Наименование;

Если фПродажаСНДС = 1 Тогда
Если вариантРасчетаНДС=1 тогда
рн.ВариантРасчетаНалогов=НДСВнутри;
Иначе
рн.ВариантРасчетаНалогов=НДССверху;
КонецЕсли;
Иначе
рн.ВариантРасчетаНалогов=шаблонРеализ.ВариантРасчетаНалогов;
КонецЕсли;

рн.РасчетныйСчет=шаблонРеализ.РасчетныйСчет;
рн.ВерсияОбъекта=шаблонРеализ.ВерсияОбъекта;
//рн.НДСвключатьВСтоимость=шаблонРеализ.НДСвключатьВСтоимость;
рн.ТипЦен=шаблонРеализ.ТипЦен;
рн.ПоставщикуВыставляетсяСчетФактураНаВозврат=шаблонРеализ.ПоставщикуВыставляетсяСчетФактураНаВозврат;
рн.Скидка=1*мПродажа.Скидка.Наименование;
рн.ЦеныИзДокумента=шаблонРеализ.ЦеныИзДокумента;

мПродажа.ВыбратьСтроки();
пока мПродажа.ПолучитьСтроку()=1 цикл
рн.НоваяСтрока();

Если мПродажа.Номенклатура.родитель.Наименование="Тара" Тогда
продолжить;
КонецЕсли;

рн.Товар = ПолучитьНоменклатуру(мПродажа.номенклатура.НаименованиеБух,мПродажа.номенклатура.СтавкаНДС, рн.ДатаДок);
Если фПродажаСНДС = 1 Тогда
СтавкаНДС=рн.Товар.СтавкаНДС.Получить(рн.ДатаДок).Ставка;
КонецЕсли;
рн.Количество=мПродажа.Количество;
рн.Цена=мПродажа.Цена;
рн.Сумма=мПродажа.сумма;
рн.СумСкидка=рн.Количество*рн.Цена-рн.Сумма;
Если фПродажаСНДС = 1 Тогда
рн.НДС=мПродажа.СуммаНДС;
Если вариантРасчетаНДС=1 Тогда
рн.всего=рн.Сумма;
Иначе
РасчетНДС=Окр(рн.Сумма*ставкаНДС/100,2,1);
Если РасчетНДС<>рн.НДС Тогда
Сообщить("В докумененте реализация "+ мПродажа.НомерДок + " для товара " + рн.Товар + " не верно расчитан НДС");
КонецЕсли;
рн.всего=рн.Сумма+рн.НДС;
КонецЕсли;
Иначе
рн.всего=рн.Сумма;
КонецЕсли;
      
Если фГотоваяПродукция = 1 Тогда
ТаблицаГП.НоваяСтрока();
ТаблицаГП.ДатаДок = мПродажа.ДатаДок;
ТаблицаГП.Товар = рн.Товар;
ТаблицаГП.Количество = рн.Количество;
Если фПлановаяСебестоимость = 1 Тогда
ТаблицаГП.Стоимость = рн.Цена;
ТаблицаГП.Сумма = Окр(рн.Количество*рн.Цена, 2, 1);
КонецЕсли;
КонецЕсли;

КонецЦикла;

КонецПроцедуры // ЗаполнитьДокументРеализация()"

 
shpecl
Пост №1
09.06.2010 12:36
 

"1С 7.7 сетевая (7.70.027)
бух редакции 4.5 (7.70.513)
торговля+склад 9.2 (7.70.938)

при нажатии в обработчике на кнопку сформировать выдает ошибку:
рн.Скидка=1*мПродажа.Скидка.Наименование;
{путь к файлу обработчика(281)}: Поле агрегатного объекта не обнаружено (Скидка)
Раньше все работало, как выяснилось были установлены какие-то обновления, после чего все и рухнуло.

Вот та часть кода в которой находится ошибка. Помогите пожалуйста и если можно объясните общедоступным языком что и куда, т.к. я не сильно разбираюсь в 1С. Заранее спасибо

//==============================================
// ЗаполнитьДокументРеализация()                  
//==============================================
Процедура ЗаполнитьДокументРеализация(мПродажа, рн)
Перем СтавкаНДС;

вариантРасчетаНДС=мПродажа.СуммаВклНДС;
                  

рн.Контрагент=ПолучитьКонтрагента(мПродажа.Контрагент.НаименованиеБух);
рн.Договор=рн.Контрагент.ОсновнойДоговор;
рн.МестоХранения=шаблонРеализ.МестоХранения;
рн.ВидОтгрузки=шаблонРеализ.ВидОтгрузки;
рн.УчитыватьНП=шаблонРеализ.УчитыватьНП;
рн.ЗачитыватьАванс=шаблонРеализ.ЗачитыватьАванс;
рн.Курс=шаблонРеализ.Курс;
рн.Скидка=1*мПродажа.Скидка.Наименование;

Если фПродажаСНДС = 1 Тогда
Если вариантРасчетаНДС=1 тогда
рн.ВариантРасчетаНалогов=НДСВнутри;
Иначе
рн.ВариантРасчетаНалогов=НДССверху;
КонецЕсли;
Иначе
рн.ВариантРасчетаНалогов=шаблонРеализ.ВариантРасчетаНалогов;
КонецЕсли;

рн.РасчетныйСчет=шаблонРеализ.РасчетныйСчет;
рн.ВерсияОбъекта=шаблонРеализ.ВерсияОбъекта;
//рн.НДСвключатьВСтоимость=шаблонРеализ.НДСвключатьВСтоимость;
рн.ТипЦен=шаблонРеализ.ТипЦен;
рн.ПоставщикуВыставляетсяСчетФактураНаВозврат=шаблонРеализ.ПоставщикуВыставляетсяСчетФактураНаВозврат;
рн.Скидка=1*мПродажа.Скидка.Наименование;
рн.ЦеныИзДокумента=шаблонРеализ.ЦеныИзДокумента;

мПродажа.ВыбратьСтроки();
пока мПродажа.ПолучитьСтроку()=1 цикл
рн.НоваяСтрока();

Если мПродажа.Номенклатура.родитель.Наименование="Тара" Тогда
продолжить;
КонецЕсли;

рн.Товар = ПолучитьНоменклатуру(мПродажа.номенклатура.НаименованиеБух,мПродажа.номенклатура.СтавкаНДС, рн.ДатаДок);
Если фПродажаСНДС = 1 Тогда
СтавкаНДС=рн.Товар.СтавкаНДС.Получить(рн.ДатаДок).Ставка;
КонецЕсли;
рн.Количество=мПродажа.Количество;
рн.Цена=мПродажа.Цена;
рн.Сумма=мПродажа.сумма;
рн.СумСкидка=рн.Количество*рн.Цена-рн.Сумма;
Если фПродажаСНДС = 1 Тогда
рн.НДС=мПродажа.СуммаНДС;
Если вариантРасчетаНДС=1 Тогда
рн.всего=рн.Сумма;
Иначе
РасчетНДС=Окр(рн.Сумма*ставкаНДС/100,2,1);
Если РасчетНДС<>рн.НДС Тогда
Сообщить("В докумененте реализация "+ мПродажа.НомерДок + " для товара " + рн.Товар + " не верно расчитан НДС");
КонецЕсли;
рн.всего=рн.Сумма+рн.НДС;
КонецЕсли;
Иначе
рн.всего=рн.Сумма;
КонецЕсли;
      
Если фГотоваяПродукция = 1 Тогда
ТаблицаГП.НоваяСтрока();
ТаблицаГП.ДатаДок = мПродажа.ДатаДок;
ТаблицаГП.Товар = рн.Товар;
ТаблицаГП.Количество = рн.Количество;
Если фПлановаяСебестоимость = 1 Тогда
ТаблицаГП.Стоимость = рн.Цена;
ТаблицаГП.Сумма = Окр(рн.Количество*рн.Цена, 2, 1);
КонецЕсли;
КонецЕсли;

КонецЦикла;

КонецПроцедуры // ЗаполнитьДокументРеализация()"

 
Thorvardr
Пост №2
"Впишите перед:> рн.Скидка=1*мПродажа.Скидка.Наиме...
09.06.2010 12:44
 
 
shpecl
Пост №3
Реализация и ниже та же ошибка
09.06.2010 13:44
 
 
Thorvardr
Пост №4
В типовой 1С:Бухгалтерии нет документа вида "Реали...
09.06.2010 13:55
 
 
shpecl
Пост №5
что порекомендуете сделать? можно как-то безболезн...
09.06.2010 14:01
 
 
Thorvardr
Пост №6
Запросто, просто закомментарьте строку
09.06.2010 14:37
 
 
shpecl
Пост №7
"закомментировал строки, вроде все пошло, осталось...
09.06.2010 14:48
 
 
shpecl
Пост №8
"Теперь выдаёт еще одну ошибку:текДок.Записать();{...
11.06.2010 10:44
 
 
Prikum
Пост №9
А что в этой процедуре : ПолучитьНомерДокумента(Пр...
11.06.2010 10:47
 
 
shpecl
Пост №10
я не знаю =( где можно посмотреть что там или что?...
11.06.2010 10:52
 
 
Prikum
Пост №11
А Вы кто? пригласите специалиста!
11.06.2010 10:59
 
 
zak555 (398843952)
Пост №12
"текДок.Новый();//вставка+СтараяРабочаяДата = Рабо...
11.06.2010 11:54
 
 
shpecl
Пост №13
а можно написать программулину, чтобы все предыдущ...
24.06.2010 18:39
 
 
zak555 (398843952)
Пост №14
> а можно написать программулину, чтобы все предыд...
24.06.2010 20:06
 
 
shpecl
Пост №15
ну обработку, которая удалила бы перенесенные доку...
25.06.2010 00:37
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании авансовый платеж автозаполнение реквизитов Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безвозмездная передача имущества безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм взыскание налогов видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты возмещение расходов восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты по ГПД выплаты работникам выплаты физическим лицам вычет НДС вычет по НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация гражданско-правовой договор графики работы дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественные налоги имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лекарственные препараты лизинг лизинговое имущество ликвидация организации лицензирование малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая задолженность налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговая ставка налоговое администрирование налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый вычет по ндфл налоговый контроль налоговый мониторинг налоговый учет налоговый учет расходов налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нулевая ставка обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязанности налогоплательщика обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность в фсс отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы передача имущества перенос убытков персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подача уведомления подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверки бизнеса продажа алкогольной продукции прожиточный минимум производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандартный налоговый вычет стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура табачные изделия таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность УКД универсальный корректировочный документ УПД уплата госпошлины уплата налога уплата налогов уплата НДС уплата сбора упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет реализации учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги