Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Другие решения на платформе "1С:Предприятие 8"]

Выбор типа документа из выпадающего списка

Katywka
читатель
офлайн
Дата регистрации: 21.01.2010
Сообщений: 155
Пост №1
 
22.01.2011 10:00

Подскажите пожалуйста, как в 8.1 реализовать следующее - во внешней обработке из выпадающего списка выбрать тип документа, когда тип будет выбран, "выьащить" все реквизиты из этого типа документа.<br>Т.е. выбирать надо не какой-то конкретный документ, а тип

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №2
 
24.01.2011 13:28

"лСписок = Новый СписокЗначений;<br>Для Каждого МД Из Метаданные.Документы Цикл<br> лСписок.Добавить(МД, МД.Имя);<br>КонецЦикла;<br>ЭлементыФормы.ПолеВвода1.СписокВыбора = лСписок;<br><br>//Выбор элемента (при выборе)в Элем<br>МД = Элем.Значение;<br>Для Каждого Рекв Из МД.Реквизиты Цикл<br>КонецЦикла;<br>Для Каждого ТЧ Из МД.ТабличныеЧасти Цикл<br>КонецЦикла;<br><br>Что-то типа этого. В общем - смотрите Метаданные<br>"

Katywka
читатель
офлайн
Дата регистрации: 21.01.2010
Сообщений: 155
Пост №3
 
26.01.2011 13:00

Спасибо, обязательно попробую

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С