Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

РСВ-1 в Комплексной

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3082
Пост №1
 
07.02.2011 21:42

"Комплект форм отчетности: Rp10q401<br>Релиз конфигурации: Комплексная 7.70.504<br>Задача уже неактуальна, но, возможно, баги останутся на следующий комплект, кто нибудь сумеет победить проблему, а может и представители 1С тему заметят, исправят.<br><br>Сегодня ходил делать обновление с 501 на 504. Между делом клиент пожаловался о том, что РСВ-1 заполняли вручную для одного из 16 юрлиц, учет которых ведется в базе, так как автозаполнение некорректно работает.<br>Особенности юрлица:<br>Страховой тариф = Организации, использующие ЕНВД (то есть, чистый ЕНВД, без распределений)<br>Наличие инвалидов = да<br><br>Стал смотреть алгоритм, обнаружились странные дела. Алгоритм задумывался как отличный, сделана попытка выяснения того является ли наш страховой тариф УСН/ЕНВД и является ли он единственным и если это так, то все данные, кроме инвалидов пытаемся включить в Раздел 1-2. Так и должно быть, судя по всему, так все клиенты хотели с самого начала.<br>В rcv102.ert<br>Исправление 1:<br>Строка 3527:<br>ПрименяетсяТолькоЕНВД = 0;<br>Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") Тогда<br> ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);<br>КонецЕсли;<br><br>так... а где про "BUOUSL" (про комплексную)? Надо так:<br>ПрименяетсяТолькоЕНВД = 0;<br>Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") Тогда<br> ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);<br>ИначеЕсли ИдентКонфигурации = "BUOUSL" Тогда<br> ПрименяетсяТолькоЕНВД = ?(ВыбраннаяФирма.ТарифСтраховыхВзносов.Получить(Дата1) = Перечисление.ТарифыСтраховыхВзносов.ЕНВД, 1, 0);<br>КонецЕсли;<br><br>Исправление 2:<br>Сразу следующий блок.<br>Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") ИЛИ (ИдентКонфигурации = "BUPSB25") Тогда<br> ПониженныеСтавкиРавныОсновным = ПроверкаРавенстваОсновнойИПониженнойСтавок();<br>иначе       <br> ПониженныеСтавкиРавныОсновным = 0;<br>КонецЕсли;<br><br>тоже про "BUOUSL" забыли.<br>меняем на<br>Если (ИдентКонфигурации = "BU42TK") ИЛИ (ИдентКонфигурации = "BASUOR") ИЛИ (ИдентКонфигурации = "PBOUL") ИЛИ (ИдентКонфигурации = "BUPSB25") ИЛИ (ИдентКонфигурации = "BUOUSL") Тогда<br><br>Исправление 3:<br>смотрим в ПроверкаРавенстваОсновнойИПониженнойСтавок(), это примерно строка 3268, видим что там про комплексную не забыли, но! Тут видим строчку:<br>ТаблицаОсновныхТарифов = ПолучитьТаблицуОсновныхТарифов();<br>смотрим в ПолучитьТаблицуОсновныхТарифов(), а там то про комплексную как раз забыли. Делаем там замену строки:<br>ТаблицаОсновныхТарифов.ВидТарифа = Константа.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));<br>на<br>Если ИдентКонфигурации = "BUOUSL" Тогда<br> ТаблицаОсновныхТарифов.ВидТарифа = ВыбраннаяФирма.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));<br>Иначе<br> ТаблицаОсновныхТарифов.ВидТарифа = Константа.ТарифСтраховыхВзносов.Получить(КонМесяца(Дата(Год,Месяц,01)));<br>КонецЕсли;<br><br>комментарий по исправлениям 2 и 3:<br>пользователь сказал, что это неправильный ход и проверять ПониженныеСтавкиРавныОсновным вообще не надо, но что то я ей не поверил<br><br>Исправление 4:<br>смотрим примерно в строку 4104. Тут вообще забыли, что в комплексной есть разделитель учета. В результате по всем юрлицам идет запрос без фильтра к общим бухитогам и получается "куча". Нужно чтобы было так:<br>БухИт = СоздатьОбъект("БухгалтерскиеИтоги");<br>Если ИдентКонфигурации = "BUOUSL" Тогда<br> БухИт.ИспользоватьРазделительУчета(ВыбраннаяФирма); //тут все верно, т.к. ВыбраннаяФирма.Вид()="СвоиЮрлица"<br>КонецЕсли;<br><br>Теперь смотрим в В rcv103.ert:<br>Исправление 5:<br>Строка 1732. Исправляем все так же как в исправлениях 1,2 и 3.<br><br>Исправление 6:<br>Смотрим внимательно на текст чуть ниже строки 1732:<br>ПрименяетсяТолькоЕНВД = 0;<br>Если (ИдентКонфигурации = "BU...<br> ПрименяетсяТолькоЕНВД = ?(Константа.ТарифСтр...<br>КонецЕсли;<br>...<br>ПрименяетсяТолькоЕНВД = 0; //!!!??? - зачем тут эта строка? Выходит, что что бы ни было вычислено чуть выше, все равно принудительно ставится, что у нас ПрименяетсяТолькоЕНВД = 0. Как будто это тест был какой то и строку убрать забыли. Убираем ее.<br><br>Вот после этих исправлений отчет заполнился как положено."

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
07.02.2011 22:18

ты в 1с на удалёнку от ста тыщ иди

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С