Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Другие решения на платформе "1С:Предприятие 8"]

УТ 10.3, Указание складов в табличной части

Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №1
 
09.02.2011 12:50

"Всем доброго дня.
Вопрос - УТ 10.3.13.2

В настройках параметров учета в реквизите "Указание складов в Тбл части документов" стоит "В док. реализации".

ОДНАКО! Это не работает. Или я чего то не понимаю. По коду смотрел - В свойствах поля изначально стоит "ВИДИМЫй", однако в отладчике при открытии формы в свойствах колонки склад в свойстве видимый стоит "ложь"!!!.


Процедура УстановитьВидимостьКолонок(КолонкиТабПоля, СтруктураКолонок, ПризнакВидимости) Экспорт

Если ПризнакВидимости Тогда
Для Каждого ТекКолонка из СтруктураКолонок Цикл
ИмяКолонки                               = ТекКолонка.Ключ;
КолонкиТабПоля[ИмяКолонки].ИзменятьВидимость = Истина;
                        ??????????????????????????????????????? ВОТ ТУТ НИЧЕГО НЕ ДОЛЖНО БЫТЬ?

КонецЦикла;
Иначе
Для Каждого ТекКолонка из СтруктураКолонок Цикл
ИмяКолонки                               = ТекКолонка.Ключ;
КолонкиТабПоля[ИмяКолонки].ИзменятьВидимость = Ложь;
КолонкиТабПоля[ИмяКолонки].Видимость       = Ложь;
КонецЦикла;
КонецЕсли;

КонецПроцедуры // УстановитьВидимостьКолонок()

OFF: тяжко сосредоточиться. Оказывается ГИБДД переименуют в "Полицейскую Инспекцию Дорожного Регулирования". НЕПОВЕЗЛО!!!!!!!!!
)))))))))))))))))



"

Тэра
активный пользователь
офлайн
Дата регистрации: 25.12.2008
Сообщений: 22059
Пост №2
 
09.02.2011 13:01

> OFF: тяжко сосредоточиться. Оказывается ГИБДД переименуют в "Полицейскую Инспекцию Дорожного Регулирования".
На тебя это такое впечатление произвело?

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №3
 
09.02.2011 13:03

Смотрите откуда взялась СтруктураКолонок и где оно создается.

Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №4
 
09.02.2011 13:11

"Вообщем такая непонятка - при открытии документа Реализация товаров и услуг в модуле формы вот тут:

////////////////////////////////////////////////////­////////////////////////////
// ОПЕРАТОРЫ ОСНОВНОЙ ПРОГРАММЫ
мОповещатьВладельцаОЗакрытии = Ложь;

мКолонкиТовары             = ЭлементыФормы.Товары.Колонки; // в колонке склад УЖЕ стоит ЛОЖЬ!!!

мКолонкиТаблицаАвтоСкидок = ЭлементыФормы.ТаблицаАвтоСкидок.Колонки;
мКолонкиУслуги             = ЭлементыФормы.Услуги.Колонки;
мКолонкиВозвратнаяТара       = ЭлементыФормы.ВозвратнаяТара.Колонки;

Хотя в конфигураторе в свойствах стоит галочка "ВИДИМОСТЬ, ДОСТУПНОСТЬ". И соответственно предыдущий пост это в процедуре ПриОткрытии() есть строка
РаботаСДиалогами.УстановитьВидимостьОбязательностьСклада(мКолонкиТовары, мКолонкиВозвратнаяТара, ЭлементыФормы.Склад, "Склад", мУказаниеСкладовВТЧ);"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №5
 
09.02.2011 13:22

> > OFF: тяжко сосредоточиться. Оказывается ГИБДД переименуют в "Полицейскую Инспекцию Дорожного Регулирования".
> На тебя это такое впечатление произвело?

аббревиатура-то будет П.И.Д.Р =)

Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №6
 
09.02.2011 15:43

АП!
Очень срочно надо(((((( уже голову сломал

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №7
 
09.02.2011 15:58

"У меня не УТ, а УПП, но флаг в настройке учета работает как надо.

> Очень срочно надо(((((( уже голову сломал
Не надо ломать голову - надо смотреть код и значения переменных. А то у вас получается: вводить пароль пока компьютер не согластиться :)
В частности откройте модуль объекта (документа реализации) и в самом низу будет что-нибудь типа
мУказаниеСкладов = глЗначениеПеременной("УказаниеСкладовВТабличнойЧастиДокументов");
мУказаниеСкладовВТЧ = (мУказаниеСкладов = Перечисления.ВариантыУказанияСкладовВТабличнойЧастиДокументов.ДляДокументовПоступленияРеализации)
Или (мУказаниеСкладов = Перечисления.ВариантыУказанияСкладовВТабличнойЧастиДокументов.ДляДокументовРеализации);

Если вы не заметили, то в строке
> РаботаСДиалогами.УстановитьВидимостьОбязательностьСклада(мКолонкиТовары, мКолонкиВозвратнаяТара, ЭлементыФормы.Склад, "Склад", мУказаниеСкладовВТЧ);
Видимостью управляет переменная мУказаниеСкладовВТЧ. Вот и узнайте чему она равна и почему она равна, скорее всего, Ложь."

Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №8
 
09.02.2011 16:31

ну на таком уровне я разбираюсь))) В том то и дело что она равна истине.
Ладно, буду копать. Хорошо, другой вопрос - вот инициирую создание нового документа (нажимаю "Добавить"). В каком месте поставить точку останова, чтобы это было так сказать "самое начало выполнения". Не могу понять, почему в свойствах колонки склад стоит "Видимый", а перед открытием документа видимость у него уже "Ложь"?

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №9
 
09.02.2011 17:09

4 точки:
1. Модуль объекта в самом низу (после процедур на первой строке оператора)
2. Модуль формы в самом низу (после процедур на первой строке оператора)
3. Событие формы ПередОткрытием
4. Событие формы ПриОткрытии

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №10
 
09.02.2011 17:11

> ну на таком уровне я разбираюсь))) В том то и дело что она равна истине.
Если при вызове УстановитьВидимостьОбязательностьСклада мУказаниеСкладовВТЧ=Истина, то после выхода оттуда Колонка должна иметь Видимость = Истина.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги