Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Другие решения на платформе "1С:Предприятие 8"]

RegExp Как заэкранировать все метасимволы в строке

Grayson211
читатель
офлайн
Дата регистрации: 11.02.2011
Сообщений: 29
Пост №1
 
02.03.2011 11:05

Здравствуйте. Проблема такая: Осуществляется проверка вводимого телефона на соответствие в базе. Поскольку многие телефоны записываются с кодом (863)67.....и т.д. при поиске из-за скобобк они не выдаются, подскажите пожалуйста , как заэкранировать всю строку на вхождение метасимволов.

Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №2
 
02.03.2011 11:07

Платформа какая?

Grayson211
читатель
офлайн
Дата регистрации: 11.02.2011
Сообщений: 29
Пост №3
 
02.03.2011 11:10

1С:Предприятие 8.1 (8.1.14.72)

Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №4
 
02.03.2011 13:12

Как поиск осуществляется? Есть функции "Найти" и "СтрЗаменить"

Grayson211
читатель
офлайн
Дата регистрации: 11.02.2011
Сообщений: 29
Пост №5
 
02.03.2011 14:40

"RegExp = Новый COMОбъект("VBScript.RegExp");
RegExp.IgnoreCase = Истина;
RegExp.Global = Ложь;
RegExp.MultiLine = Ложь;
RegExp.Pattern = ПроверяемыйТелефон;
Запрос=Новый Запрос("ВЫБРАТЬ
| Информация.РабТелефон,
| Информация.Клиент
|ИЗ
| РегистрСведений.Информация КАК Информация");
Выборка=Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
Совпадения=RegExp.Execute(Выборка.РабТелефон);
ЧислоВхождений=Совпадения.Count();
Если ЧислоВхождений>0 Тогда
Для к = 0 По ЧислоВхождений-1 Цикл
Match = Совпадения.Item(к);
Сообщить("Найдено совпадение по рабочему телефону клиента: "+Выборка.Клиент+" тел.: "+Выборка.РабТелефон);
КонецЦикла;
КонецЕсли
КонецЦикла;"

Grayson211
читатель
офлайн
Дата регистрации: 11.02.2011
Сообщений: 29
Пост №6
 
02.03.2011 15:01

Через найти тоже не получается

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №7
 
02.03.2011 15:07

Тут надо сначала привести все номера к одному формату, только тогда можно что-то делать. Телефон могут записать как 999 99 99 или 999-99-99, а это все разные строки и никакое сравнение их не возьмет.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги