Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Ошибка в программе или может как-то по другому надо делать?

Buster
читатель
офлайн
Дата регистрации: 25.05.2011
Сообщений: 6
Пост №1
 
25.05.2011 16:46

"Конфигурация Бухгалтерия предприятия, редакция 2.0 (2.0.22.1)

Ошибка состоит в том, что после корректировки долга надо выписывать счет-фактур на аванс, а это неправильно.

Получили денежные средства документом Платежка вх №1 от 01.02.11.
Перед формирование книги продаж, запускаем обработку Регистрация счетов фактур на аванс, и регистрируем счет фактуру.
Сформировали книгу продаж и книгу покупок за 1ый квартал.

01.04.11 делаем документ Корректировка долга и переносим аванс с одного договора на другой.
Запускаем обработку Регистрация счетов фактур на аванс и он опять мне говорит о том, что надо зарегистрировать счет фактур на аванс по документу Платежка вх №1 от 01.02.11, хотя на него уже было все зарегистрировано.

Мало того, корректировка долга, не исправляет регистр НДС с авансов. Поэтому, если даже убирать из регистрации строку неправильную, то в регистре по остаткам получится "минус".

Такая ошибка повторяется в связи с поиском счет-фактуры по контрагенту и договору, но т.к. мы договор поменяли, то естественно в выписанных уже не находит.

Кусок кода:
Процедура ОпределитьРанееВыписанныеСчетаФактуры(ТаблицаАвансов)

Если ТаблицаАвансов.Количество() > 0 Тогда
      
       Запрос = Новый Запрос;
       Запрос.Текст =
            "ВЫБРАТЬ
            | СчетФактураВыданный.Ссылка КАК СчетФактура,
            | СчетФактураВыданный.Ссылка.Дата КАК ДатаВыписки,
            | СчетФактураВыданный.Ссылка.ДоговорКонтрагента,
            | СчетФактураВыданный.ДокументОснование
            |ИЗ
            | Документ.СчетФактураВыданный.ДокументыОснования КАК СчетФактураВыданный
            |ГДЕ
            | СчетФактураВыданный.ДокументОснование В(&ДокументыОснования)
            | И СчетФактураВыданный.Ссылка.ВидСчетаФактуры = ЗНАЧЕНИЕ(Перечисление.НДСВидСчетаФактуры.НаАванс)
            | И СчетФактураВыданный.Ссылка.ПометкаУдаления = ЛОЖЬ";
      
       Запрос.УстановитьПараметр("ДокументыОснования", ОбщегоНазначения.УдалитьПовторяющиесяЭлементыМассива(ТаблицаАвансов.ВыгрузитьКолонку("ДокументОснование"), Истина));
      
       СФПоДокументам = Запрос.Выполнить().Выгрузить();
      
       Если СФПоДокументам.Количество()>0 Тогда
            
            СтруктураОтбора = Новый Структура("ДокументОснование, ДоговорКонтрагента"); // по данной структуре отбора не найдет выписанную ранее счет фактуру, потому что поменялся договор
            Для Каждого СФ Из СФПоДокументам Цикл
             ЗаполнитьЗначенияСвойств(СтруктураОтбора, СФ);
             СтрокиОтбора = ТаблицаАвансов.НайтиСтроки(СтруктураОтбора);
             Для Каждого СтрокаОтбора Из СтрокиОтбора Цикл
                   СтрокаОтбора.СчетФактура = СФ.СчетФактура;
                   СтрокаОтбора.ДатаВыписки = СФ.ДатаВыписки;
             КонецЦикла;
            КонецЦикла;
            
       КонецЕсли;
КонецЕсли;

Или я что-то неправильно делаю?)"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги