Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Форум

Развернуть все [1С:Зарплата и управление персоналом 8] Формирование отчета по времени
Piratik
Пост №1
Piratik
читатель
офлайн
Дата регистрации: 22.09.2009
Сообщений: 76
Пост №1
 
29.12.2011 11:00

"Доброе время суток. У меня следующая проблема, разработали отчет по отработанному времени рабочих. Если допустим задать период с 01.01.2011 по 31.12.2011 и человек принят на предприятие 01.03.2011 то при формировании отчеты отработанные часы проставляются начиная с января месяца т.е как бы сдвигаются. Проверил запрос в консуле все нормально, отработанное время начинается с 01.03.2011. Как я понимаю ошибка допущена на стадии формирования таблицы.

http://imageshack.us/photo/my-images/694/566jh.jpg/

Ячейки
на скриншоте помеченные желтым должны быть пустые, так как человек не работал в эти месяца.

Кусок кода отвечающего за формирование:



 Запрос.Текст = "ВЫБРАТЬ
| СУММА(РабочееВремяРаботниковОрганизацийОбороты.ЧасовОборот) КАК явка,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.Физлицо КАК Сотрудник,
| РабочееВремяРаботниковОрганизацийОбороты.Период КАК Период,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.ТекущееПодразделениеОрганизации КАК ПодразделениеОрганизации
|ИЗ
| РегистрНакопления.РабочееВремяРаботниковОрганизаций.Обороты(&НачПериод, &КонПериод, Месяц, (НЕ ВидИспользованияРабочегоВремени В (&СписокЗначенийВидВремени))) КАК РабочееВремяРаботниковОрганизацийОбороты
|
|СГРУППИРОВАТЬ ПО
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.Физлицо,
| РабочееВремяРаботниковОрганизацийОбороты.Период,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.ТекущееПодразделениеОрганизации
|
|УПОРЯДОЧИТЬ ПО
| Период
|ИТОГИ
| СУММА(явка)
|ПО
| ПодразделениеОрганизации,
| Сотрудник,
| Период";

СписокЗначенийВидВремени = Новый СписокЗначений;
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеЧасы);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеЧасыАдминистраторов);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.РаботаНочныеЧасы);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.Командировка);
Запрос.УстановитьПараметр("СписокЗначенийВидВремени",СписокЗначенийВидВремени);

Результат = Запрос.Выполнить();

НомерПП = 1;
ИтогЯвка = 0;
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаПодразделение = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ПодразделениеОрганизации");
Пока ВыборкаПодразделение.Следующий() Цикл
       ОбластьСтрокаПодразделение = Макет.ПолучитьОбласть("СтрокаПодразделение|КолонкаСотрудник");
       ОбластьСтрокаПодразделение.Параметры.Заполнить(ВыборкаПодразделение);
       ТабДок.Вывести(ОбластьСтрокаПодразделение,ВыборкаПодразделение.Уровень());
       Для н=0 по КолвоМесяцев Цикл
            ОбластьСтрока = Макет.ПолучитьОбласть("СтрокаПодразделение|КолонкаСтроки");
            ТабДок.Присоединить(ОбластьСтрока);
       КонецЦикла;
      
       Выборка = ВыборкаПодразделение.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Сотрудник");
       Пока Выборка.Следующий() Цикл
            ОбластьСтрокаСотрудник = Макет.ПолучитьОбласть("Строка|КолонкаСотрудник");
            ОбластьСтрокаСотрудник.Параметры.Заполнить(Выборка);
            ОбластьСтрокаСотрудник.Параметры.НомерПП = НомерПП;
            ТабДок.Вывести(ОбластьСтрокаСотрудник,Выборка.Уровень());
            
            ЧасовНакопительно = 0;
            ВыборкаПоПериодам = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Период");
            Для н=0 по КолвоМесяцев Цикл
             Если ВыборкаПоПериодам.Следующий() Тогда
                   ОбластьСтрока = Макет.ПолучитьОбласть("Строка|КолонкаСтроки");
                   ЧасовНакопительно = ЧасовНакопительно + ВыборкаПоПериодам.явка;
                   ОбластьСтрока.Параметры.Заполнить(ВыборкаПоПериодам);
                   ОбластьСтрока.Параметры.явкаНакоп = ЧасовНакопительно;
                   ТабДок.Присоединить(ОбластьСтрока);            
             Иначе
                   ОбластьСтрока = Макет.ПолучитьОбласть("Строка|КолонкаСтроки");
                   ТабДок.Присоединить(ОбластьСтрока);
             КонецЕсли;
            КонецЦикла;
            
            ИтогЯвка = ИтогЯвка + Выборка.явка;
            НомерПП = НомерПП + 1;
       КонецЦикла;
      
КонецЦикла;




Помогите пожалуйста с решением проблемы. Заранее благодарен."

 
Piratik
Пост №1
29.12.2011 11:00
 

"Доброе время суток. У меня следующая проблема, разработали отчет по отработанному времени рабочих. Если допустим задать период с 01.01.2011 по 31.12.2011 и человек принят на предприятие 01.03.2011 то при формировании отчеты отработанные часы проставляются начиная с января месяца т.е как бы сдвигаются. Проверил запрос в консуле все нормально, отработанное время начинается с 01.03.2011. Как я понимаю ошибка допущена на стадии формирования таблицы.

http://imageshack.us/photo/my-images/694/566jh.jpg/

Ячейки на скриншоте помеченные желтым должны быть пустые, так как человек не работал в эти месяца.

Кусок кода отвечающего за формирование:



 Запрос.Текст = "ВЫБРАТЬ
| СУММА(РабочееВремяРаботниковОрганизацийОбороты.ЧасовОборот) КАК явка,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.Физлицо КАК Сотрудник,
| РабочееВремяРаботниковОрганизацийОбороты.Период КАК Период,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.ТекущееПодразделениеОрганизации КАК ПодразделениеОрганизации
|ИЗ
| РегистрНакопления.РабочееВремяРаботниковОрганизаций.Обороты(&НачПериод, &КонПериод, Месяц, (НЕ ВидИспользованияРабочегоВремени В (&СписокЗначенийВидВремени))) КАК РабочееВремяРаботниковОрганизацийОбороты
|
|СГРУППИРОВАТЬ ПО
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.Физлицо,
| РабочееВремяРаботниковОрганизацийОбороты.Период,
| РабочееВремяРаботниковОрганизацийОбороты.Сотрудник.ТекущееПодразделениеОрганизации
|
|УПОРЯДОЧИТЬ ПО
| Период
|ИТОГИ
| СУММА(явка)
|ПО
| ПодразделениеОрганизации,
| Сотрудник,
| Период";

СписокЗначенийВидВремени = Новый СписокЗначений;
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеЧасы);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеЧасыАдминистраторов);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.РаботаНочныеЧасы);
СписокЗначенийВидВремени.Добавить(Справочники.КлассификаторИспользованияРабочегоВремени.Командировка);
Запрос.УстановитьПараметр("СписокЗначенийВидВремени",СписокЗначенийВидВремени);

Результат = Запрос.Выполнить();

НомерПП = 1;
ИтогЯвка = 0;
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаПодразделение = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ПодразделениеОрганизации");
Пока ВыборкаПодразделение.Следующий() Цикл
       ОбластьСтрокаПодразделение = Макет.ПолучитьОбласть("СтрокаПодразделение|КолонкаСотрудник");
       ОбластьСтрокаПодразделение.Параметры.Заполнить(ВыборкаПодразделение);
       ТабДок.Вывести(ОбластьСтрокаПодразделение,ВыборкаПодразделение.Уровень());
       Для н=0 по КолвоМесяцев Цикл
            ОбластьСтрока = Макет.ПолучитьОбласть("СтрокаПодразделение|КолонкаСтроки");
            ТабДок.Присоединить(ОбластьСтрока);
       КонецЦикла;
      
       Выборка = ВыборкаПодразделение.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Сотрудник");
       Пока Выборка.Следующий() Цикл
            ОбластьСтрокаСотрудник = Макет.ПолучитьОбласть("Строка|КолонкаСотрудник");
            ОбластьСтрокаСотрудник.Параметры.Заполнить(Выборка);
            ОбластьСтрокаСотрудник.Параметры.НомерПП = НомерПП;
            ТабДок.Вывести(ОбластьСтрокаСотрудник,Выборка.Уровень());
            
            ЧасовНакопительно = 0;
            ВыборкаПоПериодам = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Период");
            Для н=0 по КолвоМесяцев Цикл
             Если ВыборкаПоПериодам.Следующий() Тогда
                   ОбластьСтрока = Макет.ПолучитьОбласть("Строка|КолонкаСтроки");
                   ЧасовНакопительно = ЧасовНакопительно + ВыборкаПоПериодам.явка;
                   ОбластьСтрока.Параметры.Заполнить(ВыборкаПоПериодам);
                   ОбластьСтрока.Параметры.явкаНакоп = ЧасовНакопительно;
                   ТабДок.Присоединить(ОбластьСтрока);            
             Иначе
                   ОбластьСтрока = Макет.ПолучитьОбласть("Строка|КолонкаСтроки");
                   ТабДок.Присоединить(ОбластьСтрока);
             КонецЕсли;
            КонецЦикла;
            
            ИтогЯвка = ИтогЯвка + Выборка.явка;
            НомерПП = НомерПП + 1;
       КонецЦикла;
      
КонецЦикла;




Помогите пожалуйста с решением проблемы. Заранее благодарен."

 
Денис (САМАРА)
Пост №2
Что-то не видно в коде условия на дату принятия со...
29.12.2011 13:27
 
 
Алавир
Пост №3
Ощущение, что даты у этих проблемных просто сдвину...
29.12.2011 21:05
 

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС

1С бесплатно 1С-Отчетность 1С-Такском 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление небольшой фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПАРК-Риски 1СПредприятие 8 2-НДФЛ 3-НДФЛ 4-ФСС 5 минут 54-ФЗ 6-НДФЛ CRM IT-компании авансовый платеж автозаполнение реквизитов Агентский договор. Учет административная ответственность адресный классификатор акцизы алкоголь алкогольная продукция амортизационная премия амортизация арбитражная практика аттестация рабочих мест аудит аудиторские организации база для начисления страховых взносов база по страховым взносам база по налогу на прибыль банк и касса в 1с банкротство без ККТ безвозмездная передача имущества безнадежная задолженность безналичные расчеты бланки строгой отчетности больничное пособие больничный листок бухгалтер бухгалтерия автономного учреждения бухгалтерская отчетность бухгалтерские события бухгалтерский баланс бухгалтерский учет бухучет бюджет муниципального образования бюджет поселения бюджетная отчетность бюджетный учет ввоз товаров взаимозависимые_лица взноcы в ПФР взносы в ФОМС взносы в ФСС взносы на травматизм взыскание налогов видео 1С видео-уроки 1С водный налог возврат налогов возврат переплаты возмещение расходов восстановление НДС выездная налоговая проверка выездная проверка выплата зарплаты выплаты по ГПД выплаты работникам выплаты физическим лицам вычет НДС вычет по НДС вычеты по НДФЛ ВЭД ГК РФ госпошлина государственная регистрация гражданско-правовой договор графики работы дебиторка декларация о плате за негативное воздействие на окружающую среду декларация по алкоголю декларация по налогу на прибыль декларация по НДС День Бухгалтерии детские пособия ДиректБанк договор комиссии договор подряда договор поставки договорная политика документальное оформление документооборот долговые обязательства должная осмотрительность доходы организации ЕГАИС ЕГРЮЛ единый расчет по страховым взносам ЕНВД ЕСН ЕСХН задолженность по налогам займы закон о бухгалтерском учете занимательная бухгалтерия заработная плата зарплата зарплатные налоги защита персональных данных заявление о постановке на учет земельный налог изменения 2015 изменения в законодательстве изменения в законодательстве 2012 изменения в законодательстве 2013 изменения-2017 имущественные вычеты имущественные налоги имущественный налоговый вычет индивидуальный предприниматель иностранные компании иностранный контрагент иностранный работник интернет-компании интернет-магазины ИП ИП на ЕНВД ип на усн ИС 1С:ИТС исправление бухгалтерских ошибок исправление ошибок ИТС ИФНС кадастровая стоимость кадровое оформление камеральная проверка кассовая дисциплина кассовые операции кассовый чек КБК КИК ККТ КЛАДР ключевая ставка книга на УСН книга покупок книга продаж КоАП РФ коды видов продукции командировка командировочные расходы компенсации работникам компенсационные выплаты компенсация за отпуск консолидированная группа контролируемые сделки контрольные соотношения корректировочный счет-фактура коэффициент-дефлятор крупнейшие налогоплательщики курсовые разницы лекарственные препараты лизинг лизинговое имущество ликвидация организации лицензирование малый бизнес маркировка изделий маркировка изделий из натурального меха маркировка меховых изделий маркировка товара материальная выгода материальная помощь материнский капитал миниденьги модернизация основных средств МРОТ МСФО наличные расчеты налог на игорный бизнес налог на имущество налог на имущество физических лиц налог на прибыль налоги физических лиц налоговая база по налогу на прибыль налоговая база по ндс налоговая декларация налоговая задолженность налоговая ответственность налоговая отчетность налоговая политика налоговая проверка налоговая ставка налоговое администрирование налоговые льготы налоговые споры налоговый агент налоговый агент НДФЛ налоговый агент по ндс налоговый агент по ндфл налоговый агент по НДФЛ налоговый вычет налоговый вычет по ндфл налоговый контроль налоговый мониторинг налоговый учет налоговый учет расходов налогообложение доходов налогоплательщик начисление амортизации начисление пени НДПИ НДС НДС по ставке 10% НДС при экспорте НДС-2015 НДФЛ негативное воздействие на окружающую среду неотделимые улучшения неприменение ккт нерезиденты НИОКР НК РФ НМА новая форма декларации новая форма расчета новости нулевая ставка обзор обзор бухгалтерских событий обзор новостей обособленное подразделение обособленные подразделения обучение 1с обязанности налогоплательщика обязательное социальное страхование обязательное страхование от несчастных случаев на производстве оказание услуг ОКВЭД2 онлайн-касса онлайн-ккт онлайн-ККТ освобождение от налогообложения освобождение от ндс освобождение от ндфл основные средства отпускные отходы отчетность в ПФР отчетность в пфр отчетность в росприроднадзор отчетность в росстат отчетность в Росстат отчетность в фсс отчетность организации отчетность по страховым взносам отчетность предпринимателя оформление счета-фактуры оформление счетов-фактур охрана труда патентная система патентная система налогообложения ПБУ 18 первичные документы передача имущества перенос убытков персонифицированный учет плата за негативное воздействие на окружающую среду плата за проезд грузовиков платежи платежное поручение платежные документы 1с повышение налогов повышение ставок подакцизные товары подача уведомления подтверждающие документы подтверждение расходов полномочия налоговых органов пониженные тарифы поправки в НК РФ поправки в тк рф порядок маркировки товаров пособие по беременности и родам пособие по временной нетрудоспособности пособие по нетрудоспособности пособие по уходу за ребенком посреднические договоры постановка на учет постановка на учет в налоговом органе права налогоплательщика представление сведений применение ККТ приостановление операций по счету проверки бизнеса продажа алкогольной продукции прожиточный минимум производственный календарь проф. Пятов ПСН путевой лист работники-иностранцы раздельный учет расходы на ГСМ расходы на рекламу расходы организации расчет больничного листа расчет заработной платы расчет НДПИ расчет себестоимости расчет страховых взносов расчетный счет расчеты с работниками регистрация ККТ регистрация юридических лиц реестр ККТ реорганизация розничная торговля росалкогольрегулирование РСВ-1 самое новое в 1С:Бухгалтерии самозанятые граждане свод отчетов секреты 1С:ЗУП сельскохозяйственный товаропроизводитель система "Платон" служебная командировка снижение ставок совмещение налоговых режимов составление и сдача отчетности составление и сдача отчетности социальное страхование социальные вычеты социальный налоговый вычет спецоценка условий труда средний заработок ставка НДС Ставка НДФЛ ставка рефинансирования ставки страховых взносов стандартные вычеты стандартный налоговый вычет стандарты бухучета статистика статистическая отчетность статотчетность страхование страховые взносы страховые взносы в пфр страховые взносы в фсс страховые взносы для самозанятых страховые взносы на травматизм страховые тарифы судебная практика судебное решение судебный вердикт суточные счет-фактура табачные изделия таможенные платежи таможенный союз ТК РФ торговый сбор транспортный налог трудовая книжка трудовой договор увольнение по инициативе руководителя увольнение по соглашению сторон уголовная ответственность УКД универсальный корректировочный документ УПД уплата госпошлины уплата налога уплата налогов уплата НДС уплата сбора упрощенная система налогообложения УСН уставный капитал уточненка учет аренды учет в АО учет в бюджетных учреждениях учет в госорганизациях учет в ООО учет в сельском хозяйстве учет в строительстве учет в туризме учет дивидендов учет доходов при усн учет импорта учет лизинга учет МПЗ учет на производстве учет ОС учет основных средств учет премий учет расходов учет расходов при усн учет реализации учет субсидий учет товаров учет ценных бумаг учет экспорта учетная политика факсимиле федеральный стандарт бухгатерского учета ФИАС фиксированные страховые взносы финансовый анализ ФНС РФ форма 6-НДФЛ форма заявления формы документов хроники 54-ФЗ штрафные санкции экологические платежи экспорт продукции электронная отчетность электронная подпись электронные счета-фактуры электронный документооборот электронный формат энциклопедия проверок

Все теги