Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Сортировка документов по реквизиту

Korpas
читатель
офлайн
Дата регистрации: 01.07.2004
Сообщений: 218
Пост №1
 
15.11.2004 13:22

Допустим, есть несколько документов "Поступление товаров", в каждом из которых в шапке указан свой поставщик, свой договор, номер и дата. Как сделать сортировку этих поступлений по поставщику, т.е. сначала идут поступления по первому поставщику, потом по второму и т.д.?

_Alex
читатель
офлайн
Дата регистрации: 29.01.2004
Сообщений: 4
Пост №2
 
15.11.2004 14:38

Если в журнале, то никак.

Миронов Евгений (Мосстрой ИВЦ, Москва)
новичок
офлайн
Пост №3
 
15.11.2004 15:44

доработать стандартный Реестр Документов

Korpas
читатель
офлайн
Дата регистрации: 01.07.2004
Сообщений: 218
Пост №4
 
15.11.2004 19:50

Я имею ввиду не в программе, а при написании внешнего отчета в конфигураторе. Можно ли как-нибудь обойтись без Таблицы Значений или нет?

Цуленков Павел (Перспектива, Чита)
читатель
офлайн
Пост №5
 
16.11.2004 03:45

"Можно с помощью запроса, например:<br><br><br><br> Запрос = СоздатьОбъект("Запрос");<br><br> ТекстЗапроса = "Период с НачДата по КонДата;<br><br> |Док = Документ.ПриходнаяНакладная.ТекущийДокумент;<br><br> |Поставщик = Документ.ПриходнаяНакладная.Клиент;<br><br> |Группировка Поставщик Упорядочить по Поставщик.Наименование;<br><br> |Группировка Док;";<br><br> <br><br> Если Запрос.Выполнить(ТекстЗапроса) = 0 тогда<br><br> Сообщить("Ошибка выполнения запроса");<br><br> Возврат;<br><br> КонецЕсли;<br><br> <br><br> Пока Запрос.Группировка("Поставщик") = 1 цикл<br><br> Пока Запрос.Группировка("Док") = 1 цикл<br><br>                   ........<br><br> КонецЦикла;<br><br> КонецЦикла;<br><br>"

Миронов Евгений (Мосстрой ИВЦ, Москва)
новичок
офлайн
Пост №6
 
16.11.2004 12:15

ТаблицаЗначений является наиболее естесственной формой для работы с 1С

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С