Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

ОСВ по счету (добавить доп колонку)

diablo05
читатель
офлайн
Дата регистрации: 23.06.2010
Сообщений: 1435
Пост №1
 
17.01.2013 18:13

"доброго времени суток. бух 7.7<br> <br>ТАкая ситуация. нужно было в карточку счета, и в ОСВ по счету добавить доп колонку.<br> <br>В карточке счета я нарисовал новую колонку Инн.ввел туда выражение ИннОперации(Опер)<br> <br>и дописал чуть модуль :<br> <br>Функция ИННОперации(О)<br>                   <br> Стр = """";<br> <br> Для х = 1 по О.Дебет.Счет.КоличествоСубконто() Цикл<br>       Если О.Дебет.Счет.ВидСубконто(х) = ВидыСубконто.Контрагенты Тогда<br>            Стр = О.Дебет.Субконто(х).ИНН;<br>       КонецЕсли;<br> КонецЦикла;<br> <br> <br> Для х = 1 по О.Кредит.Счет.КоличествоСубконто() Цикл<br>       Если О.Кредит.Счет.ВидСубконто(х) = ВидыСубконто.Контрагенты Тогда<br>            Стр = О.Кредит.Субконто(х).ИНН;<br>            <br>       КонецЕсли;<br>       <br> КонецЦикла;<br> <br> <br>все работает, инн отображается.<br> <br>А вот в ОСБ по счету, такая штука не получается. и как добавить туда Инн я так и не додумался ;(("

Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №2
 
17.01.2013 20:10

так а в чем вопрос? куда добавить?

diablo05
читатель
офлайн
Дата регистрации: 23.06.2010
Сообщений: 1435
Пост №3
 
17.01.2013 21:02

когда формируешь осб по счету. после первой колонки (в осб) я добавил еще одну (инн). но как в модуле прописат что бы отображалось инн я ненаю..<br> <br>в карточки счета сделал (как я писал выше).. до пустим по 50 счету он туда подставляет инн контрагентов<br>а нужно так же сделать в оборотке по счету.

Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №4
 
17.01.2013 21:05

вы, Владимир, вслепую печатаете что ли?<br> <br>совсем по тупому показать? а уж захотите оптимизировать - ваше дело

diablo05
читатель
офлайн
Дата регистрации: 23.06.2010
Сообщений: 1435
Пост №5
 
17.01.2013 23:12

"кстати да, почти вслепую. и очень быстро.. ;( так как ни чего не успеваю. всегда куда то спешу)))<br> <br>да мне пофигу как, можно совсем по тупому. это нужно на 1 раз. вывести ее, распечатать и отдать. просто нужен инн в первом случаи. и "код" во втором случаи (20 счет субконто видынаменклатуры)"

Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №6
 
17.01.2013 23:38

если почту не поменяли, то смотрите.

diablo05
читатель
офлайн
Дата регистрации: 23.06.2010
Сообщений: 1435
Пост №7
 
18.01.2013 00:28

спасибо. проверил сохранил. сейчас уже спать. завтра с утра посмотрю отпишусь.

diablo05
читатель
офлайн
Дата регистрации: 23.06.2010
Сообщений: 1435
Пост №8
 
18.01.2013 11:17

"Сашечка спасибо ;) все именно так"

Алина71
читатель
офлайн
Дата регистрации: 24.03.2010
Сообщений: 3
Пост №9
 
10.04.2013 12:56

Возникла такая же ситуация, нужна колонка ИНН в карточке счета по 51 счету. Попробовала сделать как у Вас, но колонка пустая, ИНН не выводится. Не подскажете в чем может быть проблема?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С