Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

ОСВ по счету (добавить доп колонку)

diablo05
Пост №1
diablo05
активный пользователь
онлайн
Дата регистрации: 23.06.2010
Сообщений: 1349
Пост №1
 
17.01.2013 18:13

"доброго времени суток. бух 7.7

ТАкая ситуация. нужно было в карточку счета, и в ОСВ по счету добавить доп колонку.

В карточке счета я нарисовал новую колонку Инн.ввел туда выражение ИннОперации(Опер)

и дописал чуть модуль :

Функция ИННОперации(О)
                  
Стр = """";

Для х = 1 по О.Дебет.Счет.КоличествоСубконто() Цикл
       Если О.Дебет.Счет.ВидСубконто(х) = ВидыСубконто.Контрагенты Тогда
            Стр = О.Дебет.Субконто(х).ИНН;
       КонецЕсли;
КонецЦикла;


Для х = 1 по О.Кредит.Счет.КоличествоСубконто() Цикл
       Если О.Кредит.Счет.ВидСубконто(х) = ВидыСубконто.Контрагенты Тогда
            Стр = О.Кредит.Субконто(х).ИНН;
            
       КонецЕсли;
      
КонецЦикла;


все работает, инн отображается.

А вот в ОСБ по счету, такая штука не получается. и как добавить туда Инн я так и не додумался ;(("

Sh_S
Пост №2
Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №2
 
17.01.2013 20:10

так а в чем вопрос? куда добавить?

diablo05
Пост №3
diablo05
активный пользователь
онлайн
Дата регистрации: 23.06.2010
Сообщений: 1349
Пост №3
 
17.01.2013 21:02

когда формируешь осб по счету. после первой колонки (в осб) я добавил еще одну (инн). но как в модуле прописат что бы отображалось инн я ненаю..

в карточки счета сделал (как я писал выше).. до пустим по 50 счету он туда подставляет инн контрагентов
а нужно так же сделать в оборотке по счету.

Sh_S
Пост №4
Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №4
 
17.01.2013 21:05

вы, Владимир, вслепую печатаете что ли?

совсем по тупому показать? а уж захотите оптимизировать - ваше дело

diablo05
Пост №5
diablo05
активный пользователь
онлайн
Дата регистрации: 23.06.2010
Сообщений: 1349
Пост №5
 
17.01.2013 23:12

"кстати да, почти вслепую. и очень быстро.. ;( так как ни чего не успеваю. всегда куда то спешу)))

да мне пофигу как, можно совсем по тупому. это нужно на 1 раз. вывести ее, распечатать и отдать. просто нужен инн в первом случаи. и "код" во втором случаи (20 счет субконто видынаменклатуры)"

Sh_S
Пост №6
Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №6
 
17.01.2013 23:38

если почту не поменяли, то смотрите.

diablo05
Пост №7
diablo05
активный пользователь
онлайн
Дата регистрации: 23.06.2010
Сообщений: 1349
Пост №7
 
18.01.2013 00:28

спасибо. проверил сохранил. сейчас уже спать. завтра с утра посмотрю отпишусь.

diablo05
Пост №8
diablo05
активный пользователь
онлайн
Дата регистрации: 23.06.2010
Сообщений: 1349
Пост №8
 
18.01.2013 11:17

"Сашечка спасибо ;) все именно так"

Алина71
Пост №9
Алина71
читатель
офлайн
Дата регистрации: 24.03.2010
Сообщений: 3
Пост №9
 
10.04.2013 12:56

Возникла такая же ситуация, нужна колонка ИНН в карточке счета по 51 счету. Попробовала сделать как у Вас, но колонка пустая, ИНН не выводится. Не подскажете в чем может быть проблема?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.