Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

Нет документов в запросе

IceBeerg
Пост №1
IceBeerg
читатель
офлайн
Дата регистрации: 06.10.2004
Сообщений: 803
Пост №1
 
22.01.2013 14:08

"По сабжу: конфа переписанная от ТиС. В запрос не попадают документы, хотя они есть.
Процедура Отчет()
Если ПустоеЗначение(ВыбКонПериода)=1 Тогда
       ВыбКонПериода=ТекущаяДата();
КонецЕсли;
Если ВыбКонПериода>ПолучитьДатуТА() Тогда
       ВыбКонПериода=ПолучитьДатуТА();
КонецЕсли;
Если ПустоеЗначение(ВыбНачПериода)=1 Тогда
       ВыбНачПериода=НачМесяца(ВыбКонПериода);
КонецЕсли;

ГруппаПокупатели=СоздатьОбъект("Справочник.Клиенты");
ГруппаПокупатели.НайтиПоКоду("3",0);
ГруппаПокупатели=ГруппаПокупатели.ТекущийЭлемент();

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|КлиентЗап = Регистр.Взаиморасчеты.Клиент;
|УсловияДоговора = Регистр.Взаиморасчеты.Клиент.УсловияДоговора;
|СуммаБазовая = Регистр.Взаиморасчеты.СуммаБазовая;
|Функция СуммаКонОст = КонОст(СуммаБазовая);
|Группировка КлиентЗап без групп;
|Группировка Документ;
|Условие(КлиентЗап.ПринадлежитГруппе(ГруппаПокупатели)=1);
|"//}}ЗАПРОС
;

Если ТолькоСДоговорами=1 Тогда
       ТекстЗапроса = ТекстЗапроса + "Условие(ПустоеЗначение(УсловияДоговора)=0);";
КонецЕсли;

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
       Возврат;
КонецЕсли;

Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Отчет");
Таб.ВывестиСекцию("Шапка");
Пока Запрос.Группировка("КлиентЗап") = 1 Цикл
       ПоследнийПлатеж=ПолучитьПустоеЗначение("Дата");
       Пока Запрос.Группировка(2) = 1 Цикл
            Док=Запрос.ТекДок;
            Сообщить("---ЫыЫ---");
            Если Док.Вид()="ПриходДенегНаСчет" Тогда
             ПоследнийПлатеж=Док.ДатаДок;
            КонецЕсли;
       КонецЦикла;
       Клиент=Запрос.КлиентЗап;
       Остаток=Запрос.СуммаКонОст;
       Если Остаток<0 Тогда
            Остаток=-1*Остаток;
       КонецЕсли;
       Таб.ВывестиСекцию("Строка");
КонецЦикла;
Итог=Запрос.СуммаКонОст;
Если Итог<0 Тогда
       Итог=-1*Итог;
КонецЕсли;
Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Показать("Долги контрагентов", """");
КонецПроцедуры

Почему?!"

Sh_S
Пост №2
Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №2
 
22.01.2013 14:14

я не великий спец по запросам, но где в нем описание "документа"?

IceBeerg
Пост №3
IceBeerg
читатель
офлайн
Дата регистрации: 06.10.2004
Сообщений: 803
Пост №3
 
22.01.2013 14:19

"Поправил. Все равно никак...
Процедура Отчет()
Если ПустоеЗначение(ВыбКонПериода)=1 Тогда
ВыбКонПериода=ТекущаяДата();
КонецЕсли;
Если ВыбКонПериода>ПолучитьДатуТА() Тогда
ВыбКонПериода=ПолучитьДатуТА();
КонецЕсли;
Если ПустоеЗначение(ВыбНачПериода)=1 Тогда
ВыбНачПериода=НачМесяца(ВыбКонПериода);
КонецЕсли;

ГруппаПокупатели=СоздатьОбъект("Справочник.Клиенты");
ГруппаПокупатели.НайтиПоКоду("3",0);
ГруппаПокупатели=ГруппаПокупатели.ТекущийЭлемент();

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|КлиентЗап = Регистр.Взаиморасчеты.Клиент;
|УсловияДоговора = Регистр.Взаиморасчеты.Клиент.УсловияДоговора;
|СуммаБазовая = Регистр.Взаиморасчеты.СуммаБазовая;
|ТекДок = Регистр.Взаиморасчеты.ТекущийДокумент;
|Функция СуммаКонОст = КонОст(СуммаБазовая);
|Группировка КлиентЗап без групп;
|Группировка ТекДок;
|Условие(КлиентЗап.ПринадлежитГруппе(ГруппаПокупатели)=1);
|"//}}ЗАПРОС
;

Если ТолькоСДоговорами=1 Тогда
ТекстЗапроса = ТекстЗапроса + "Условие(ПустоеЗначение(УсловияДоговора)=0);";
КонецЕсли;

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Отчет");
Таб.ВывестиСекцию("Шапка");
Пока Запрос.Группировка("КлиентЗап") = 1 Цикл
ПоследнийПлатеж=ПолучитьПустоеЗначение("Дата");
Пока Запрос.Группировка("ТекДок") = 1 Цикл
Док=Запрос.ТекДок;
Сообщить("---ЫыЫ---");
Если Док.Вид()="ПриходДенегНаСчет" Тогда
ПоследнийПлатеж=Док.ДатаДок;
КонецЕсли;
КонецЦикла;
Клиент=Запрос.КлиентЗап;
Остаток=Запрос.СуммаКонОст;
//Здесь бы разобраться кто кому и чего должен...
Если Остаток<0 Тогда
Остаток=-1*Остаток;
КонецЕсли;
Таб.ВывестиСекцию("Строка");
КонецЦикла;
//Считать не так, а вдруг нам заплатили на перед и как-бы мы должны
Итог=Запрос.СуммаКонОст;
Если Итог<0 Тогда
Итог=-1*Итог;
КонецЕсли;
Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Показать("Долги контрагентов", """");
КонецПроцедуры"

Thorvardr
Пост №4
Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №4
 
22.01.2013 15:01

"Для того чтобы в запросе написать

|Группировка Документ; 


все таки не обязательно описывать откуда брать эти данные. "Документ" считается предикатом и имеется всегда, подразумевая под собой "документ движения", так что первый вариант запроса был самодостаточным в этом смысле.
Теперь про то почему не работает. Группировка по документам движений, которые являются по смыслу аналитикой какого то выполненного оборота по регистру, подразумевает наличие в запросе функиций, которые будут как то этот оборот обобщать. Проще говоря, в ваш запрос надо добавить еще:

|Функция СуммаПриход = Приход(СуммаБазовая);
|Функция СуммаРасход = Расход(СуммаБазовая);


не смотря на то, что они вам, вроде бы как и не нужны вовсе, тогда заработает."

IceBeerg
Пост №5
IceBeerg
читатель
офлайн
Дата регистрации: 06.10.2004
Сообщений: 803
Пост №5
 
22.01.2013 15:56

Вот и я шел на обьед и подумал о
> наличие в запросе функиций
:)
Как освобожусь от текучки переделаю.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.