Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

Нет документов в запросе

IceBeerg
читатель
офлайн
Дата регистрации: 06.10.2004
Сообщений: 803
Пост №1
 
22.01.2013 14:08

"По сабжу: конфа переписанная от ТиС. В запрос не попадают документы, хотя они есть.<br>Процедура Отчет()<br> Если ПустоеЗначение(ВыбКонПериода)=1 Тогда<br>       ВыбКонПериода=ТекущаяДата();<br> КонецЕсли;<br> Если ВыбКонПериода>ПолучитьДатуТА() Тогда<br>       ВыбКонПериода=ПолучитьДатуТА();<br> КонецЕсли;<br> Если ПустоеЗначение(ВыбНачПериода)=1 Тогда<br>       ВыбНачПериода=НачМесяца(ВыбКонПериода);<br> КонецЕсли;<br> <br> ГруппаПокупатели=СоздатьОбъект("Справочник.Клиенты");<br> ГруппаПокупатели.НайтиПоКоду("3",0);<br> ГруппаПокупатели=ГруппаПокупатели.ТекущийЭлемент();<br><br> Запрос = СоздатьОбъект("Запрос");<br> ТекстЗапроса = <br> "//{{ЗАПРОС(Сформировать)<br> |Период с ВыбНачПериода по ВыбКонПериода;<br> |КлиентЗап = Регистр.Взаиморасчеты.Клиент;<br> |УсловияДоговора = Регистр.Взаиморасчеты.Клиент.УсловияДоговора;<br> |СуммаБазовая = Регистр.Взаиморасчеты.СуммаБазовая;<br> |Функция СуммаКонОст = КонОст(СуммаБазовая);<br> |Группировка КлиентЗап без групп;<br> |Группировка Документ;<br> |Условие(КлиентЗап.ПринадлежитГруппе(ГруппаПокупатели)=1);<br> |"//}}ЗАПРОС<br> ;<br><br> Если ТолькоСДоговорами=1 Тогда<br>       ТекстЗапроса = ТекстЗапроса + "Условие(ПустоеЗначение(УсловияДоговора)=0);";<br> КонецЕсли;<br> <br> Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда<br>       Возврат;<br> КонецЕсли;<br><br> Таб = СоздатьОбъект("Таблица");<br> Таб.ИсходнаяТаблица("Отчет");<br> Таб.ВывестиСекцию("Шапка");<br> Пока Запрос.Группировка("КлиентЗап") = 1 Цикл<br>       ПоследнийПлатеж=ПолучитьПустоеЗначение("Дата");<br>       Пока Запрос.Группировка(2) = 1 Цикл<br>            Док=Запрос.ТекДок;<br>            Сообщить("---ЫыЫ---");<br>            Если Док.Вид()="ПриходДенегНаСчет" Тогда<br>             ПоследнийПлатеж=Док.ДатаДок;<br>            КонецЕсли;<br>       КонецЦикла;<br>       Клиент=Запрос.КлиентЗап;<br>       Остаток=Запрос.СуммаКонОст;<br>       Если Остаток<0 Тогда<br>            Остаток=-1*Остаток;<br>       КонецЕсли;<br>       Таб.ВывестиСекцию("Строка");<br> КонецЦикла;<br> Итог=Запрос.СуммаКонОст;<br> Если Итог<0 Тогда<br>       Итог=-1*Итог;<br> КонецЕсли;<br> Таб.ВывестиСекцию("Подвал");<br> Таб.ТолькоПросмотр(1);<br> Таб.Показать("Долги контрагентов", """");<br>КонецПроцедуры<br> <br>Почему?!"

Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №2
 
22.01.2013 14:14

я не великий спец по запросам, но где в нем описание "документа"?

IceBeerg
читатель
офлайн
Дата регистрации: 06.10.2004
Сообщений: 803
Пост №3
 
22.01.2013 14:19

"Поправил. Все равно никак...<br>Процедура Отчет()<br> Если ПустоеЗначение(ВыбКонПериода)=1 Тогда<br> ВыбКонПериода=ТекущаяДата();<br> КонецЕсли;<br> Если ВыбКонПериода>ПолучитьДатуТА() Тогда<br> ВыбКонПериода=ПолучитьДатуТА();<br> КонецЕсли;<br> Если ПустоеЗначение(ВыбНачПериода)=1 Тогда<br> ВыбНачПериода=НачМесяца(ВыбКонПериода);<br> КонецЕсли;<br> <br> ГруппаПокупатели=СоздатьОбъект("Справочник.Клиенты");<br> ГруппаПокупатели.НайтиПоКоду("3",0);<br> ГруппаПокупатели=ГруппаПокупатели.ТекущийЭлемент();<br><br> Запрос = СоздатьОбъект("Запрос");<br> ТекстЗапроса = <br> "//{{ЗАПРОС(Сформировать)<br> |Период с ВыбНачПериода по ВыбКонПериода;<br> |КлиентЗап = Регистр.Взаиморасчеты.Клиент;<br> |УсловияДоговора = Регистр.Взаиморасчеты.Клиент.УсловияДоговора;<br> |СуммаБазовая = Регистр.Взаиморасчеты.СуммаБазовая;<br> |ТекДок = Регистр.Взаиморасчеты.ТекущийДокумент;<br> |Функция СуммаКонОст = КонОст(СуммаБазовая);<br> |Группировка КлиентЗап без групп;<br> |Группировка ТекДок;<br> |Условие(КлиентЗап.ПринадлежитГруппе(ГруппаПокупатели)=1);<br> |"//}}ЗАПРОС<br> ;<br><br> Если ТолькоСДоговорами=1 Тогда<br> ТекстЗапроса = ТекстЗапроса + "Условие(ПустоеЗначение(УсловияДоговора)=0);";<br> КонецЕсли;<br> <br> Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда<br> Возврат;<br> КонецЕсли;<br><br> Таб = СоздатьОбъект("Таблица");<br> Таб.ИсходнаяТаблица("Отчет");<br> Таб.ВывестиСекцию("Шапка");<br> Пока Запрос.Группировка("КлиентЗап") = 1 Цикл<br> ПоследнийПлатеж=ПолучитьПустоеЗначение("Дата");<br> Пока Запрос.Группировка("ТекДок") = 1 Цикл<br> Док=Запрос.ТекДок;<br> Сообщить("---ЫыЫ---");<br> Если Док.Вид()="ПриходДенегНаСчет" Тогда<br> ПоследнийПлатеж=Док.ДатаДок;<br> КонецЕсли;<br> КонецЦикла;<br> Клиент=Запрос.КлиентЗап;<br> Остаток=Запрос.СуммаКонОст;<br> //Здесь бы разобраться кто кому и чего должен...<br> Если Остаток<0 Тогда<br> Остаток=-1*Остаток;<br> КонецЕсли;<br> Таб.ВывестиСекцию("Строка");<br> КонецЦикла;<br> //Считать не так, а вдруг нам заплатили на перед и как-бы мы должны<br> Итог=Запрос.СуммаКонОст;<br> Если Итог<0 Тогда<br> Итог=-1*Итог;<br> КонецЕсли;<br> Таб.ВывестиСекцию("Подвал");<br> Таб.ТолькоПросмотр(1);<br> Таб.Показать("Долги контрагентов", """");<br>КонецПроцедуры"

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3082
Пост №4
 
22.01.2013 15:01

"Для того чтобы в запросе написать<br><br><pre>|Группировка Документ; </pre><br><br> все таки не обязательно описывать откуда брать эти данные. "Документ" считается предикатом и имеется всегда, подразумевая под собой "документ движения", так что первый вариант запроса был самодостаточным в этом смысле.<br>Теперь про то почему не работает. Группировка по документам движений, которые являются по смыслу аналитикой какого то выполненного оборота по регистру, подразумевает наличие в запросе функиций, которые будут как то этот оборот обобщать. Проще говоря, в ваш запрос надо добавить еще:<br> <br><pre>|Функция СуммаПриход = Приход(СуммаБазовая);<br>|Функция СуммаРасход = Расход(СуммаБазовая); </pre><br><br>не смотря на то, что они вам, вроде бы как и не нужны вовсе, тогда заработает."

IceBeerg
читатель
офлайн
Дата регистрации: 06.10.2004
Сообщений: 803
Пост №5
 
22.01.2013 15:56

Вот и я шел на обьед и подумал о<br>> наличие в запросе функиций<br>:)<br>Как освобожусь от текучки переделаю.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С