Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Другие решения на платформе "1С:Предприятие 8"]

ЭСМ-7 справка выполненных работ и услуг

Белов Александр Васильевич
Пост №1
Белов Александр Васильевич
читатель
офлайн
Дата регистрации: 20.11.2012
Сообщений: 98
Пост №1
 
04.02.2013 12:56

"Здравствуйте подскажите я в тупике...как сделать что бы одна только услуга попадала в печатную форму...я не могу понять как вывесите во внешнею печатную форму доп реквизиты я создал их в 1с предприятие к документу реализация товаров и услуг..или же я что то не то делаю

ЗапросШапка = Новый Запрос;       ЗапросШапка.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);       ЗапросШапка.Текст =       "ВЫБРАТЬ       |    РеализацияТоваровУслуг.Номер,       |    РеализацияТоваровУслуг.Дата,       |    РеализацияТоваровУслуг.Контрагент КАК Заказчик,       |    РеализацияТоваровУслуг.Организация КАК Организация,       |    РеализацияТоваровУслуг.ВалютаДокумента,       |    РеализацияТоваровУслуг.УчитыватьНДС,       |    РеализацияТоваровУслуг.СуммаВключаетНДС,       |    РеализацияТоваровУслуг.Организация.КодПоОКПО КАК ОрганизацияОКПО,       |    РеализацияТоваровУслуг.Контрагент.КодПоОКПО КАК КонтрагентОКПО       |ИЗ       |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг       |ГДЕ       |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";              Шапка = ЗапросШапка.Выполнить().Выбрать();       Шапка.Следующий();              ТабДокумент = Новый ТабличныйДокумент;       ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_ЭСМ7";       Макет       = ПолучитьМакет("ЭСМ7");       ОбластьМакета = Макет.ПолучитьОбласть("Шапка");       ОбластьМакета.Параметры.Заполнить(Шапка);       ОбластьМакета.Параметры.ДатаДень = Лев(СсылкаНаОбъект.Дата,2);       ОбластьМакета.Параметры.ДатаМесяц = Сред(СсылкаНаОбъект.Дата,4,2);       ОбластьМакета.Параметры.ДатаГод = Сред(СсылкаНаОбъект.Дата,9,2);       ОбластьМакета.Параметры.Организация = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата), "НаименованиеДляПечатныхФорм,");       ОбластьМакета.Параметры.Заказчик = ФормированиеПечатныхФорм.ОписаниеОрганизации(УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Заказчик, Шапка.Дата), "ПолноеНаименование,");       ТабДокумент.Вывести(ОбластьМакета);        Запрос = Новый Запрос;       Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);       Запрос.Текст ="ВЫБРАТЬ                           |    РеализацияТоваровУслугУслуги.Номенклатура,                           |    РеализацияТоваровУслугУслуги.Содержание,                           |    РеализацияТоваровУслугУслуги.Количество,                           |    РеализацияТоваровУслугУслуги.Цена,                           |    РеализацияТоваровУслугУслуги.Сумма,                           |    РеализацияТоваровУслугУслуги.СуммаНДС                           |ИЗ                           |    Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслугУслуги";       ТаблицаУслуги = Запрос.Выполнить().Выгрузить();              // Вывести табличную часть       ОбластьСтроки = Макет.ПолучитьОбласть("Строка");       НомерСтроки = 0;       Для Каждого СтрокаТабличнойЧасти Из ТаблицаУслуги Цикл           НомерСтроки = НомерСтроки + 1;           СтрокаУслуги = """"+СтрокаТабличнойЧасти.Номенклатура.НаименованиеПолное+" ("+СтрокаТабличнойЧасти.Содержание+")";           ОбластьСтроки.Параметры.Заполнить(СтрокаТабличнойЧасти);           ОбластьСтроки.Параметры.СтрокаУслуги = СокрЛП(СтрокаУслуги);           ОбластьСтроки.Параметры.КодНоменклатуры = СокрЛП(СтрокаТабличнойЧасти.Номенклатура.Код);                                                                                   ОбластьСтроки.Параметры.Цена = ОбщегоНазначения.ФорматСумм(СтрокаТабличнойЧасти.Цена);           ОбластьСтроки.Параметры.Сумма = ОбщегоНазначения.ФорматСумм(СтрокаТабличнойЧасти.Сумма);           ТабДокумент.Вывести(ОбластьСтроки);       КонецЦикла;       ИтогоСумма    = ТаблицаУслуги.Итог("Сумма");       ИтогоКоличество = ТаблицаУслуги.Итог("Количество");              СуммаНДС = ТаблицаУслуги.Итог("СуммаНДС");       Если Шапка.УчитыватьНДС Тогда                   Всего = ?(Шапка.СуммаВключаетНДС,ИтогоСумма,ИтогоСумма + СуммаНДС);       Иначе           Всего = ИтогоСумма;       КонецЕсли;              ОбластьМакета = Макет.ПолучитьОбласть("Подвал");       ОбластьМакета.Параметры.ИтогоСумма = ОбщегоНазначения.ФорматСумм(ИтогоСумма);       ОбластьМакета.Параметры.ИтогоКоличество = ИтогоКоличество;       ОбластьМакета.Параметры.Всего = ОбщегоНазначения.ФорматСумм(Всего);       ПарПредмета="час,часа,часов,м,,,,,0";       ПрописьЧасов = ЧислоПрописью(Цел(ИтогоКоличество),, ПарПредмета);       Минут = Цел((ИтогоКоличество-Цел(ИтогоКоличество))*60);       ПарПредмета="минута,минуты,минут,ж,,,,,0";       ПрописьМинут = ЧислоПрописью(Минут,, ПарПредмета);                      ОбластьМакета.Параметры.ПечЧасы  = """"+ПрописьЧасов+" "+НРЕГ(ПрописьМинут);              //Руководитель = ОбщегоНазначения.ОтветственныеЛица();       //ОбластьМакета.Параметры.ФИОРуководителя       = ФИОРуководителя;       //ОбластьМакета.Параметры.ДолжностьРуководителя = ДолжностьРуководителя;                      Если Шапка.УчитыватьНДС Тогда           Если СуммаНДС <> 0 Тогда               ОбластьМакета.Параметры.ВсегоНДС = ОбщегоНазначения.ФорматСумм(СуммаНДС);               ОбластьМакета.Параметры.СтрокаНДС      = ?(Шапка.СуммаВключаетНДС, "В том числе НДС:", " Сумма НДС:");           Иначе               ОбластьМакета.Параметры.ВсегоНДС = "-";               ОбластьМакета.Параметры.СтрокаНДС      = "Без налога (НДС)";           КонецЕсли;           ТабДокумент.Вывести(ОбластьМакета);           КонецЕсли;                    Возврат ТабДокумент; 

пдскажите пожалуйста!"

Prikum
Пост №2
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №2
 
04.02.2013 15:12

Во втором запросе он выбирает табличную часть все документов Реализация товаров и услуг.

Белов Александр Васильевич
Пост №3
Белов Александр Васильевич
читатель
офлайн
Дата регистрации: 20.11.2012
Сообщений: 98
Пост №3
 
04.02.2013 15:55

"Ага спасибо я исправил т.е. надо условие поставить да?....а вот еще вопросик небольшой как обратиться к доп реквизитам этого док. что бы их вывести на печатную форму..делаю доп реквизиты к этому док и потом вот такой запрос

     Запрос = Новый Запрос;       Запрос.УстановитьПараметр("Объект",СсылкаНаОбъект);       Запрос.УстановитьПараметр("Свойство","Машина");       Запрос.Текст = "ВЫБРАТЬ                      |    ЗначенияСвойствОбъектов.Значение КАК Автомобиль                      |ИЗ                      |    РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов                      |ГДЕ                      |    ЗначенияСвойствОбъектов.Объект = &Объект                      |    И ЗначенияСвойствОбъектов.Свойство = &Свойство";       Результат = Запрос.Выполнить().Выбрать(); 


тип значения реквизита выбираю справочник но нет там такого справочника Значение доп. реквизитов...а если акцентировать 2е последние строки в запросе то запрос возвращает значение...как быть подскажите?"

Prikum
Пост №4
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №4
 
04.02.2013 16:17

Учится программированию по форуму не самая лучшая идея и Вам об этом уже говорили!

Белов Александр Васильевич
Пост №5
Белов Александр Васильевич
читатель
офлайн
Дата регистрации: 20.11.2012
Сообщений: 98
Пост №5
 
04.02.2013 16:27

спс за ответ...я учусь по кнгам делаю всекак читал все как описывается в книгах курсах но все рвно ошибки выходят...мне что теперь нельзя за помощью оратится...вот вы же тоже всеравно нет нет да обращаетесь

Prikum
Пост №6
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №6
 
04.02.2013 16:37

Вы не учитесь, Вы пытаетесь переложить свою работу на плечи пользователей форума! Вы работаете где то и Вам дают задания, у Вас не получается их сделать и Вы начинаете задавать вопросы, сами даже не пытаетесь что либо найти, сразу на форум, авось кто-нибудь решит проблему!? Это неправильно, Вы же получаете ЗП, надеюсь по крайней мере!?

Дина
Пост №7
Дина
читатель
офлайн
Дата регистрации: 21.05.2010
Сообщений: 2981
Пост №7
 
04.02.2013 16:37

> вот вы же тоже всеравно нет нет да обращаетесь

Хм-ммм. Ну это ты погорячился.

Задай нужный поиск в конфигураторе и посмотри как там используется подобное.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.