Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

Ошибка обновления ЗиК 7.70.332

Dixel
читатель
офлайн
Дата регистрации: 19.02.2013
Сообщений: 3
Пост №1
 
20.02.2013 16:58

"После обновления ЗиК с релиза 331 на 332 программа при запуске пишет об ошибке:<br>"Выполняется обновление информационной базы.<br>Расчет = ВидРасчета.ПолучитьАтрибут(Док.Расчет.Код);<br>{Обработка.ОбновлениеИБ.Форма.Модуль(3685)}: Неверное имя атрибута".<br> Конфигурация типовая, без дописок. Раньше обновлялась без проблем. Тестирование базы ошибок не находит. Посмотрел в конфигураторе строку 3685 - это модуль, связанный с вычетом на детей. Пришлось вернуться на предыдущий релиз.<br> <br>В соседней организации, где мало сотрудников и нет вычетов на детей, обновление встало без ошибок."

Рисовод
читатель
офлайн
Дата регистрации: 26.12.2007
Сообщений: 25776
Пост №2
 
20.02.2013 17:27

"сам я пастернака не читал" еще, но, возможно, у вас коды детских вычетов "крякнули"?

Dixel
читатель
офлайн
Дата регистрации: 19.02.2013
Сообщений: 3
Пост №3
 
21.02.2013 11:55

Да нет, справочник кодов вычетов на месте.

Рисовод
читатель
офлайн
Дата регистрации: 26.12.2007
Сообщений: 25776
Пост №4
 
21.02.2013 12:35

попробую обновиться - отпишусь!

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3082
Пост №5
 
22.02.2013 15:07

"В вашей базе есть документ вида "НачисленияУдержанияСотрудника", в котором значение реквизита "Расчет" пустое. Наверное, это документ, который начали делать и бросили. Надо его найти и разобраться с ним.<br> <br><pre>Док = СоздатьОбъект("Документ.НачисленияУдержанияСотрудника");<br>Док.ВыбратьДокументы();<br>Пока Док.ПолучитьДокумент()=1 Цикл<br> Если глТипВидЗначения(Док.Расчет)="ВидРасчета" Тогда<br>       Если ПустоеЗначение(Док.Расчет)=1 Тогда<br>             Сообщить(Док.ТекущийДокумент());<br>       КонецЕсли;<br> КонецЕсли;<br>КонецЦикла; </pre>"

nailgy
читатель
офлайн
Дата регистрации: 25.02.2013
Сообщений: 1
Пост №6
 
25.02.2013 10:51

У меня сложилась аналогичная ситуация при обновлении релиза с 331 на 332. Я удалила непроведенные документы и все ок!<br>Удачи.

Dixel
читатель
офлайн
Дата регистрации: 19.02.2013
Сообщений: 3
Пост №7
 
26.02.2013 15:11

ОГРОМНАЯ Вам благодарность! С помощью этого кода обнаружил два проблемных документа. Действительно, начали делать и бросили, причём один из них даже не был помечен на удаление. Удалил оба - и обновление поставилось.<br> <br>Благодарю всех за участие, проблема решена.

Незабудка_525
читатель
офлайн
Дата регистрации: 06.02.2012
Сообщений: 32
Пост №8
 
27.02.2013 10:46

мнек как раз вовремя -буду своих обновлять на 332

Рисовод
читатель
офлайн
Дата регистрации: 26.12.2007
Сообщений: 25776
Пост №9
 
27.02.2013 12:10

я не тороплюсь пока с обновлением.

BigBuh
читатель
офлайн
Дата регистрации: 16.02.2005
Сообщений: 2
Пост №10
 
03.04.2013 08:48

"Перед командой, которая "валится", вставила для проверки 3 команды - и всё прошло:<br> <br>Если ПустоеЗначение(Док.Расчет)=1 Тогда<br>       Продолжить;<br>КонецЕсли;"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С