Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

Ошибка обновления ЗиК 7.70.332

Dixel
Пост №1
Dixel
читатель
офлайн
Дата регистрации: 19.02.2013
Сообщений: 3
Пост №1
 
20.02.2013 16:58

"После обновления ЗиК с релиза 331 на 332 программа при запуске пишет об ошибке:
"Выполняется обновление информационной базы.
Расчет = ВидРасчета.ПолучитьАтрибут(Док.Расчет.Код);
{Обработка.ОбновлениеИБ.Форма.Модуль(3685)}: Неверное имя атрибута".
Конфигурация типовая, без дописок. Раньше обновлялась без проблем. Тестирование базы ошибок не находит. Посмотрел в конфигураторе строку 3685 - это модуль, связанный с вычетом на детей. Пришлось вернуться на предыдущий релиз.

В соседней организации, где мало сотрудников и нет вычетов на детей, обновление встало без ошибок."

Рисовод
Пост №2
Рисовод
активный пользователь
офлайн
Дата регистрации: 26.12.2007
Сообщений: 24770
Пост №2
 
20.02.2013 17:27

"сам я пастернака не читал" еще, но, возможно, у вас коды детских вычетов "крякнули"?

Dixel
Пост №3
Dixel
читатель
офлайн
Дата регистрации: 19.02.2013
Сообщений: 3
Пост №3
 
21.02.2013 11:55

Да нет, справочник кодов вычетов на месте.

Рисовод
Пост №4
Рисовод
активный пользователь
офлайн
Дата регистрации: 26.12.2007
Сообщений: 24770
Пост №4
 
21.02.2013 12:35

попробую обновиться - отпишусь!

Thorvardr
Пост №5
Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №5
 
22.02.2013 15:07

"В вашей базе есть документ вида "НачисленияУдержанияСотрудника", в котором значение реквизита "Расчет" пустое. Наверное, это документ, который начали делать и бросили. Надо его найти и разобраться с ним.

Док = СоздатьОбъект("Документ.НачисленияУдержанияСотрудника");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент()=1 Цикл
Если глТипВидЗначения(Док.Расчет)="ВидРасчета" Тогда
       Если ПустоеЗначение(Док.Расчет)=1 Тогда
             Сообщить(Док.ТекущийДокумент());
       КонецЕсли;
КонецЕсли;
КонецЦикла;
"

nailgy
Пост №6
nailgy
читатель
офлайн
Дата регистрации: 25.02.2013
Сообщений: 1
Пост №6
 
25.02.2013 10:51

У меня сложилась аналогичная ситуация при обновлении релиза с 331 на 332. Я удалила непроведенные документы и все ок!
Удачи.

Dixel
Пост №7
Dixel
читатель
офлайн
Дата регистрации: 19.02.2013
Сообщений: 3
Пост №7
 
26.02.2013 15:11

ОГРОМНАЯ Вам благодарность! С помощью этого кода обнаружил два проблемных документа. Действительно, начали делать и бросили, причём один из них даже не был помечен на удаление. Удалил оба - и обновление поставилось.

Благодарю всех за участие, проблема решена.

Незабудка_525
Пост №8
Незабудка_525
читатель
офлайн
Дата регистрации: 06.02.2012
Сообщений: 32
Пост №8
 
27.02.2013 10:46

мнек как раз вовремя -буду своих обновлять на 332

Рисовод
Пост №9
Рисовод
активный пользователь
офлайн
Дата регистрации: 26.12.2007
Сообщений: 24770
Пост №9
 
27.02.2013 12:10

я не тороплюсь пока с обновлением.

BigBuh
Пост №10
BigBuh
читатель
офлайн
Дата регистрации: 16.02.2005
Сообщений: 2
Пост №10
 
03.04.2013 08:48

"Перед командой, которая "валится", вставила для проверки 3 команды - и всё прошло:

Если ПустоеЗначение(Док.Расчет)=1 Тогда
       Продолжить;
КонецЕсли;"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.